View Full Version : Is Setting up wireless for PC-BSD the Same Wit FreeBSD?

09-26-2006, 01:44 PM
Can anyone help me, how to install driver in freebsd OS??

Im using a intel(R) PRO/Wireless 2200BG network....

how do i start from and what im gonna do?

I need a full descriptions of command from the login root, im still new (Noob) to freebsd, hehehe

pls2 reply asap and help me, :(

09-26-2006, 02:59 PM

I've seen that this card is also supported by the default iwi driver.

09-26-2006, 03:04 PM
also read:
http://www.freebsd.org/doc/en_US.ISO885 ... eless.html (http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/network-wireless.html)

09-26-2006, 09:11 PM
Setup is the same as on FreeBSD, the dev's have not hacked the internals really.

09-27-2006, 02:42 AM
IWI(4) FreeBSD Kernel Interfaces Manual IWI(4)

iwi -- Intel PRO/Wireless 2200BG/2225BG/2915ABG IEEE 802.11 driver

To compile this driver into the kernel, place the following lines in your
kernel configuration file:

device iwi
device pci
device wlan

Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):


The iwi driver provides support for Intel PRO/Wireless 2200BG/2915ABG
MiniPCI and 2225BG PCI network adapters.

By default, the iwi driver configures the adapter for BSS operation (aka
infrastructure mode). This mode requires the use of an access point.

For more information on configuring this device, see ifconfig(8).

This driver requires firmware to be loaded before it will work. You need
to obtain iwicontrol(8) from the IWI web page listed below to accomplish
loading the firmware before ifconfig(8) will work.

Join an existing BSS network (i.e., connect to an access point):

ifconfig iwi0 inet netmask 0xffffff00

Join a specific BSS network with network name ``my_net'':

ifconfig iwi0 inet netmask 0xffffff00 ssid my_net

Join a specific BSS network with 64-bit WEP encryption:

ifconfig iwi0 inet netmask 0xffffff00 ssid my_net \
wepmode on wepkey 0x1234567890

Join a specific BSS network with 128-bit WEP encryption:

ifconfig iwi0 inet netmask 0xffffff00 ssid my_net \
wepmode on wepkey 0x01020304050607080910111213

iwi%d: device timeout The driver will reset the hardware. This should
not happen.

iwi%d: Please load firmware The required firmware has not been loaded
into the card, and therefore the card cannot operate. Load the firmware
with iwicontrol(8) before proceeding.

an(4), ath(4), ipw(4), pci(4), wi(4), wlan(4), ifconfig(8),
iwicontrol(8), wicontrol(8)

The IWI Web Page, http://damien.bergamini.free.fr/ipw/.

The iwi driver was written by Damien Bergamini <damien@FreeBSD.org>.

FreeBSD 6.1 July 16, 2005 FreeBSD 6.1
Following the directions is all you should need.

10-15-2006, 12:59 AM
I went to the link provided by Dragnlord http://damien.bergamini.free.fr/ipw/ and then to the Freebsd documentation. at here:
and ran into trouble at this step below:

# iwicontrol -i iwi0 -d /usr/local/libdata/if_iwi -m bss

I believe that this is erroneous as I could not even locate if_iwi on my harddrive, let alone in this directory. Instead I found a series of iwi-xxx.fw files including iwi-bss.fw (I am now on a different computer and did not note the directory...sorry). At any rate, I tried the iwi-bss.fw with the above command and it sort of worked.
I could see my device but that was about all. I tried prepping it for WPA as per the config file and instructions further on in the document - but again no luck. It did not like my ssid or my WPA key.

Has anyone on this list actually got this 2200bg chipset to work on PCBSD, particularily with an IBM R51 Thinkpad.
BTW, I setup PCBSD on this laptop several months ago and it is great except for the wireless. Today at least I got close but any extra tips would be most welcome.


01-13-2007, 06:29 PM
Hate reviving an old dead thread, but...

I too am having trouble getting my wireless 2915ABG to work. I am using PC-BSD 1.3.01.

Let me start by prefixing the following with:

A.) I'm a BSD "virgin" -- so please, be easy.
B.) I'm not entirely sure as to all of the steps I've taken so far as I've been working on this issue for a few days. I tried my best to resolve the issue before crying for help.


For a long time, the "iwicontrol" command continued returning: "command not found" and my wireless card was not seen by PC-BSD... I have managed to resolve both of these issues (although, admittedly I don't know how) -- so SOME progress has been made.

Here is where I currently am:


%iwicontrol iwi0 -r
Radio is ON


%ifconfig iwi0
iwi0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> mtu 1500
inet6 fe80::213:blah:blah:blah%iwi0 prefixlen 64 scopied 0x5
ether 00:blah:blah:blah:blah:blah
media: IEEE 802.11 Wireless Ethernet autoselect
status: no carrier
ssid :: channel 1
authmode OPEN privacy OFF txpowmax 100 protmode CTS


%iwicontrol -i iwi0 -d /usr/local/libdata/if_iwi -m bss
iwicontrol: /usr/local/libdata/if_iwi/iwi-boot.fw: No such file or directory

Notice that this particular error: "No such file or directory" appears no matter what path I specify after the "iwicontrol -i iwi0 -d" command, and I've tried several paths listed in various guides and forum threads I found with the help of Google.

Also, before I headed to bed last night -- I "THOUGHT" that when I was issuing the ifconfig command I continued to see an error about "Firmware cannot be loaded" or "Please load Firmware" but I do not seem to be able to recreate that message this morning.

In any event, this is where I currently stand. I'm getting a little discouraged and frustrated and would be extremely thankful for any assistance. I'm more than willing to help YOU help ME; so if there is any other information I can provide to help reach a resolution, please do not hesitate to ask.


Thanks in advance!


I remembered just the command that was talking about loading the firmware after I made my post, so here goes (just in case it helps):

%dmesg | grep iwi
iwi0: <Intel(R) PRO/Wireless 2915ABG> mem 0xdfcff000-0xdfcfffff irq 17 at device 3.0 on pci2
iwi0: Ethernet address: 00:13:blah:blah:blah:blah
iwi0: Please load firmware

Although I don't know what I'm talking about, I think my problem is this combination of "No such file or directory" and "Please load firmware" -- unfortunately I have NO IDEA what to do about it.

Thanks again!

01-13-2007, 06:57 PM
I can't help you much with your problem but someone in these forums will be along at sometime today to respond, of that I am pretty sure. In the mean time open a konsole/console and touch /usr/local/libdata/if_iwi/iwi-boot.fw

That will create and empty file of the one that is missing. That may be all it takes to relieve that error or it maybe not, it may be looking for some data in that file but it wont hurt to try as you can always rm it later.

01-13-2007, 07:04 PM
Thanks... I'll give it a try, and report back.

On a side note: I hope I detailed my issue well enough -- I am a Technical Writer by trade, and if I wind up enjoying PC-BSD as much as I think I'm going to -- I wouldn't mind volunteering my talents to help with some documentation for the project.


touch /usr/local/libdata/if_iwi/iwi-boot.fw also generated the "No such file or directory" message.

01-13-2007, 07:27 PM
i don't know if this (http://leaf.dragonflybsd.org/mailarchive/users/2006-04/msg00078.html) will help but it's a thread from Dragonfly BSD on your same problem....or better yet, their wiki on installing it (http://wiki.dragonflybsd.org/index.cgi/HowtoSetUpIpw2200)

Edit: Even better, a BSD guide (http://damien.bergamini.free.fr/ipw/iwi-freebsd.html)

01-13-2007, 07:56 PM
I started with the "Even better BSD guide" - it wasn't much help at all.

Now, using the second dragonfly link provided I can now run the command:

%iiwicontrol iwi0 -d /usr/libdata/if_iwi

I don't receive the "No such file or directory" error any more (having downloaded, untarred, and renamed the 2.3 TGZ) so I thought I was in business, but...

When I search for wireless networks, mine is still not found (and I'm sitting less than 2 feet from the access point) and running:

% dmesg | grep iwi

still returns

iwi0: Please load firmware


01-13-2007, 08:06 PM
Maybe this may help (http://www.linuxquestions.org/questions/showthread.php?t=452480), it's a post on another forum from a PC-BSD user that finally got it to work...

01-13-2007, 08:16 PM
That's a no go. I came across that thread last night. He and I tried all the same stuff, but our end results were different.

If I can figure out how to COMPLETELY reverse/uninstall what I've done so far, maybe somebody could help me from the beginning more easily than trying to figure out where I went askew. What do ya think?


I'll check back for replies this evening, I have a road trip to take.

Thanks for all of your help thus far.

01-13-2007, 08:52 PM
Road trip postponed...

In my attempts to "backtrack" I did a decent enough job to go far enough back that "iwicontrol" is again not a valid command... yet strangely it is installed and the card is still recognized.

Bah... installation of PC-BSD was pretty quick; I think I'll wipe the current install away and start with a clean canvas.


Alright, here goes everything I've done starting from a fresh installation of PC-BSD.

Step 1 was to confirm that my wireless card was not "seen" by PC-BSD from the start.

%su -
pcbsd-9191# ifconfig
inet6 fe80::212:3fff:fe23:90a5%bge0 prefixlen 64 scopeid 0x1
ether 00:12:3f:23:90:a5
media: Ethernet autoselect (none)
status: no carrier
pflog0: flags=0<> mtu 33208
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
inet6 ::1 prefixlen 128
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x3
inet netmask 0xff000000
pfsync0: flags=0<> mtu 2020
Check! No instance of my wireless card.

I then decided to update my ports tree (I think that's what you guys call it anyway) by clicking Start -> Settings -> System Administration -> PC-BSD Systems Manager -> Tasks -> Fetch Ports. After the ports were retrieved I did the following based upon the instructions at http://damien.bergamini.free.fr/ipw/iwi-freebsd.html:

pcbsd-9191# cd /usr/ports/net/iwi-firmware/
pcbsd-9191# make install clean
I was met with what looked like an X screen asking me which of the two packages I should grab; I selected the default option and chose OK.
=> ipw2200-fw-2.4.tgz doesn't seem to exist in /usr/ports/distfiles/.
=> Attempting to fetch from ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/local-distfiles/flz/ipw/.
ipw2200-fw-2.4.tgz 100% of 264 kB 223 kBps
=> iwi-freebsd-1.3.4.tgz doesn't seem to exist in /usr/ports/distfiles/.
=> Attempting to fetch from ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/local-distfiles/flz/ipw/.
iwi-freebsd-1.3.4.tgz 100% of 21 kB 45 kBps
===> Extracting for iwi-firmware-2.4_7
=> MD5 Checksum OK for ipw2200-fw-2.4.tgz.
=> SHA256 Checksum OK for ipw2200-fw-2.4.tgz.
=> MD5 Checksum OK for iwi-freebsd-1.3.4.tgz.
=> SHA256 Checksum OK for iwi-freebsd-1.3.4.tgz.
===> Patching for iwi-firmware-2.4_7
===> Configuring for iwi-firmware-2.4_7
===> Building for iwi-firmware-2.4_7
cd /usr/ports/net/iwi-firmware/work/iwi-freebsd-1.3.4/src/usr.sbin/iwicontrol/; make all
Warning: Object directory not changed from original /usr/ports/net/iwi-firmware/work/iwi-freebsd-1.3.4/src/usr.sbin/iwicontrol
cc -O2 -fno-strict-aliasing -pipe -c iwicontrol.c
cc -O2 -fno-strict-aliasing -pipe -o iwicontrol iwicontrol.o
gzip -cn iwicontrol.8 > iwicontrol.8.gz
===> Installing for iwi-firmware-2.4_7
===> Generating temporary packing list
===> Checking if net/iwi-firmware already installed
/bin/sh /usr/ports/net/iwi-firmware/../ipw-firmware/pkg-req iwi-firmware INSTALL
Next, I got to feast on what looked like about a 4,000 page license agreement. After I agreed to the conditions I got the following:
Do you agree with these terms [y/N] ? y
cd /usr/ports/net/iwi-firmware/work/iwi-freebsd-1.3.4/src/usr.sbin/iwicontrol/; make install BINDIR="/usr/sbin" MANDIR="/usr/share/man/man" KMODDIR="/boot/modules" SHELL=/bin/sh PORTOBJFORMAT=elf NO_LINT=YES TARGETDIR=/usr DESTDIR= PREFIX=/usr LOCALBASE=/usr/local X11BASE=/usr/X11R6 MOTIFLIB="-L/usr/X11R6/lib -lXm -lXp" LIBDIR="/usr/lib" CFLAGS="-O2 -fno-strict-aliasing -pipe " CXXFLAGS="-O2 -fno-strict-aliasing -pipe" MANPREFIX="/usr/share" BSD_INSTALL_PROGRAM="install -s -o root -g wheel -m 555" BSD_INSTALL_SCRIPT="install -o root -g wheel -m 555" BSD_INSTALL_DATA="install -o root -g wheel -m 444" BSD_INSTALL_MAN="install -o root -g wheel -m 444"
install -s -o root -g wheel -m 555 iwicontrol /usr/sbin
install -o root -g wheel -m 444 iwicontrol.8.gz /usr/share/man/man8
/bin/mkdir -p /boot/firmware
install -o root -g wheel -m 444 /usr/ports/net/iwi-firmware/work/LICENSE /boot/firmware/LICENSE.iwi
install -o root -g wheel -m 444 /usr/ports/net/iwi-firmware/work/ipw-2.4-boot.fw /boot/firmware/iwi-boot.fw
install -o root -g wheel -m 444 /usr/ports/net/iwi-firmware/work/ipw-2.4-bss.fw /boot/firmware/iwi-bss.fw
install -o root -g wheel -m 444 /usr/ports/net/iwi-firmware/work/ipw-2.4-bss_ucode.fw /boot/firmware/iwi-ucode-bss.fw
install -o root -g wheel -m 444 /usr/ports/net/iwi-firmware/work/ipw-2.4-ibss.fw /boot/firmware/iwi-ibss.fw
install -o root -g wheel -m 444 /usr/ports/net/iwi-firmware/work/ipw-2.4-ibss_ucode.fw /boot/firmware/iwi-ucode-ibss.fw
install -o root -g wheel -m 444 /usr/ports/net/iwi-firmware/work/ipw-2.4-sniffer.fw /boot/firmware/iwi-sniffer.fw
install -o root -g wheel -m 444 /usr/ports/net/iwi-firmware/work/ipw-2.4-sniffer_ucode.fw /boot/firmware/iwi-ucode-sniffer.fw
This port has installed following files in /boot/firmware:

- LICENSE.iwi : License terms,
- iwi-boot.fw : Boot mode firmware,
- iwi-bss.fw : BSS mode firmware,
- iwi-ucode-bss.fw : BSS mode micro-code,
- iwi-ibss.fw : IBSS mode firmware,
- iwi-ucode-ibss.fw : IBSS mode micro-code,
- iwi-sniffer.fw : Sniffer mode firmware,
- iwi-ucode-sniffer.fw : Sniffer mode micro-code.

Ensure you've read license terms carefully before you use this

You must choose the correct mode depending on how you want to
use your adapter.

For instance, to download firmware for BSS mode:

# iwicontrol -i iwi0 -d /boot/firmware -m bss

The port has installed a startup script (iwi.sh). Add these lines
to /etc/rc.conf to use it :

- iwi_enable (bool) : defaults to "NO", set it to "YES" to
use the startup script.
- iwi_interfaces (str) : defaults to "iwi0", override it to
change to interface names list (optional).
- iwi_mode_<iface> (str) : defaults to "bss", possible values
are bss, ibss and sniffer (optional).
===> Installing early rc.d startup script(s)
===> Registering installation for iwi-firmware-2.4_7
===> Cleaning for iwi-firmware-2.4_7

Following the next step in the IPW guide I linked to earlier I used kldload and grep to see if the card was now showing up.
pcbsd-9191# kldload -v if_iwi
Loaded if_iwi, id=9
pcbsd-9191# dmesg | grep iwi
iwi0: <Intel(R) PRO/Wireless 2915ABG> mem 0xdfcff000-0xdfcfffff irq 17 at device 3.0 on pci2
iwi0: Ethernet address: 00:13:ce:30:b5:c7
To settle my own curiosity I decided to see if my ifconfig returned different results than earlier too. It did, it now shows the wireless card that was missing prior.
inet6 fe80::212:3fff:fe23:90a5%bge0 prefixlen 64 scopeid 0x1
inet netmask 0xffffff00 broadcast
ether 00:12:3f:23:90:a5
media: Ethernet autoselect (100baseTX <full-duplex>)
status: active
pflog0: flags=0<> mtu 33208
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
inet6 ::1 prefixlen 128
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x3
inet netmask 0xff000000
pfsync0: flags=0<> mtu 2020
iwi0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> mtu 1500
ether 00:13:ce:30:b5:c7
media: IEEE 802.11 Wireless Ethernet autoselect
status: no carrier
ssid "" channel 1
authmode OPEN privacy OFF txpowmax 100 protmode CTS

Feeling more reassured, I decided to try the iwicontrol command now using the /boot/ path rather than the one specified on the driver's site guide. I learned my lesson regarding that earlier. This time I saw where ports copied the files to; I missed that the first time around. Anyway, here's what happened:

pcbsd-9191# iwicontrol -i iwi0 -d /boot/firmware -m bss
iwicontrol: Command not found.

Somehow I made it past this part earlier, but I have no clue what I did. So, this time before being so adventurous I think I'll wait and see if any advice can be tossed out at this point. Let me know where I've went wrong.

Thank you.

01-15-2007, 04:11 PM
I'm open to suggestions for other resources if the active community here is simply too small at this time to have encountered much of this. Naturally, I would have sought the guidance from the fine folks at the official FreeBSD forum, but since there is no official FreeBSD forum I assume that would be a pretty tough trick.

So, if we aren't armed with answers to get this crazy 2915ABG up and running, feel free to link me to a list of other resources where I may find success. I'd really like to start learning more about BSD so that I can jump in and start helping others.

On that note... does anyone know if the forum at bsdforums.org has a large following? Might that be the ticket?

01-15-2007, 05:20 PM
last I was at bsdforums.org it was pretty full, made one of the MS developers network forums I dropped by look small ^_^

01-16-2007, 06:06 PM
I took the advice and posted a request for help there. Now I'm sitting back with fingers crossed.

01-27-2007, 10:28 AM
Hi people,

I have a problem installing my intel 3945ABG card. I have check the forum entries on this subject but non of them helped out. I am completly new to BSD though I have linux experience. But enough smalltalk, the problem:

I am working with a Toshiba Satellite A100-159 with internal intel 3945ABG wireless card. I have done the following to install the drivers:

# portsnap fetch extract
#pkg_add -r portupgrade
#portinstall ipw-firmware

Then I added the rule: if_iwi_load="YES" tot /boot/loader.conf and I did a reboot.

One would expect to see the iwi0 after a ifconfig or to see any mentioning of iwi after a dmesg | grep iwi but I got nothing.

I also did

#kldload -v if_iwi
kldload: can't load if_iwi: File exists

Which suggests that the module is loaded... I really don't know what step to take next, hope anyone can help me out, I don't want to step back to linux after my first BSD try.


01-27-2007, 06:23 PM
There has been a long, ongoing discussion about this on the FreeBSD Hardware lists, too long to post here. They are testing a newer driver. Best suggestion is to read about it here (http://freebsd.rambler.ru/srch?words=3945ABG&sort=6)

Here is a link to the driver http://www.clearchain.com/~benjsc/download/20070107-wpi-freebsd.tar.gz

01-28-2007, 08:52 AM
Thanks for the reply, I'm back to fedora for the moment. I will give it a try as soon as I have a bit of time. Maybe I can contribute to the discussion.