View Full Version : SOLVED: PC-BSD won't detect my WD Raptor 74GB Hard Drives

06-30-2006, 05:19 AM
I've searched through a few posts and still didn't find an answer, so hopefully u guys can help. I have two Hard Drives, both WD 74GB raptors. I've tried installing PC-BSD with both of them in at the same time, then one at a time, with no luck. Here comes the weird part, this happens with every other version of BSD or Linux ( ubuntu, suse, fedora). The only thing that will see these hard drives is Windows (ive installed windows just to make sure i can intall something on them). Even stranger, ive installed SUSE on these before, about 6 months ago. My thoughts are that the proper drivers aren't present, but im somewhat of a newbie.

Any Help would be greatly appreciated.

06-30-2006, 08:51 AM
You should try(if this isn't a hardware failure)some sort of live-cds for formating,repairing,salvaging those disks(and mbr).
I use UBCD:

or frenzy

if you need a more "tehnical" and BSD-ish aproach.And if it works try again installing PCBSD.

06-30-2006, 02:23 PM
I have 3 of these Raptors HDDs. They are SATA, and each time they were's detected was because of a cheap SATA controller, for instance with an Asus K8S-MX mobo. What mobo do you have? They are working fine with my A8V and my K8V-X mobos here.

06-30-2006, 06:22 PM
I've run the ultimate bootcd as well as a couple others, and up until recently, they were working fine. Now, for example, when i use Hirems boot cd and log into partition magic, it gives me an error message saying that there is some type of failure. Again, these were working fine before (up until about a month ago i believe). I have run multiple tests on the hard drives, and they both pass. As far as the motherboard goes...the box was originally a HP M7470 ATHLON 64 X2 4200+, i gutted it though and put it into a different case and put in the WD Raptors. The motherboard is an AmethystM-GL6E which is actually the MSI MS-7184 which MSI makes no mention of on their website. It is most like the MS-7093 (RS-480).
Do you think because i switched the internals to another case that may have changed something? Im fresh out of ideas i have been working on this for countless days.
Any help is greatly appreciated

06-30-2006, 06:56 PM
Have you cleared the MBR?

Boot with a Win98 boot disk (you can find an ISO in Google if you don't have one) and

fdisk /mbr

That may help.

06-30-2006, 07:06 PM
i have another 300gb seagate that i run windows off of ( which im using now) i simply unplug the wd raptor and plug this one in when i want windows. if i clear the MBR will windows still boot up when i plug this hard drive in?

06-30-2006, 07:24 PM
i have another 300gb seagate that i run windows off of ( which im using now) i simply unplug the wd raptor and plug this one in when i want windows. if i clear the MBR will windows still boot up when i plug this hard drive in?

Yes...if it's on a separate HD...each HD has a MBR (actually, they have two of them)...if you clear the MBR on the HD that doesn't have windows it wont affect the one that does have windows.

06-30-2006, 08:31 PM
i used caldera Dr-Dos and tried fdisk /mbr but it doesn't recognize fdisk. So i used my win xp disk and used the recovery console and typed in fixmbr, and i also did a chkdsk /r for the hell of it. So, did that solve my problem? no. I also kept my 300gb seagate in and tried to install pcbsd (and suse and freebsd just in case) on it, and guess what happened, it didn't detect that one either. My guess is it has something to do with sata drivers ( all 3 my hard drives are sata) any way to invoke it to search for sata hdds? im getting desperate at this point, i just want a stable operating system!

06-30-2006, 09:38 PM
okay...i used a different dos app and did fdisk /mbr, it didn't give me any messages but i booted into windows, it found my raptor which it didn't do previously when i had my seagate in also. windows did its thing with installing the hard drive, i restarted and put in the pc bsd cd, loaded, it found both hard drives, i installed it on the raptor, all is well (now i need to figure out how to get my wireless to work though.)
Thanx a ton!

06-30-2006, 09:51 PM
Glad to help.

For those that may have this problem and don't have a Win98 boot disk here is a link to an ISO that will write to floppy, only problem is that it's a windows exe. Hope this helps: