View Full Version : AppCafe missing meta-files. <Solved>

11-29-2011, 07:57 PM
I've finally managed to use the upgrade manager for amd64/9.0-Rc2 from 9.0-Rc1. It seems the meta-files for appcafe didn't upgrade properly.

I'm left with the appcafe not being able to even see which programs are available to me.

What I need to know is how to adjust appcafe to reload or re-download the meta-files that will leave me with an operational appcafe.

I'll google this and see if I can find any way to resolve this. In the meantime I'll sure take suggestions if you have them.

11-29-2011, 08:07 PM
The meta-files should be updated every 24 hours automatically if you
have a working net connection. Can you paste the output of "ls -al

Also try this as root:

# /usr/local/etc/rc.d/pbid restart

Any errors?

11-29-2011, 08:13 PM
ls -al /var/db/pbi/index

drwxr-xr-x 2 root wheel 512 Nov 21 12:31 .
drwxr-xr-x 9 root wheel 512 Nov 28 16:17 ..
-rw-r--r-- 1 root wheel 185996 Nov 28 04:15 dd3920955c2fcf9bcc66b20dc0d89354-index
-rw-r--r-- 1 root wheel 11 Nov 28 21:01 dd3920955c2fcf9bcc66b20dc0d89354-index.time

I get no errors when I restart the pbid. It stops and starts smoothly.

Firefox from ports works fine as does thunderbird so I know the internet connection is working.

This is the error message I'm getting when I start appcafe..

Missing meta-files for RepoID: 001. This is normally due to the internet connection being offline or mis-configured.

11-29-2011, 08:34 PM
Looks like you have a partial download of the index files. Do this:

# rm /var/db/pbi/index/*
# /usr/local/etc/rc.d/pbid restart
# tail -f /var/log/pbid.log

You should see in the log file that it is downloading new meta-data.
Once its finished you can try opening appcafe again.

11-29-2011, 10:51 PM
This thread needs to be marked as solved now. Thanks for your help Kris.

02-01-2012, 03:08 PM
I have the same issue by the fix did not work for me. Any further thoughts?
Update works fine so I know my connection to PC-BSD infrastructure is good.
Nice O/S btw.