View Full Version : Panic message

09-07-2010, 03:37 AM
I recently decided to experiment with learning a little about BSD and so downloaded an install disc for PC-BSD 8.1. I am using an HP Pavilion DV6 laptop with an Intel Core 2 Duo processor, and so downloaded and burned a dvd install disc for amd64. However, upon booting I immediately get a panic message which reports "corrupt memlist1" and then forces a reboot. I also tried an install disc for x86, just in case, and it resulted in the same failure. I have searched online and can find nothing about this specifically.

I am wondering what might prompt this result, and whether there is anything I can do to move forward in possibly installing PC-BSD? Many thanks in advance for any help.

09-07-2010, 04:19 AM
Problem with allocating memory. Either you have bad memory stick or this is a real bug...which the latter is unlikely. I suggest you run some mem tests. Then again, could be BIOS and need some update. OEM BIOS is always troublesome.

This panic message comes from line 181 of src/lib/libstand/zalloc.c

for (pmn = &mp->mp_First; (mn = *pmn) != NULL; pmn = &mn->mr_Next) {
* If area between last node and current node
* - check range
* - check merge with next area
* - check merge with previous area
if ((char *)ptr <= (char *)mn) {
* range check
if ((char *)ptr + bytes > (char *)mn)
panic("zfree(%p,%d): corrupt memlist1",ptr, bytes);

* merge against next area or create independant area

if ((char *)ptr + bytes == (char *)mn) {
((MemNode *)ptr)->mr_Next = mn->mr_Next;
((MemNode *)ptr)->mr_Bytes= bytes + mn->mr_Bytes;
} else {
((MemNode *)ptr)->mr_Next = mn;
((MemNode *)ptr)->mr_Bytes= bytes;
*pmn = mn = (MemNode *)ptr;

* merge against previous area (if there is a previous
* area).

if (pmn != &mp->mp_First) {
if ((char*)pmn + ((MemNode*)pmn)->mr_Bytes == (char*)ptr) {
((MemNode *)pmn)->mr_Next = mn->mr_Next;
((MemNode *)pmn)->mr_Bytes += mn->mr_Bytes;
mn = (MemNode *)pmn;
if ((char *)ptr < (char *)mn + mn->mr_Bytes)
panic("zfree(%p,%d): corrupt memlist2", ptr, bytes);

09-07-2010, 07:03 PM
Thanks for the help.

I went to HP's site and downloaded the newest BIOS update and installed it, and then downloaded memtest86 and ran that. It passed and reported no errors. However, when I tried the install disc again it still reports a panic, though this time it was not "corrupt memlist1" but "wild pointer." I then downloaded the FreeBSD install disc and it also failed with a panic, though it did get a little further. After listing available memory it reported "constant not found" and then "panic: Assertion failed: (FALSE), function ficlCompile SoftCore, file softcore.c line 428".

09-07-2010, 07:06 PM
Is there any nifty BIOS option that is enabled like advance power management? This is thoroughly a hardware problem.

09-07-2010, 07:55 PM
This BIOS, which is Insyde, is really spartan, and under configuration only has Language, LAN Power Savings, Fan always on, and boot sequence. I toggled the LAN Power Savings setting from enabled to disabled and tried running the discs both ways, and nothing changed. Still reports a panic and reboots, or just flashes and reboots instantly.

09-07-2010, 08:06 PM
Well, then that's that. BIOS problem. I'm sure Microsoft works on it. Got to give them props for that. =P

I'd fill out some bug report to the FreeBSD people though so that they are aware of the problem.

09-07-2010, 08:33 PM
I will certainly do that. And thanks again for the help.

11-22-2011, 06:43 PM
By any chance has anyone resolved this old problem? I'm now encountering an almost identical scenario. Laptop is an HP Pavilion dv8000 series (8210us, if memory serves). Tried to load the Live DVD (9.0 rc1/64bit) to test functionality and got the following error:

BTX Loader: Panic: zfree (0x77697000, 20480): corrupt memlist2

I really want to return to using PC-BSD (been several years since I used it), but need to make sure it'll run before overwriting my existing OS.

11-22-2011, 07:27 PM
That kind of error should be reported to the FreeBSD team:

http://www.freebsd.org/send-pr.html ('http://www.freebsd.org/send-pr.html')

11-23-2011, 12:33 AM
Sadly, I very much doubt that solving a hardware problem for a five year old laptop is going to be high on anyone's to-do list but mine (methinks I'd be waiting a very long time for a response, and as I said, I'm very eager to use PC-BSD again). My goal here is mainly to discover whether this existing problem, that I now share, was ever resolved.

11-23-2011, 02:45 PM
That kind of error usually does interest the developers, because it can
occur on new hardware as well. I assume you tried downloading a 9.0
image and testing if it fails there?

11-23-2011, 07:51 PM
I used: PCBSD9.0-RC1-x64-DVD-live.iso, but didn't bother checking the MD5, since the file came down 100%. Also, the contents of the burned disc are perfectly readable. Still, I suppose it's a good idea to eliminate that possibility, but it looks like they've released RC2 now, and I can't find the MD5 for the RC1 iso (ftp for the older versions isn't working right now --connection is repeatedly refused). Here's the MD5 that the downloaded RC1 generates, if by chance you've got access to the correct info:


11-23-2011, 08:31 PM
Kris, it would be best to supply MD5 and SHA256 checksums in further announce emails. So they are distributed through more than one channel.

There is a Google cache hit for PCBSD9.0-RC1-x64-DVD-live.iso and 1636956502A43AA5E375797E9D3BC4BC.

11-24-2011, 12:33 AM
Wow, I had the weirdest experience. Grabbed the RC2 Live iso, checked and burned it, and tried to load it. Nada. Wouldn't even post (perpetual flashing cursor). So, out of curiosity, I tried putting the RC1 disc back in, just to see if it was the RC2 disc messing up, or if my laptop was choking. Intead of the previous error, it was now repeatedly rebooting after showing the initial loader text (same stuff I saw before, just prior to the error).

And here's where it gets interesting. I decided to hit ESC, which gives me the boot menu. In the BIOS I'm set for the usual CD/DVD-->HD boot priority, but on this menu it shows the HD. So I switch to the DVD drive, hit enter, and now it begins loading the OS. Crazy. Keep in mind, it was still trying to boot with the DVD before, or I'd never have seen loader info or error (it merely would have gone into Windows as per usual), but for some bizarre reason doing it this way got the ball rolling.

Anyhow, I got it RC1 to load, although it wouldn't load the sound driver or network card. Strangely enough, both of them appear to be supported (Broadcom 802.11 b/g WLAN [4318] & Conexant AC-Link Audio), so I'm not sure why they didn't load.

So maybe, just maybe this could work, but I'd sure like to know why RC2 wouldn't do anything.