Reply
 
Thread Tools Display Modes
  #1  
Old 02-26-2008, 08:54 AM
hank hank is offline
Junior Member
 
Join Date: Apr 2007
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Default Firewall issues with Limewire and KTorrent
I installed the latest Limewire and KTorrent PBIs on PC-BSD 1.4.1.2. I then went on to the Firewall GUI to allow incoming ports for these two programs. When I tried to use Limewire or KTorrent, the programs told me that the firewall blocked the necessary ports. Why? It seems that the firewall GUI didn't work. So, I tried editing the /etc/pf.inports file and added tcp and udp ports for Limewire and KTorrent:

# KTorrent
tcp: 55555
udp: 55555
# KTorrent DHT
tcp: 55556
udp: 55556
# Limewire
tcp: 41593
udp: 41593

It didn't work either. It used to work with PC-BSD 1.3.4. So, what should I do to make Limewire and KTorrent work? I think the PBI developers should add scripts to modify the default firewall configs automatically to make programs like these run after they are installed. That will make life a lot easier for the end users.
Reply With Quote
  #2  
Old 03-07-2008, 08:38 PM
hank hank is offline
Junior Member
 
Join Date: Apr 2007
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Firewall issues with Limewire and KTorrent
Can anyone help me with this problem? I have even tried disabling the firewall and firewall rules in /etc/rc.conf :

pf_rules_enable="NO"
pf_enable="NO"

However, Limewire and KTorrent still insisted that the firewall blocked the incoming connection. Maybe it's not the firewall, but those two programs that have some problems.
Reply With Quote
  #3  
Old 03-07-2008, 08:58 PM
antik antik is offline
Senior Member
 
Join Date: Jul 2005
Location: Estonia
Posts: 3,610
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Firewall issues with Limewire and KTorrent
Originally Posted by hank
Can anyone help me with this problem? I have even tried disabling the firewall and firewall rules in /etc/rc.conf :

pf_rules_enable="NO"
pf_enable="NO"

However, Limewire and KTorrent still insisted that the firewall blocked the incoming connection. Maybe it's not the firewall, but those two programs that have some problems.
Check for yourserf if firewall is working:

Code:
# pfctl -sa
__________________
"All parts should go together without forcing. Therefore, if you can't get them together again, there must be a reason. By all means, do not use a hammer." -- IBM maintenance manual, 1975
Reply With Quote
  #4  
Old 03-08-2008, 12:05 AM
hank hank is offline
Junior Member
 
Join Date: Apr 2007
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Firewall issues with Limewire and KTorrent
I tried the command and the result is:

Code:
FILTER RULES:
No queue in use

INFO:
Status: Disabled                                Debug: None
I guess the firewall has been disabled. I even tried nmap to scan for open ports. The strange thing is that even though the firewall has been disabled, almost all ports are closed except: 22, 445 and 139. Those are the original open ports in /etc/pf.inports. Even though 55555, 55556 and 41596 had been added to /etc/pf.inports, they are still reported as closed. What could be closing these ports? This is wierd.
Reply With Quote
  #5  
Old 03-09-2008, 10:04 PM
hank hank is offline
Junior Member
 
Join Date: Apr 2007
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Firewall issues with Limewire and KTorrent
Can anyone who has made KTorrent and Limewire work properly respond? Let me know how you got these programs to work. Did the programs work right after installation? I am not sure if it is my PC-BSD installation, PC-BSD bug or those programs that has been causing this problem. I plan to do a fresh PC-BSD reinstall as a last resort. But, before I do that I'd like to hear your experiences in using KTorrent and Limewire.
Reply With Quote
  #6  
Old 03-10-2008, 06:22 AM
Protagonist Protagonist is offline
Senior Member
 
Join Date: Jan 2007
Location: Central Oregon coast
Posts: 328
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to Protagonist
Default Re: Firewall issues with Limewire and KTorrent
Originally Posted by hank
Can anyone who has made KTorrent and Limewire work properly respond? Let me know how you got these programs to work. Did the programs work right after installation? I am not sure if it is my PC-BSD installation, PC-BSD bug or those programs that has been causing this problem. I plan to do a fresh PC-BSD reinstall as a last resort. But, before I do that I'd like to hear your experiences in using KTorrent and Limewire.
I use KTorrent to download OS distributions from time to time and have no problems with it. As I recall I installed it from the PBI and it worked out of the box, so to speak. I do not use Limewire so can't say anything about that.
__________________
--------------------------------------
Computing can be fun again
format C:\
There are alternatives
--------------------------------------
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot install nvidia, ktorrent from ports damatta General Questions 4 05-24-2007 04:53 AM


All times are GMT. The time now is 07:29 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Copyright 2005-2010, The PC-BSD Project. PC-BSD and the PC-BSD logo are registered trademarks of iXsystems.
All other content is freely available for sharing under the terms of the Creative Commons Attribution License.