Reply
 
Thread Tools Display Modes
  #1  
Old 08-01-2007, 12:11 AM
simonC simonC is offline
Junior Member
 
Join Date: Jul 2007
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default sshd setup
Does anybody know how to set-up sshd?

I was looking in the forum and following the instructions. So far, mine is not working. I just want to see if it works in my local home network first.

Here is my sshd_config
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~``
Port 22
Protocol 2
ListenAddress x.x.x.x <- Here I put the IP machine

# HostKey for protocol version 1
HostKey /etc/ssh/ssh_host_key
# HostKeys for protocol version 2
#HostKey /etc/ssh/ssh_host_dsa_key

# Lifetime and size of ephemeral version 1 server key
KeyRegenerationInterval 1h
ServerKeyBits 768

# Logging
#obsoletes QuietMode and FascistLogging
SyslogFacility AUTH
LogLevel INFO

# Authentication:

LoginGraceTime 2m
PermitRootLogin no
StrictModes yes

#RSAAuthentication yes
PubkeyAuthentication yes
AuthorizedKeysFile .ssh/authorized_keys

# For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
#RhostsRSAAuthentication no
# similar for protocol version 2
#HostbasedAuthentication no
# Change to yes if you don't trust ~/.ssh/known_hosts for
# RhostsRSAAuthentication and HostbasedAuthentication
#IgnoreUserKnownHosts no
# Don't read the user's ~/.rhosts and ~/.shosts files
#IgnoreRhosts yes

# Change to yes to enable built-in password authentication.
PasswordAuthentication yes
PermitEmptyPasswords no

# Change to no to disable PAM authentication
#ChallengeResponseAuthentication yes

# Kerberos options
#KerberosAuthentication no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes
#KerberosGetAFSToken no

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes

# Set this to 'no' to disable PAM authentication (via challenge-response)
# and session processing.
#UsePAM yes

#AllowTcpForwarding yes
#GatewayPorts no
#X11Forwarding yes
#X11DisplayOffset 10
#X11UseLocalhost yes
PrintMotd yes
#PrintLastLog yes
#TCPKeepAlive yes

#UseLogin no
#UsePrivilegeSeparation yes
#PermitUserEnvironment no
#Compression yes
#ClientAliveInterval 0
#ClientAliveCountMax 3
#UseDNS yes
#PidFile /var/run/sshd.pid
#MaxStartups 10

# no default banner path
#Banner /some/path
AllowUsers rvs

# override default of no subsystems
Subsystem sftp /usr/libexec/sftp-server
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~`

In rc.conf,
sshd_enable="YES"

In inetd.conf
ssh stream tcp nowait root /usr/sbin/sshd sshd -i -4
ssh stream tcp6 nowait root /usr/sbin/sshd sshd -i -6

I don't know what else I can do.

Any ideas?

Thanks in advance

Simon C
Reply With Quote
  #2  
Old 08-01-2007, 02:12 AM
flibbum flibbum is offline
Member
 
Join Date: Dec 2005
Location: wisconsin
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Default
Is sshd not running at all, or can you just not connect to it? I must have set it up on my wife's mac, since I ssh into it sometimes, but I would have to dig around to see what I did.
Reply With Quote
  #3  
Old 08-01-2007, 02:16 AM
simonC simonC is offline
Junior Member
 
Join Date: Jul 2007
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default
Not connect at all. I know that is working because I did ps, but I can't make it accept connections.
Reply With Quote
  #4  
Old 08-01-2007, 02:21 AM
flibbum flibbum is offline
Member
 
Join Date: Dec 2005
Location: wisconsin
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Default
Does it give any kind of error, or does it just time out or something? Also, I noticed you have Protocol 2 as the protocol, but have a key for protocol 1 listed. I'm not sure if that's the problem, but you might want to try Protocol 2,1 and see what happens.
Reply With Quote
  #5  
Old 08-01-2007, 09:59 AM
Solarin's Avatar
Solarin Solarin is offline
Super Moderator
 
Join Date: Jul 2005
Location: Birmingham, UK
Posts: 743
Thanks: 0
Thanked 0 Times in 0 Posts
Default
Are you running the firewall? If so, have you opened up port 22?
__________________
Tim McCormick
PC-BSD Lead Developer
tim at pcbsd.org
Reply With Quote
  #6  
Old 08-01-2007, 02:58 PM
simonC simonC is offline
Junior Member
 
Join Date: Jul 2007
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default
It is giving timeout. For firewall, I change the "in" keyword by "on" in port22.

Including, I disable firewall commented out the lines in rc.conf. Now that you mention firewall, commenting out the lines in rc.conf is the right way to disable it?
Reply With Quote
  #7  
Old 08-02-2007, 10:51 AM
putu putu is offline
Senior Member
 
Join Date: Mar 2007
Location: DENPASAR - BALI
Posts: 548
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via Yahoo to putu
Default
Are sure your network is fine ?

How do you connect to each other ?

Are you using switch hub ?

You better double check your connection :!:

Try to do ping commnd :wink:
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
So what gives with SSHD here ? supercobrajet Installing PC-BSD 2 04-05-2009 12:44 AM
Setup NAT and PF marc-r Installing PC-BSD 5 02-24-2007 01:10 PM
pc-bsd hangs at Starting sshd. detpenguin Startup Bug Reports (read-only) 7 12-24-2005 05:41 AM
eth setup gatttliff General Questions 2 11-20-2005 07:10 AM


All times are GMT. The time now is 12:56 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Copyright 2005-2010, The PC-BSD Project. PC-BSD and the PC-BSD logo are registered trademarks of iXsystems.
All other content is freely available for sharing under the terms of the Creative Commons Attribution License.