Reply
 
Thread Tools Display Modes
  #1  
Old 02-16-2007, 10:16 AM
logical logical is offline
Junior Member
 
Join Date: Feb 2007
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default how can i change my locale??(en_US.UTF-8 to ko_KR.UTF-8)
how can i change my locale at KDE?
base kde and kconsol..
i want to change everything locale to ko_KR.UTF-8...
but i don't know how to do it...
Reply With Quote
  #2  
Old 02-16-2007, 10:32 AM
Charles Charles is offline
Senior Member
 
Join Date: May 2005
Posts: 3,710
Thanks: 0
Thanked 0 Times in 0 Posts
Default
It should have been done automatically when you chose "Korean" during installation... I'll report the problem.
Reply With Quote
  #3  
Old 02-16-2007, 10:59 AM
logical logical is offline
Junior Member
 
Join Date: Feb 2007
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default
thanks Charles ....

It's not change..

first , when I install PC-BSD , i choice korean language..
but After system rebooting, i confirm locale at kconsol and k->menu->command line..

but locale is presented en_US.UTF-8..
It's not changed....
Reply With Quote
  #4  
Old 02-16-2007, 07:31 PM
Apatewna Apatewna is offline
Senior Member
 
Join Date: May 2006
Location: Greece
Posts: 1,142
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via ICQ to Apatewna Send a message via MSN to Apatewna Send a message via Yahoo to Apatewna
Default
Originally Posted by logical
thanks Charles ....

It's not change..

first , when I install PC-BSD , i choice korean language..
but After system rebooting, i confirm locale at kconsol and k->menu->command line..

but locale is presented en_US.UTF-8..
It's not changed....
See this first and then this

Charles, greek language selected during installation and had the same problem, no proper encoding settings in .cshrc or .login_conf
__________________
RTFM and STFW before anything bad happens

Please read and UNDERSTAND these pages before posting:
http://www.catb.org/~esr/faqs/smart-questions.html
http://en.wikipedia.org/wiki/Netiquette
Reply With Quote
  #5  
Old 02-17-2007, 04:45 AM
logical logical is offline
Junior Member
 
Join Date: Feb 2007
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default
thanks...Apatewna

it's very simple...

when I installed at korean language PC-BSD, the system default locale is en_US.UTF-8.

but I have to change in korean locale for writting korean word..

and so..
each user home directory have .login_conf file...
and i insert .login_conf at this...

Code:
me:\
       :charset=eucKR:\
       :lang=ko_KR.eucKR
and then locale is en_US.UTF-8 --> ko_KR.eucKR...

how simple changed!!!

and then... i installed nabi korean input method tool..
it was located at /usr/port/koean/nabi Folder..
and I installed nabi(make install clean)

After nabi install, i creat file at /user home directory/.kde/env/nabi.sh
example my case, /home/final/.kde/env/nabi.sh
and i edit it.

Code:
nabi &
export XIMODIFIERS="@im=nabi"
then i change permission (chmod 755 nabi.sh)
and then I system rebooting....

finally, i can write korean word... in KDE

and i try SKIM setting the same progress....(skim in kde, scim in gnome input method tool)
Reply With Quote
  #6  
Old 02-17-2007, 06:56 AM
Apatewna Apatewna is offline
Senior Member
 
Join Date: May 2006
Location: Greece
Posts: 1,142
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via ICQ to Apatewna Send a message via MSN to Apatewna Send a message via Yahoo to Apatewna
Default
Glad you made it work. I always forget that there are people who use "exotic" alphabets like almost all asian countries, my guide is mostly targeting the more simple alphabets.

Feel free to enter your comment about Korean writing in the post about i18n so that people in your country can take advantage of it too
__________________
RTFM and STFW before anything bad happens

Please read and UNDERSTAND these pages before posting:
http://www.catb.org/~esr/faqs/smart-questions.html
http://en.wikipedia.org/wiki/Netiquette
Reply With Quote
  #7  
Old 09-03-2012, 08:52 AM
helix helix is offline
Senior Member
 
Join Date: Feb 2012
Location: Slovenia
Posts: 142
Thanks: 54
Thanked 13 Times in 12 Posts
Default
Originally Posted by Apatewna View Post
Glad you made it work. I always forget that there are people who use "exotic" alphabets like almost all asian countries, my guide is mostly targeting the more simple alphabets.

Feel free to enter your comment about Korean writing in the post about i18n so that people in your country can take advantage of it too
When I try to open suggested link about localization this pops up:

Object not found!

The requested URL was not found on this server. The link on the referring page seems to be wrong or outdated. Please inform the author of that page about the error.

If you think this is a server error, please contact the webmaster.
Error 404
forums.pcbsd.org
Mon Sep 3 01:51:47 2012
Apache/2.2.17 (FreeBSD) mod_ssl/2.2.17 OpenSSL/0.9.8q DAV/2 SVN/1.6.15 PHP/5.2.14 with Suhosin-Patch
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Firefox addon Quick Locale Switcher? josegator PBI Discussion 1 07-09-2009 01:49 PM
I have a trouble on Japanese locale. cervo-cn21s General Questions 1 05-09-2009 11:32 AM
Locale bug under Ext3 FS and in the terminal rodrigocastrillon General Bug Reports 0 12-15-2008 12:10 AM
Gtk-WARNING "Locale not supported by C library" bigfatgeek General Questions 12 05-13-2008 12:28 PM
locale problem robinreplab General Questions 0 03-18-2007 11:02 AM


All times are GMT. The time now is 12:15 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Copyright 2005-2010, The PC-BSD Project. PC-BSD and the PC-BSD logo are registered trademarks of iXsystems.
All other content is freely available for sharing under the terms of the Creative Commons Attribution License.