Reply
 
Thread Tools Display Modes
  #1  
Old 02-15-2007, 03:46 AM
ezcomputers ezcomputers is offline
Junior Member
 
Join Date: Feb 2007
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default Intel 945gm chipset x11 won't start sees it as intel i810
Hello, I've run into a problem after installing pc-bsd. My dell latitude would be supported if it had the high end graphics. It CURRENTLY HAS THE INTEL 945gm Express graphics chipset and my xorg.conf file sees it as in i810 which does not work. I'm very new to pc-bsd but I can follow instructions on how to get it working so any help that could be given I would appreciate.

Thanks

_peter
Reply With Quote
  #2  
Old 02-15-2007, 09:02 AM
Arabian Arabian is offline
Senior Member
 
Join Date: Nov 2006
Location: State of Qatar, Arab world
Posts: 147
Thanks: 0
Thanked 0 Times in 0 Posts
Default
Please post your dmesg, and your xorg.conf
Reply With Quote
  #3  
Old 02-15-2007, 11:56 AM
ezcomputers ezcomputers is offline
Junior Member
 
Join Date: Feb 2007
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default
this is my xorg.conf it's whatever pc-bsd sets as default for my machine as I havent touched it and just installed it fresh.

# XFree86 configuration file for RoFreeSBIE

Section "ServerLayout"
Identifier "XFree86 Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "ServerFlags"
#Option "DisableVidModeExtension" "True"
#Option "NoTrapSignals" "True"
#Option "DisableModInDev" "True"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
ModulePath "/usr/X11R6/lib/modules"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic/"
FontPath "/usr/X11R6/lib/X11/fonts/TrueType/"
FontPath "/usr/X11R6/lib/X11/fonts/illinoy/"
FontPath "/usr/X11R6/lib/X11/fonts/webfonts/"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/TTF/"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo/"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath "/usr/X11R6/lib/X11/fonts/CID/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/dejavu/"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic/"
FontPath "/usr/X11R6/lib/X11/fonts/hebrew/"
FontPath "/usr/X11R6/lib/X11/fonts/vietnamese/"
FontPath "/usr/X11R6/lib/X11/fonts/indic/"
FontPath "/usr/X11R6/lib/X11/fonts/ae_fonts1/AAHS"
FontPath "/usr/X11R6/lib/X11/fonts/ae_fonts1/AGA"
FontPath "/usr/X11R6/lib/X11/fonts/ae_fonts1/FS"
FontPath "/usr/X11R6/lib/X11/fonts/ae_fonts1/Kasr"
FontPath "/usr/X11R6/lib/X11/fonts/ae_fonts1/MCS"
FontPath "/usr/X11R6/lib/X11/fonts/ae_fonts1/Shmookh"
FontPath "/usr/X11R6/lib/X11/fonts/local/"
EndSection

Section "Module"
# Load "record"
Load "ddc"
Load "dri"
Load "dbe"
Load "extmod"
Load "glx"
Load "xtrap"
Load "freetype"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/sysmouse"
Option "Buttons" "6"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
#DefaultDepth 24
DefaultDepth 16
SubSection "Display"
Depth 0
Modes "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1280x800" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1280x800" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1280x800" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection


Section "Monitor"
#DisplaySize 300 190 # mm
Identifier "Monitor0"
VendorName "CMO"
ModelName "1415"
EndSection

Section "Device"
### Available Driver options are:-
### Values: [i]: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "NoAccel" # [<bool>]
#Option "SWcursor" # [<bool>]
#Option "ColorKey" # [i]
#Option "CacheLines" # [i]
#Option "Dac6Bit" # [<bool>]
#Option "DRI" # [<bool>]
#Option "NoDDC" # [<bool>]
#Option "ShowCache" # [<bool>]
#Option "XvMCSurfaces" # [i]
#Option "PageFlip" # [<bool>]
Identifier "Card0"
Driver "i810"
VendorName "Intel Corporation"
BoardName "Mobile Integrated Graphics Controller"
BusID "PCI:0:2:0"
EndSection




and here's my dmesg.boot

Copyright (c) 1992-2006 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
The Regents of the University of California. All rights reserved.
FreeBSD 6.1-RELEASE-p11 #5: Wed Dec 20 18:29:42 PST 2006
root@PCBSD.localhost:/usr/obj/usr/src/sys/PCBSDv1.3-SMP
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Genuine Intel(R) CPU T2300 @ 1.66GHz (1664.45-MHz 686-class CPU)
Origin = "GenuineIntel" Id = 0x6e8 Stepping = 8
Features=0xbfe9fbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE ,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,CLFLUSH,DTS,AC PI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>
Features2=0xc189<SSE3,MON,EST,TM2,<b14>,<b15>>
AMD Features=0x100000<NX>
Cores per package: 2
real memory = 1063784448 (1014 MB)
avail memory = 1031835648 (984 MB)
ACPI APIC Table: <DELL M07 >
FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
cpu0 (BSP): APIC ID: 0
cpu1 (AP): APIC ID: 1
ioapic0: Changing APIC ID to 2
ioapic0 <Version 2.0> irqs 0-23 on motherboard
kbd1 at kbdmux0
acpi0: <DELL M07 > on motherboard
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x1008-0x100b on acpi0
cpu0: <ACPI CPU> on acpi0
acpi_throttle0: <ACPI CPU Throttling> on cpu0
cpu1: <ACPI CPU> on acpi0
acpi_throttle1: <ACPI CPU Throttling> on cpu1
acpi_throttle1: failed to attach P_CNT
device_attach: acpi_throttle1 attach returned 6
acpi_acad0: <AC Adapter> on acpi0
battery0: <ACPI Control Method Battery> on acpi0
battery1: <ACPI Control Method Battery> on acpi0
acpi_lid0: <Control Method Lid Switch> on acpi0
acpi_button0: <Power Button> on acpi0
acpi_button1: <Sleep Button> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
pci0: <display, VGA> at device 2.0 (no driver attached)
pci0: <display> at device 2.1 (no driver attached)
pci0: <multimedia> at device 27.0 (no driver attached)
pcib1: <ACPI PCI-PCI bridge> at device 28.0 on pci0
pci11: <ACPI PCI bus> on pcib1
pcib2: <ACPI PCI-PCI bridge> at device 28.1 on pci0
pci12: <ACPI PCI bus> on pcib2
pci12: <network> at device 0.0 (no driver attached)
pcib3: <ACPI PCI-PCI bridge> at device 28.2 on pci0
pci9: <ACPI PCI bus> on pcib3
bge0: <Broadcom BCM5752 Gigabit Ethernet, ASIC rev. 0x6002> mem 0xefcf0000-0xefcfffff irq 18 at device 0.0 on pci9
bge0: firmware handshake timed out
miibus0: <MII bus> on bge0
ukphy0: <Generic IEEE 802.3u media interface> on miibus0
ukphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT, 1000baseT-FDX, auto
bge0: Ethernet address: 00:18:8b:a6:d2:f2
uhci0: <UHCI (generic) USB controller> port 0xbf80-0xbf9f irq 20 at device 29.0 on pci0
uhci0: [GIANT-LOCKED]
usb0: <UHCI (generic) USB controller> on uhci0
usb0: USB revision 1.0
uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhci1: <UHCI (generic) USB controller> port 0xbf60-0xbf7f irq 21 at device 29.1 on pci0
uhci1: [GIANT-LOCKED]
usb1: <UHCI (generic) USB controller> on uhci1
usb1: USB revision 1.0
uhub1: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
uhci2: <UHCI (generic) USB controller> port 0xbf40-0xbf5f irq 22 at device 29.2 on pci0
uhci2: [GIANT-LOCKED]
usb2: <UHCI (generic) USB controller> on uhci2
usb2: USB revision 1.0
uhub2: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub2: 2 ports with 2 removable, self powered
uhci3: <UHCI (generic) USB controller> port 0xbf20-0xbf3f irq 23 at device 29.3 on pci0
uhci3: [GIANT-LOCKED]
usb3: <UHCI (generic) USB controller> on uhci3
usb3: USB revision 1.0
uhub3: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub3: 2 ports with 2 removable, self powered
ehci0: <Intel 82801GB/R (ICH7) USB 2.0 controller> mem 0xffa80000-0xffa803ff irq 20 at device 29.7 on pci0
ehci0: [GIANT-LOCKED]
usb4: EHCI version 1.0
usb4: companion controllers, 2 ports each: usb0 usb1 usb2 usb3
usb4: <Intel 82801GB/R (ICH7) USB 2.0 controller> on ehci0
usb4: USB revision 2.0
uhub4: Intel EHCI root hub, class 9/0, rev 2.00/1.00, addr 1
uhub4: 8 ports with 8 removable, self powered
pcib4: <ACPI PCI-PCI bridge> at device 30.0 on pci0
pci3: <ACPI PCI bus> on pcib4
cbb0: <O2Micro OZ6912/6972 PCI-CardBus Bridge> at device 1.0 on pci3
cardbus0: <CardBus bus> on cbb0
pccard0: <16-bit PCCard bus> on cbb0
isab0: <PCI-ISA bridge> at device 31.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <GENERIC ATA controller> port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xbfa0-0xbfaf irq 17 at device 31.2 on pci0
ata0: <ATA channel 0> on atapci0
ata1: <ATA channel 1> on atapci0
pci0: <serial bus, SMBus> at device 31.3 (no driver attached)
acpi_tz0: <Thermal Zone> on acpi0
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64,0x62,0x66 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: [GIANT-LOCKED]
psm0: model GlidePoint, device ID 0
sio0: <16550A-compatible COM port> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
sio0: type 16550A
pmtimer0 on isa0
orm0: <ISA Option ROMs> at iomem 0xc0000-0xce7ff,0xce800-0xcffff on isa0
ppc0: parallel port not found.
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
uhub5: vendor 0x413c product 0xa005, class 9/0, rev 2.00/50.18, addr 2
uhub5: 4 ports with 0 removable, self powered
uhub6: vendor 0x0b97 product 0x7761, class 9/0, rev 1.10/1.10, addr 3
uhub6: 3 ports with 2 removable, bus powered
ugen0: O2 O2Micro CCID SC Reader, rev 1.10/1.10, addr 4
ugen1: vendor 0x413c product 0x8103, rev 2.00/24.22, addr 5
Timecounters tick every 1.000 msec
ad0: 76319MB <Hitachi HTS721080G9SA00 MC4OC10H> at ata0-master UDMA33
acd0: CDRW <TSSTcorpCD-RW/DVD-ROM TSL462D/DE01> at ata1-master UDMA33
SMP: AP CPU #1 Launched!
cd0 at ata1 bus 0 target 0 lun 0
cd0: <TSSTcorp CDRW/DVD TSL462D DE01> Removable CD-ROM SCSI-0 device
cd0: 33.000MB/s transfers
cd0: Attempt to query device size failed: NOT READY, Medium not present - tray closed
Trying to mount root from ufs:/dev/ad0s1a
bge0: firmware handshake timed out


There's the contents of my xorg.conf and my dmesg.boot these files both are products of a default pc-bsd 1.3 install. I didnt edit anything just installed it and X won't start Any help would be greatly appreciated


Thanks alot

Cant wait to get this to work so I can run X on this laptop

Thanks

-Pete
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel i810 not working wm Graphics Cards 4 04-13-2009 09:34 PM
RAID - Intel Chipset and PCBSD install nodje General Questions 0 10-10-2007 06:49 AM
Intel 945GM... how?? xenonsoft Graphics Cards 21 07-20-2007 11:04 PM
Intel 82845G/GL (i810 driver) problem w/ 19" LCD DataTracer Graphics Cards 4 01-14-2007 06:31 AM
Intel 810 chipset ggordon Tips and Tricks 2 11-11-2006 07:16 PM


All times are GMT. The time now is 08:01 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Copyright 2005-2010, The PC-BSD Project. PC-BSD and the PC-BSD logo are registered trademarks of iXsystems.
All other content is freely available for sharing under the terms of the Creative Commons Attribution License.