Reply
 
Thread Tools Display Modes
  #1  
Old 11-23-2013, 08:41 PM
rrod rrod is offline
Senior Member
 
Join Date: Jan 2013
Posts: 105
Thanks: 6
Thanked 0 Times in 0 Posts
Default Screen Saver
How do I get the screen saver to work. I use krunner to start it, but I get this message "The XScreenSaver daemon doesn't seem to be running on display ":0". Launch it now?" I click yes and it runs. But only until the system is restarted. The screen saver cannot be found in the Control Panel. Is there a way to work without having to restart it every time the system is booted? PCBSD version 9.2.
Reply With Quote
  #2  
Old 11-23-2013, 11:03 PM
anika200 anika200 is offline
Senior Member
 
Join Date: Feb 2013
Location: US
Posts: 100
Thanks: 38
Thanked 13 Times in 12 Posts
Default
Did you try the kde screen locker? It is under >> Sysem Settings >> Display and Monitors >> Screen Locker
Reply With Quote
The Following User Says Thank You to anika200 For This Useful Post:
Micros (11-24-2013)
  #3  
Old 11-24-2013, 12:12 AM
Micros Micros is offline
Senior Member
 
Join Date: Dec 2012
Posts: 187
Thanks: 38
Thanked 17 Times in 14 Posts
Default
Thanks anika, I was having same issue as rrod, but going through the kde classic menu>screensaver.
__________________
PC-BSD 10
FreeBSD 10 on RaspberryPI

Last edited by Micros; 12-02-2013 at 04:12 AM.
Reply With Quote
  #4  
Old 11-24-2013, 01:39 AM
rrod rrod is offline
Senior Member
 
Join Date: Jan 2013
Posts: 105
Thanks: 6
Thanked 0 Times in 0 Posts
Default
Thanks anika. I had not. Though there was a screen saver that could be set to display alternating screen savers. Seems to be gone in 9.2. Or just haven't figured out how to do it. Thanks again.
Reply With Quote
  #5  
Old 11-25-2013, 12:28 AM
rrod rrod is offline
Senior Member
 
Join Date: Jan 2013
Posts: 105
Thanks: 6
Thanked 0 Times in 0 Posts
Default
Actually, if you run Krunner and type screensaver, thats what I am interested in. The Xscreen saver daemon is not running. How do I get that to run without having to start it everytime the system is rebooted?
Reply With Quote
  #6  
Old 11-25-2013, 11:24 AM
anika200 anika200 is offline
Senior Member
 
Join Date: Feb 2013
Location: US
Posts: 100
Thanks: 38
Thanked 13 Times in 12 Posts
Default
Originally Posted by rrod View Post
Actually, if you run Krunner and type screensaver, thats what I am interested in. The Xscreen saver daemon is not running. How do I get that to run without having to start it everytime the system is rebooted?
The kde screen saver module Are the xscreensaver modules..... Do you want to run one that is not listed?

Sorry, I do not understand your need to start the xscreensaver daemon because that functionality has been moved to the screen locker in KDE.
Reply With Quote
  #7  
Old 11-25-2013, 08:21 PM
rrod rrod is offline
Senior Member
 
Join Date: Jan 2013
Posts: 105
Thanks: 6
Thanked 0 Times in 0 Posts
Default
I don't see where that has been moved. Its that the two are different. Because if you use the one in the screen locker, you only have the option of one screen saver. If you run krunner and turn on that xscreen saver daemon, you can set it up to alternate different displays. This is just a preference for me. I like that one better. Its no big deal. Try it and see what I mean.
Reply With Quote
  #8  
Old 11-25-2013, 10:56 PM
anika200 anika200 is offline
Senior Member
 
Join Date: Feb 2013
Location: US
Posts: 100
Thanks: 38
Thanked 13 Times in 12 Posts
Default
Originally Posted by rrod View Post
I don't see where that has been moved. Its that the two are different. Because if you use the one in the screen locker, you only have the option of one screen saver. If you run krunner and turn on that xscreen saver daemon, you can set it up to alternate different displays. This is just a preference for me. I like that one better. Its no big deal. Try it and see what I mean.
I see what you mean now, they removed the alternating functionality.

I just added xscreensaver to the kde autostart module and rebooted and it seems to be running and functioning, try it out and see if it works for you.
Just launch autostart from krunner and then in the search bar type in xscreensaver.
Reply With Quote
  #9  
Old 11-26-2013, 01:34 AM
rrod rrod is offline
Senior Member
 
Join Date: Jan 2013
Posts: 105
Thanks: 6
Thanked 0 Times in 0 Posts
Default
Thanks anika. That works.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 03:08 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Copyright 2005-2010, The PC-BSD Project. PC-BSD and the PC-BSD logo are registered trademarks of iXsystems.
All other content is freely available for sharing under the terms of the Creative Commons Attribution License.