Reply
 
Thread Tools Display Modes
  #1  
Old 04-12-2013, 05:48 PM
jrlokken jrlokken is offline
Junior Member
 
Join Date: Apr 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Sound configuration question
Hello Folks,

I have never had a good grasp on configuring sound in BSD, and have some questions about sound in PCBSD/KDE4.

PCBSD 9.1-RELEASE #2
KDE4
HP Pavilion dv4

#cat /dev/sndstat
FreeBSD Audio Driver (newpcm: 64bit 2009061500/amd64)
Installed devices:
pcm0: <ATI RS690/780 (HDMI)> (play)
pcm1: <IDT 92HD71B7 (Analog 2.0+HP/2.0)> (play/rec) default
pcm2: <IDT 92HD71B7 (Internal Analog Mic)> (rec)
pcm3: <IDT 92HD71B7 (Digital)> (play)

I'm using KDE4 and kmix

When I use the Sound Configuration applet from the PCBSD Control Panel, the only device that actually plays sound (using the Test Sound button) is pcm1, so I have set that as the default sound device.

The first issue is that, no matter what I have the volume (master) set to, when any sound plays, it immediately moves the volume, pcm, and speaker levels to 100% and sound will play only at full volume. As an example, if I set the volume, pcm, and speaker sliders to, say, 15%, then open Sound Configuration from the PCBSD Control Panel, select pcm1 from the drop-down, click test sound, all sliders (vol, pcm, speaker) are adjusted to 100% and the test sound plays at full volume. I'm not sure what adjustment(s) I need to make to remedy this situation.

Another point of confusion -- when I Select Master Channel in KMix, there is a Current Mixer: field. I have 4 options to choose from, all called OSS Audio Mixer. Which one do I want? ALSA and OSS are installed -- do I need them both?

Is there any chance of getting the touch buttons for volume control/mute to work on this dv4? Thanks in advance,


Joshua
Reply With Quote
  #2  
Old 04-12-2013, 06:19 PM
rvc rvc is offline
Senior Member
 
Join Date: Jul 2012
Location: India
Posts: 592
Thanks: 25
Thanked 48 Times in 45 Posts
Default
have you used the "mixer" command without quotes in a terminal ?
mine is like this
Quote:
[rvc@isotope] ~% mixer
Mixer vol is currently set to 100:100
Mixer pcm is currently set to 100:100
Mixer rec is currently set to 0:0
Mixer ogain is currently set to 100:100
Mixer monitor is currently set to 42:42
Recording source: monitor
[rvc@isotope] ~%
in the terminal you can issue command like mixer vol 50 OR mixer monitor 50 or something like that.... may be your problem is solved ?
__________________
r v c.
Associated with : VEDGOO.COM
My Home Page , BSD Walls 1920X1080
Reply With Quote
  #3  
Old 04-12-2013, 06:34 PM
jrlokken jrlokken is offline
Junior Member
 
Join Date: Apr 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default
Hello,

Yes, I have tried mixer from the command line, as well -- same problem. If I set the levels with mixer, ie:

mixer vol 10
mixer pcm 10
mixer speaker 10

Then play sound, all levels are still set to 100 and sound plays at full volume. Thanks for the prompt response, I appreciate your time.


Joshua
Reply With Quote
  #4  
Old 04-12-2013, 07:25 PM
Beanpole's Avatar
Beanpole Beanpole is offline
Senior Member
 
Join Date: May 2010
Posts: 2,396
Thanks: 8
Thanked 387 Times in 323 Posts
Default
The sound configuration utility in the control panel is designed to always set the volume to 100% when you click "Test Sound" to make sure that you can actually hear the little *ping* sound. That utility is only for detecting/setting the main output sound device, it is NOT designed to test everything related to sound configuration. So to perform an accurate check of the sound volume, you will need to use something other than the sound device testing utility (like a small audio file or a youtube video).

After setting up the main mound device with that utility, you will need to use KDE's sound configuration/mixer utilities to control the sound output after that. Since you mentioned that your device is the second one (pcm1), I would guess that the second OSS mixer in KDE is the one that will work properly. Since KDE is used to a linux-centric device layout (which we do not have on FreeBSD obviously), the number of audio devices that KDE will report should be correct, but the labels are sometimes incorrect, so you might end up needing to test all of the KDE mixers to find out which one controls the proper output device levels.
__________________
~ Ken Moore ~
PC-BSD/iXsystems
Reply With Quote
  #5  
Old 04-12-2013, 07:30 PM
jrlokken jrlokken is offline
Junior Member
 
Join Date: Apr 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default
That makes sense -- and now, after doing some more testing, it is indeed the second mixer that works properly, and I can verify that sound from my media player is working, and honors the mixer settings. Thanks very much for your assistance.


Joshua
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 07:30 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Copyright 2005-2010, The PC-BSD Project. PC-BSD and the PC-BSD logo are registered trademarks of iXsystems.
All other content is freely available for sharing under the terms of the Creative Commons Attribution License.