Reply
 
Thread Tools Display Modes
  #1  
Old 09-05-2012, 07:04 PM
bds bds is offline
Senior Member
 
Join Date: Oct 2009
Posts: 510
Thanks: 75
Thanked 50 Times in 46 Posts
Default 9.1-RC1 Wireless issues
Hi all --

I have a number of potentially related wireless/networking issues with 9.1-RC1 (amd64, Thinkpad X61, Intel 4965 AG/AGN wireless card).

Work maintains a campus-wide network named "ut-open". I can (generally) connect without any problems in my office. However, when I go to different buildings, I'm unable to connect to the same network name. Occasionally, I'll be able to
  1. delete the network profile ("ut-open"),
  2. Apply,
  3. wait for the network to restart,
  4. Add a network profile ("ut-open"),
  5. Check the Advanced tab for DCHP,
  6. Apply,
  7. wait for the network to restart,
and then maybe I'll have wireless. Is there a workaround for this?

A second issue is a driver crash when connecting to the wireless network in some of the other buildings. I've been pressed for time, but I'll try to sit down tomorrow and test this a bit more and see if it's as pernicious as it seems. See attached dmesg [1]. I've read a few other reports of this, but I don't recall a cause or solution.

Third -- I observed some weird behavior from lagg0 today. I switch between a wired connection and the wireless network so I have lagg0 enabled in PC-BSD Network Manager > Network Configuration (Advanced) tab. Since setting up 9.1-RC1 & using wired/wireless (w/lagg0 enabled) I haven't seen it in dmesg or in ifconfig. But it showed up this afternoon, after the driver crash I mention above. I've attached an ifconfig from shortly after the crash & the appearance of lagg0.

I'm sorry that this is so long. If a mod wants to break this out into separate threads please do so. My networking-fu is incredibly weak so all suggestions are greatly appreciated.


[1] dmesg -- sorry, it was heavily truncated for the forum post. let me know if there's a need to see all of it.
Code:
Wed Sep  5 13:13:34 EDT 2012
drmn0: <Intel i965GM> on vgapci0
info: [drm] MSI enabled 1 message(s)
info: [drm] AGP at 0xe0000000 256MB
iicbus0: <Philips I2C bus> on iicbb0 addr 0xff
iic0: <I2C generic I/O> on iicbus0
iic1: <I2C generic I/O> on iicbus1
iicbus2: <Philips I2C bus> on iicbb1 addr 0xff
iic2: <I2C generic I/O> on iicbus2
iic3: <I2C generic I/O> on iicbus3
iicbus4: <Philips I2C bus> on iicbb2 addr 0xff
iic4: <I2C generic I/O> on iicbus4
iic5: <I2C generic I/O> on iicbus5
iicbus6: <Philips I2C bus> on iicbb3 addr 0xff
iic6: <I2C generic I/O> on iicbus6
iic7: <I2C generic I/O> on iicbus7
iicbus8: <Philips I2C bus> on iicbb4 addr 0xff
iic8: <I2C generic I/O> on iicbus8
iic9: <I2C generic I/O> on iicbus9
iicbus10: <Philips I2C bus> on iicbb5 addr 0xff
iic10: <I2C generic I/O> on iicbus10
iic11: <I2C generic I/O> on iicbus11
iicbus12: <Philips I2C bus> on iicbb6 addr 0xff
iic12: <I2C generic I/O> on iicbus12
iic13: <I2C generic I/O> on iicbus13
iicbus14: <Philips I2C bus> on iicbb7 addr 0xff
iic14: <I2C generic I/O> on iicbus14
iic15: <I2C generic I/O> on iicbus15
info: [drm] Supports vblank timestamp caching Rev 1 (10.10.2010).
info: [drm] Driver supports precise vblank timestamp query.
drmn0: taking over the fictitious range 0xe0000000-0xf0000000
info: [drm] initialized overlay support
info: [drm] Initialized i915 1.6.0 20080730
Sep  5 13:13:47 rook gnome-keyring-daemon[2753]: couldn't allocate secure memory to keep passwords and or keys from being written to the disk
iwn0: iwn_intr: fatal firmware error
firmware error log:
  error type      = "NMI_INTERRUPT_WDG" (0x00000004)
  program counter = 0x0000046C
  source line     = 0x000000D0
  error data      = 0x0000000207430000
  branch link     = 0x00008370000004C2
  interrupt link  = 0x000006DA000018B8
  time            = 200035
driver status:
  tx ring  0: qid=0  cur=0   queued=0  
  tx ring  1: qid=1  cur=0   queued=0  
  tx ring  2: qid=2  cur=0   queued=0  
  tx ring  3: qid=3  cur=4   queued=1  
  tx ring  4: qid=4  cur=102 queued=0  
  tx ring  5: qid=5  cur=0   queued=0  
  tx ring  6: qid=6  cur=0   queued=0  
  tx ring  7: qid=7  cur=0   queued=0  
  tx ring  8: qid=8  cur=0   queued=0  
  tx ring  9: qid=9  cur=0   queued=0  
  tx ring 10: qid=10 cur=0   queued=0  
  tx ring 11: qid=11 cur=0   queued=0  
  tx ring 12: qid=12 cur=0   queued=0  
  tx ring 13: qid=13 cur=0   queued=0  
  tx ring 14: qid=14 cur=0   queued=0  
  tx ring 15: qid=15 cur=0   queued=0  
  rx ring: cur=1
[2] ifconfig
Code:
em0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
	options=4219b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,TSO4,WOL_MAGIC,VLAN_HWTSO>
	ether 00:1d:72:98:56:41
	inet6 fe80::21d:72ff:fe98:5641%em0 prefixlen 64 scopeid 0x1 
	nd6 options=23<PERFORMNUD,ACCEPT_RTADV,AUTO_LINKLOCAL>
	media: Ethernet autoselect
	status: no carrier
iwn0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 2290
	ether 00:1d:72:98:56:41
	nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
	media: IEEE 802.11 Wireless Ethernet autoselect mode 11na
	status: associated
fwip0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
	lladdr 0.1d.72.ff.98.56.41.ff.a.2.ff.fe.0.0.0.0
	nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
fwe0: flags=8902<BROADCAST,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
	options=8<VLAN_MTU>
	ether 02:1d:72:56:41:ff
	nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
	ch 1 dma -1
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
	options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>
	inet6 ::1 prefixlen 128 
	inet6 fe80::1%lo0 prefixlen 64 scopeid 0xb 
	inet 127.0.0.1 netmask 0xff000000 
	nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
lagg0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
	ether 00:1d:72:98:56:41
	inet 216.96.177.145 netmask 0xfffffe00 broadcast 216.96.177.255
	nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
	media: Ethernet autoselect
	status: active
	laggproto failover lagghash l2,l3,l4
	laggport: wlan0 flags=4<ACTIVE>
	laggport: em0 flags=1<MASTER>
wlan0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
	ether 00:1d:72:98:56:41
	nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
	media: IEEE 802.11 Wireless Ethernet OFDM/54Mbps mode 11na
	status: associated
	ssid ut-open channel 161 (5805 MHz 11a ht/40-) bssid d8:c7:c8:89:cd:31
	country US authmode OPEN privacy OFF txpower 16 bmiss 10 mcastrate 6
	mgmtrate 6 scanvalid 450 bgscan bgscanintvl 300 bgscanidle 250
	roam:rssi 7 roam:rate 64 ampdulimit 64k ampdudensity 8
	-amsdutx amsdurx shortgi wme roaming MANUAL
Reply With Quote
  #2  
Old 09-06-2012, 07:50 PM
bds bds is offline
Senior Member
 
Join Date: Oct 2009
Posts: 510
Thanks: 75
Thanked 50 Times in 46 Posts
Default
Confirming that the only way to connect to the same network, albeit in a different building, is to Configure wlan0 > "remove" ut-open > Scan > Add ut-open > Apply, with waiting for the intra-step network restarts.

Has anyone else run into this sort of thing? There isn't anything in wpa_supplicant (or something else) that caches the IP address in my office and then trys to apply it when I boot in another building?

Thanks in advance!
Reply With Quote
  #3  
Old 10-07-2012, 02:25 AM
jwele jwele is offline
Member
 
Join Date: Aug 2012
Posts: 33
Thanks: 5
Thanked 0 Times in 0 Posts
Default
I have the Intel Wimax 6150 AGN PCI card on 9.1. Never successfully connected to my homes network yet. Card says associated but doesn't receive an IP address or anything.
Reply With Quote
  #4  
Old 10-08-2012, 03:13 AM
rvc rvc is offline
Senior Member
 
Join Date: Jul 2012
Location: India
Posts: 593
Thanks: 25
Thanked 48 Times in 45 Posts
Default
earlier in the initial install days of 9.0, i used to have these nightmares. i could connect from home and not from office and vice versa if i redid the who issue in office. (at times, wi-fi would never get active and whatever workaround i did never woke that up)

i dont know if i am technically right but this workaround solved my issue.

i went for a fresh re-install, after first initialization of wi-fi network from network profiles, i clicked on restart network. next, i opened Network manager to see if wlan0 interface was listed. i hit the save button and then tried to reboot. this time wifi caught up.

similarly in any other networks all i had to do was configure wlan0 and add a new profile and save it.

perhaps you can create new profiles like Location 1, Location 2 etc ? i use the same service provider with auto DHCP but from different location. (Office and Home, in my case)

This workaround should work as the network will be activated on boot.
__________________
r v c.
Associated with : VEDGOO.COM
My Home Page , BSD Walls 1920X1080
Reply With Quote
Reply

Tags
9.1-rc1 wireless, iwn crash, lagg0

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 08:59 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Copyright 2005-2010, The PC-BSD Project. PC-BSD and the PC-BSD logo are registered trademarks of iXsystems.
All other content is freely available for sharing under the terms of the Creative Commons Attribution License.