Reply
 
Thread Tools Display Modes
  #1  
Old 07-07-2012, 05:47 AM
malco_2001 malco_2001 is offline
Senior Member
 
Join Date: Aug 2010
Posts: 127
Thanks: 7
Thanked 30 Times in 23 Posts
Default 9-stable 20120622 xdcmp
XDCMP does not work if even if you check the box to enable it under the new gdm setup control panel unless you add

[daemon]
RemoteGreeter=/usr/lib/gdm/gdm-xdmcp-chooser-slave
to /usr/local/etc/gdm/custom.conf
Reply With Quote
  #2  
Old 07-07-2012, 06:48 AM
malco_2001 malco_2001 is offline
Senior Member
 
Join Date: Aug 2010
Posts: 127
Thanks: 7
Thanked 30 Times in 23 Posts
Default
In addition to this setting I also had to run the command

xhost +

as a regular user to disable the X access control list. That is before I could run
Xnest :1 -query myserversip to connect from another machine.
Reply With Quote
  #3  
Old 07-09-2012, 03:57 PM
kmoore134's Avatar
kmoore134 kmoore134 is offline
Administrator
 
Join Date: May 2005
Location: Knoxville, TN
Posts: 2,568
Thanks: 0
Thanked 162 Times in 127 Posts
Default 9-stable 20120622 xdcmp
Are you sure that is the right file? That doesn't exist here, but this
one does:

/usr/local/libexec/gdm-xdmcp-chooser-slave
__________________
----
Kris Moore
PC-BSD Founder
Reply With Quote
  #4  
Old 07-11-2012, 12:15 AM
malco_2001 malco_2001 is offline
Senior Member
 
Join Date: Aug 2010
Posts: 127
Thanks: 7
Thanked 30 Times in 23 Posts
Default
You are right. I was using
RemoteGreeter=/usr/lib/gdm/gdm-xdmcp-chooser-slave which was the incorrect path. That is strange because I know I even rolled back using a snapshot to the state of a fresh install. I am going to format this machine again to try it with just the host + setting. I know for sure that it did not allow me to connect until I did that.

Last edited by malco_2001; 07-11-2012 at 03:09 AM.
Reply With Quote
  #5  
Old 07-11-2012, 03:00 AM
malco_2001 malco_2001 is offline
Senior Member
 
Join Date: Aug 2010
Posts: 127
Thanks: 7
Thanked 30 Times in 23 Posts
Default
Ok this time I think I have narrowed it down a little further. xhost + wasn't required. editing /usr/local/etc/gdm/custom.conf wasn't required. It was only working because i was restarting gdm in between trying random things. I assumed that it had fixed things because i disconnected my monitor when rebooting the server. The problem still occurs when I attach a monitor unless i restart gdm. The minute I restart gdm the screen appears on both my remote session and my attached monitor. I will have to look into it some more....

Last edited by malco_2001; 07-11-2012 at 03:28 AM.
Reply With Quote
  #6  
Old 07-11-2012, 02:05 PM
kmoore134's Avatar
kmoore134 kmoore134 is offline
Administrator
 
Join Date: May 2005
Location: Knoxville, TN
Posts: 2,568
Thanks: 0
Thanked 162 Times in 127 Posts
Default 9-stable 20120622 xdcmp
I've added the RemoteGreeter= for 9.1, so it should work out of box now
__________________
----
Kris Moore
PC-BSD Founder
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 02:11 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Copyright 2005-2010, The PC-BSD Project. PC-BSD and the PC-BSD logo are registered trademarks of iXsystems.
All other content is freely available for sharing under the terms of the Creative Commons Attribution License.