Reply
 
Thread Tools Display Modes
  #1  
Old 05-10-2012, 02:13 AM
mettw mettw is offline
Junior Member
 
Join Date: May 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default 3g ppp
I have a 3G modem (Maxxon bp3) for telstra in Australia and I am completely lost as to how I am supposed to start a connection with it. I installed PCBSD from the CD.

In Network Configuration I set everything up as it should be, and judging by Linux it should be on the device cua0.1. So how do I actually start a connection? There is nowhere to enter a phone number, no ppp utility that I can see, and nothing in the manual about it.

What am I supposed to do to get PPP started?
Reply With Quote
  #2  
Old 05-10-2012, 02:46 PM
kmoore134's Avatar
kmoore134 kmoore134 is offline
Administrator
 
Join Date: May 2005
Location: Knoxville, TN
Posts: 2,568
Thanks: 0
Thanked 163 Times in 127 Posts
Default 3g ppp
You'll need to edit /etc/ppp/ppp.conf by hand most likely. At the moment
we don't have any developers who are using PPP over 3G to test / fix
this functionality in the GUI.
__________________
----
Kris Moore
PC-BSD Founder
Reply With Quote
  #3  
Old 05-11-2012, 01:16 AM
mettw mettw is offline
Junior Member
 
Join Date: May 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default
OK, Thanks. I just assumed there would be some Ubuntu like utility.

One more question, on my Debian system authentication is done through an AT command of:

AT$QCPDPP=1,1,"password","username"

On BSD is this sent to the modem automatically by the

set authname foo
set authkey bar

lines?

Do you know how I would go about setting the CID and auth type that are also set by this command? I presume PAP must be set somehow, and I can set the CID=1 by dialling *99#, but I was just wondering if FreeBSD used the same method or not. I am no expert on PPP and modems.

Thanks.
Reply With Quote
  #4  
Old 05-15-2012, 05:52 PM
Amzo Amzo is offline
Junior Member
 
Join Date: May 2012
Posts: 4
Thanks: 0
Thanked 2 Times in 2 Posts
Default
During my time with 3G on FreeBSD, I had to interactively send commands to ppp to start a successful connection. These where my steps taken.

Start PPP in interactive mode:

Code:
ppp
Specify the device:

Code:
set device /dev/cuaU0.0
Enable DNS

Code:
enable dns
Specify it to request a remote

Code:
ifaddr 10.0.0.1/0 10.0.0.2/0 255.255.255.0 0.0.0.0
Code:
add default HISADDR
I normally disable ipv6 stuff:

Code:
disable ipv6cp
Specify timeout to be 0 other wise it disconnects on idle:

Code:
set timeout 0
Now enter a terminal prompt to send commands to the device:

Code:
term
For finding out what commands to send to the modem, I used wvdialconf to probe the modem under Linux and wrote down the commands which were the following:

send the commands to the device:

Code:
ATZ
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
AT+CGDCONT=,1"IP","three.co.uk"
ATDT*99\
Then type ~/ to return back to PPP. Then simply type:

Code:
dial
This got me up and running with 3G on FreeBSD. there wasn't much documentation on it, so took me awhile. hopefully you find this useful.
Reply With Quote
  #5  
Old 06-10-2012, 03:19 AM
mettw mettw is offline
Junior Member
 
Join Date: May 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default
I got internet running through internet connection sharing with my windows laptop so I stopped messing about with this for a while. But I have finally got my 3g modem to work on PC-BSD.

There is something very weird going on with connecting to the modem with PPP. Most of my problem before was that I couldn't even get a term session in PPP to send AT commands. Even now it is unreliable. Sometimes it just can't get a term session and I have to try it a number of times or else switch the modem off and on again.

This is what I had to do to get it up and running. Some of this might be redundant - This is my first connection with it.

ppp.conf
Code:
default:
  set timeout 180
  set device /dev/cuaU0.1
  set dial

telstra.bigpond:
  enable dns
  set authname USERNAME
  set authkey PASSWORD
  set login
  set ifaddr 10.0.0.1/0 10.0.0.2/0 255.255.255.0 0.0.0.0
  add default HISADDR
Then in PPP I entered:
Code:
>set timeout 180
>set device /dev/cuaU0.1
>set dial
>term
Failed to open /dev/cuaU0.1
>term
Failed to open /dev/cuaU0.1
>term
deflink: Entering terminal mode on /dev/cuaU0.1
Type '~?' for help
at
OK
at+CGATT?
:CGATT=1

OK
AT+CGDCONT=1,"IP","telstra.bigpond"
OK
AT$QCPDPP=1,1,"PASSWORD","USERNAME"
OK
ATDT *99***1#\
CONNECT

~.
>dial telstra.bigpond

Last edited by mettw; 06-10-2012 at 03:21 AM.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 10:19 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Copyright 2005-2010, The PC-BSD Project. PC-BSD and the PC-BSD logo are registered trademarks of iXsystems.
All other content is freely available for sharing under the terms of the Creative Commons Attribution License.