Closed Thread
 
Thread Tools Display Modes
  #1  
Old 02-09-2012, 01:39 PM
Bonitu Bonitu is offline
Junior Member
 
Join Date: Feb 2012
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Question VirtualBox - Shared Folders
Hi,

My host is XP Pro
Guest: PC-BSD 9
Virtualbox version: 4.1.8.

I'm very new to *nix.
I have installed the guest additions from the installation dvd (4.0.14_OSE r74382) and I have the video and mouse working nicely.

However, I cannot find a way to share the host folder with the guest pc-bsd.

I tried various suggestions I counld find on the net, but nothing works.
Does anyone have a working solution?
  #2  
Old 02-09-2012, 04:59 PM
Cobalt Cobalt is offline
Senior Member
 
Join Date: Apr 2009
Location: USA
Posts: 447
Thanks: 0
Thanked 10 Times in 10 Posts
Default
Add your folder by right-clicking on your PC-BSD entry and click Settings, then Shared Folders.

To mount it, you'd probably use something like: mount -t vboxsf Desktop /home/cobalt/Desktop

or maybe:

net use x: \\vboxsvr\Desktop

for a DOS-like OS
  #3  
Old 02-09-2012, 05:44 PM
Bonitu Bonitu is offline
Junior Member
 
Join Date: Feb 2012
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default
x: \\vboxsvr\Desktop
Is for windows-like guests, which is not the case here.

Shared folders are already defined on the settings.

mount -t vboxsf Desktop /home/cobalt/Desktop returns the following error:
"Operation not supported by device"
  #4  
Old 02-09-2012, 05:59 PM
Cobalt Cobalt is offline
Senior Member
 
Join Date: Apr 2009
Location: USA
Posts: 447
Thanks: 0
Thanked 10 Times in 10 Posts
Default
I meant for /home/cobalt/Desktop to be an example. You'd use your home directory in this case.

The net use x: \\vboxsvr\Desktop was for syntax reference. Well, VirtualBox will show you what the Windows path is when you select the Windows folder.

The syntax *should* be like this in your VM:
mount -t vboxsf Name_of_Shared_Windows_Folder Windows_Path_to_Shared_Folder

I'm shooting from the hip since I've never tried it.

Last edited by Cobalt; 02-09-2012 at 06:01 PM.
  #5  
Old 02-09-2012, 06:18 PM
Bonitu Bonitu is offline
Junior Member
 
Join Date: Feb 2012
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default
Well, I meant only to save time, by "reporting" as I did.

Of course I did used the command as meant, with my own local settings for the actual folder names.
It does not work.

I can only guess that this vboxsf is not part of this version of guest additions. (It does work on later guest additions for Sabayon or Ubuntu Guest machines).

As I mentioned on my initial post, I tried what I could find on the net, but nothing worked.

Thanks for trying though.
  #6  
Old 02-09-2012, 06:54 PM
Cobalt Cobalt is offline
Senior Member
 
Join Date: Apr 2009
Location: USA
Posts: 447
Thanks: 0
Thanked 10 Times in 10 Posts
Default
By going into KDE's Settings, then Sharing and setting a user and password, I was able to detect Windows shares on my network in PC-BSD.

Try making a shared folder with XP and see if it appears in KDE's file manager, Dolphin, after doing the step above. You might be able to share folders this way.
  #7  
Old 02-09-2012, 07:24 PM
Bonitu Bonitu is offline
Junior Member
 
Join Date: Feb 2012
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default
Originally Posted by Cobalt View Post
By going into KDE's Settings, then Sharing and setting a user and password, I was able to detect Windows shares on my network in PC-BSD.

Try making a shared folder with XP and see if it appears in KDE's file manager, Dolphin, after doing the step above. You might be able to share folders this way.
I don't understand what you mean by "Sharing and setting a user and password" on KDE.
I have root access and the user I am using in general, on the pc-bsd.
I set a folder under /media/mount_point_name (which is supposed to be the place where vbox defines it's shares since Ver 4 (I think). That folder have full permissions just for the test.

The XP directory (which is to be shared on the vbox guest machine) is listed on the vbox "shared directories".

Aside from that, I don't have an internal sharing or network on the XP host. It is a stand alone desktop, with a single user.

I am reluctant to start any network unless it is the only way to make this work, because I don't understand anything in networks.

Can you guide me step by step?
  #8  
Old 02-09-2012, 08:17 PM
Cobalt Cobalt is offline
Senior Member
 
Join Date: Apr 2009
Location: USA
Posts: 447
Thanks: 0
Thanked 10 Times in 10 Posts
Default
I can't really guide you on how to create a shared folder in XP, but here's a tutorial on it: http://compnetworking.about.com/od/w...winxpfiles.htm

For PC-BSD, click your application launcher (PC-BSD logo in the bottom-left corner) then click Computer and click System Settings. Alternatively, you can just search for it with the search box at the top of the menu by typing: System Settings

Under the Network and Connectivity section, you should see Sharing. Double-click it and it should pop up with a window that says: Use to configure which Windows (SMB) filesystems you can browse. Just put in your user and password that you use for your PC-BSD account and hit Apply.

Then click your application launcher again and search for Dolphin. It'll be at the top. Any shared Windows folders will pop up on the side bar. If you can't see the sidebar, just hit F9.

None of this involves VirtualBox's folder sharing.

Hope this helps.
  #9  
Old 02-10-2012, 05:50 AM
Bonitu Bonitu is offline
Junior Member
 
Join Date: Feb 2012
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default
Quote:
Under the Network and Connectivity section, you should see Sharing. Double-click it and it should pop up with a window that says: Use to configure which Windows (SMB) filesystems you can browse. Just put in your user and password that you use for your PC-BSD account and hit Apply.
I did it, but I don't see any change:

My username on the pc-bsd was able to see all the folders on the pc-bsd machine before this.
Adding the username and password on the "share" of the system settings ("configure which Windows (SMB) filesystems you can browse") did not allow to specifically select any specific folder.

On the XP side, even though I shared a folder via windows "net share", there's no connection between the two elements (the XP shared folder and the instructions on the pc-bsd side).

I know there must be some "missing link", but I am not sure what to do about it.
  #10  
Old 03-18-2014, 11:19 PM
Jungle-Boogie Jungle-Boogie is offline
Junior Member
 
Join Date: Jul 2013
Posts: 16
Thanks: 0
Thanked 1 Time in 1 Post
Default Possible on 10?
Now that we're a couple years later and have great revisions of both PCBSD and virtual box, is it now possible to create shared directories amont windows 7 and pcbsd 10?

Code:
jboogie@pcbsdcat[16:09] ~ % sudo mount -t vboxsf syncme /usr/home/jboogie/Documents
Password:
mount: syncme: Operation not supported by device
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 02:04 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Copyright 2005-2010, The PC-BSD Project. PC-BSD and the PC-BSD logo are registered trademarks of iXsystems.
All other content is freely available for sharing under the terms of the Creative Commons Attribution License.