Reply
 
Thread Tools Display Modes
  #1  
Old 01-21-2012, 03:17 PM
bds bds is offline
Senior Member
 
Join Date: Oct 2009
Posts: 502
Thanks: 72
Thanked 50 Times in 46 Posts
Default pc-nettray 100% processor usage
hi all --

in the process of trying to get my wifi working, i've noticed that pc-nettray manager is using ~100% of one of my processor cores. is this normal?

cheers!
screenshot:http://imgur.com/8VbOv.png
Reply With Quote
  #2  
Old 07-03-2012, 03:31 PM
drulavigne drulavigne is offline
Administrator
 
Join Date: Nov 2009
Posts: 1,080
Thanks: 35
Thanked 48 Times in 47 Posts
Default
There have been many fixes to pc-nettray for 9.1. If you get a chance to test the latest snapshot or the upcoming beta1,let us know if this is still an issue or if it has been resolved.
Reply With Quote
  #3  
Old 07-03-2012, 04:44 PM
bds bds is offline
Senior Member
 
Join Date: Oct 2009
Posts: 502
Thanks: 72
Thanked 50 Times in 46 Posts
Default
hi Dru --

I can report that I'm still having the same problem in the 20120605 snapshot. Screenshot to follow -- here: http://imgur.com/Vqx0O.

Thanks!

Last edited by bds; 07-03-2012 at 04:58 PM. Reason: added imgur link
Reply With Quote
  #4  
Old 07-03-2012, 05:10 PM
kmoore134's Avatar
kmoore134 kmoore134 is offline
Administrator
 
Join Date: May 2005
Location: Knoxville, TN
Posts: 2,568
Thanks: 0
Thanked 162 Times in 127 Posts
Default pc-nettray 100% processor usage
I've just updated the code a bit, hopefully it gets rid of the 100%
processor usage you saw.

When the next image hits, please retest and let us know if it still does
this.
__________________
----
Kris Moore
PC-BSD Founder
Reply With Quote
  #5  
Old 07-03-2012, 05:32 PM
bds bds is offline
Senior Member
 
Join Date: Oct 2009
Posts: 502
Thanks: 72
Thanked 50 Times in 46 Posts
Default
hi Kris -- no problem. Thanks for taking a look at this!

Cheers,
Bridger
Reply With Quote
  #6  
Old 07-19-2012, 07:01 PM
bds bds is offline
Senior Member
 
Join Date: Oct 2009
Posts: 502
Thanks: 72
Thanked 50 Times in 46 Posts
Default
hi Kris & co.

I can throw up a screenshot at some point -- pc-nettray is continuing to use 100% WCPU as reported by top. If this helps at all:

CPU: 24.8% user, 0.0% nice, 25.2% system, 0.0% interrupt, 49.8% idle

Please let me know if there's any info I can pass along to help debug.
Cheers!

(using Beta1)
Reply With Quote
  #7  
Old 07-19-2012, 07:35 PM
kmoore134's Avatar
kmoore134 kmoore134 is offline
Administrator
 
Join Date: May 2005
Location: Knoxville, TN
Posts: 2,568
Thanks: 0
Thanked 162 Times in 127 Posts
Default pc-nettray 100% processor usage
This on a wireless device? Can you paste the output of "ps -auwwx | grep
pc-nettray"?
__________________
----
Kris Moore
PC-BSD Founder
Reply With Quote
  #8  
Old 07-19-2012, 08:14 PM
bds bds is offline
Senior Member
 
Join Date: Oct 2009
Posts: 502
Thanks: 72
Thanked 50 Times in 46 Posts
Default
hi Kris --
yes, it's on a Thinkpad X61 (Intel Wireless WiFi Link 4965). Here's the output from BETA1:


Code:
[bridger@pcbsd-4853] ~% ps -auwwx | grep pc-nettray
root        2155 100.0  0.6 158208 20008 ??  I     3:44PM  1:01.80 pc-nettray wlan0
root         540   0.0  0.1  57260  3940 ??  I     3:44PM  0:00.01 sudo pc-nettray wlan0
bridger    10326   0.0  0.1  16280  1876  0  S+    3:49PM  0:00.00 grep pc-nettray
I'll add the output from 9.0 as soon as I reboot.
Thanks!

Here's 9.0:
Code:
bridger@rook> ps -auwwx | grep pc-nettray                                                                                  ~
root        3616 100.0  0.7 153016  22272  ??  S     3:54PM 0:37.11 pc-nettray wlan0
root        2887   0.0  0.1  44648   3160  ??  I     3:54PM 0:00.01 sudo pc-nettray wlan0
root        2894   0.0  0.1  44648   3108  ??  I     3:54PM 0:00.01 sudo pc-nettray em0
root        2903   0.0  0.6 148216  19252  ??  S     3:54PM 0:00.25 pc-nettray em0
bridger     6509   0.0  0.1  16424   1820   0  S+    3:57PM 0:00.00 grep --color=auto pc-nettray

Last edited by bds; 07-19-2012 at 08:19 PM. Reason: output from 9.0
Reply With Quote
  #9  
Old 07-19-2012, 08:27 PM
kmoore134's Avatar
kmoore134 kmoore134 is offline
Administrator
 
Join Date: May 2005
Location: Knoxville, TN
Posts: 2,568
Thanks: 0
Thanked 162 Times in 127 Posts
Default pc-nettray 100% processor usage
Ok, I may have just fixed this. Can you install our tools from source
and confirm? (You'll need the development meta-pkg installed in system
manager)

% svn co svn://svn.pcbsd.org/pcbsd/current/src-qt4 src-qt4
% cd src-qt4/libpcbsd
% qmake-qt4 *.pro
% sudo make install
% cd ../pc-netmanager/src/NetworkTray
% qmake-qt4 *.pro
% sudo make install

Then restart the network tray, by logging out / in. Does it fix the issue?
__________________
----
Kris Moore
PC-BSD Founder
Reply With Quote
  #10  
Old 07-19-2012, 09:01 PM
bds bds is offline
Senior Member
 
Join Date: Oct 2009
Posts: 502
Thanks: 72
Thanked 50 Times in 46 Posts
Default
Thanks, Kris,

your fix seems to have done the trick:

Code:
ps -auwwx | grep pc-nettray

[bridger@pcbsd-4853] ~% ps -auwwx | grep pc-nettray
root       15814   0.0  0.1  57260  4280 ??  I     4:56PM  0:00.01 sudo pc-nettray wlan0
root       20604   0.0  0.7 158132 21784 ??  S     4:57PM  0:00.20 pc-nettray wlan0
bridger    41988   0.0  0.1  16280  1888  0  S+    4:59PM  0:00.01 grep pc-nettray
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 09:34 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Copyright 2005-2010, The PC-BSD Project. PC-BSD and the PC-BSD logo are registered trademarks of iXsystems.
All other content is freely available for sharing under the terms of the Creative Commons Attribution License.