Reply
 
Thread Tools Display Modes
  #1  
Old 10-27-2011, 11:21 AM
shakky4711 shakky4711 is offline
Member
 
Join Date: Jun 2008
Posts: 31
Thanks: 0
Thanked 0 Times in 0 Posts
Default PC-BSD 9.0 RC1 Firefox does not start
Hello,

yesterday over night I updated my Beta with XFCE4 as Desktop to RC1. After the update the previous installes Firefox was gone. So I installed the PBI, install from 7.0.1 was running successful, but when I wanted to start it nothing happens.

Next try was to remove the PBI and install by PKG_ADD. While the installation some claims about newer versions than necessary appeared, but no really strange messages. The result was identical to the PBI, can not start Firefox, neither by pressing the start field in the start menu, nor starting by shell instruction.

The alternative webbrower Midori is starting and running without problems.
Does anybody know about this issue?

Thanks
Shakky4711
Reply With Quote
  #2  
Old 10-27-2011, 06:58 PM
Nukama Nukama is offline
Member
 
Join Date: Jul 2010
Posts: 50
Thanks: 1
Thanked 2 Times in 2 Posts
Default
Hi,

can you start a xterm an type "firefox" in it to start it from command line.
Then post the output here.

I've also problems running Firefox-7.0.1-i386, but 6.0.2 works on i386.
On my amd64 rigs Firefox-7.0.1 runs without problems.

firefox-6.0.2-i386 (working):
Code:
Gtk-Message: Failed to load module "atk-bridge"
Gtk-Message: Failed to load module "canberra-gtk-module"
Gtk-Message: Failed to load module "gail-gnome"
Gtk-Message: Failed to load module "gnomesegvhandler"

(firefox-bin:68072): GLib-GObject-WARNING **: gsignal.c:1149: unable to lookup signal "text-insert" for non instantiatable type `AtkText'
firefox-7.0.1-i386 (fail):
Code:
Gtk-Message: Failed to load module "atk-bridge"
Gtk-Message: Failed to load module "canberra-gtk-module"
Gtk-Message: Failed to load module "gail-gnome"
Gtk-Message: Failed to load module "gnomesegvhandler"
Illegal instruction

Last edited by Nukama; 10-27-2011 at 07:18 PM.
Reply With Quote
  #3  
Old 10-30-2011, 10:07 AM
shakky4711 shakky4711 is offline
Member
 
Join Date: Jun 2008
Posts: 31
Thanks: 0
Thanked 0 Times in 0 Posts
Default
When I start by shell command the response is "Illegal instruction".
Epiphany and Chromium run without problems on my i386 system. Maybe it is an issue based on the fact that I updated from beta to RC.

When I want to fill some free time I will make a fresh install and test again.
Reply With Quote
  #4  
Old 10-31-2011, 03:15 PM
kmoore134's Avatar
kmoore134 kmoore134 is offline
Administrator
 
Join Date: May 2005
Location: Knoxville, TN
Posts: 2,568
Thanks: 0
Thanked 163 Times in 127 Posts
Default PC-BSD 9.0 RC1 Firefox does not start
Try removing / re adding firefox. I know there was a bad binary patch
that went out for it at one point, not sure if that caused the issue here.
__________________
----
Kris Moore
PC-BSD Founder
Reply With Quote
  #5  
Old 10-31-2011, 06:01 PM
Nukama Nukama is offline
Member
 
Join Date: Jul 2010
Posts: 50
Thanks: 1
Thanked 2 Times in 2 Posts
Default
I've used pbi_delete and pbi_add several times, but with no good outcome, except for this pbi.
Code:
pbi_add ./firefox-6.0.2-i386.pbi 
Verifying Checksum...OK
Extracting to: /usr/pbi/firefox-i386
/tmp/.PBI.25505/.PBI-header.25505/post-install.sh: cannot create /boot/loader.conf: Permission denied
Installed: Firefox-6.0.2
But command line throws out an error for current firefox.pbi, which might be correlated to this problem.
Code:
pbi_add -r firefox
Downloading ftp://ftp.pcbsd.org/pub/mirror/PBI/www/firefox/9/x32/firefox-7.0.1-i386.pbi
/usr/pbi/.firefox-7.0.1-i386.pbi.21439        100% of  106 MB  781 kBps 00m00s

Verifying Checksum...OK
Extracting to: /usr/pbi/firefox-i386
ln: /home/user/lib/firefox/sdk/bin/xpidl: No such file or directory
Installed: Firefox-7.0.1
Reply With Quote
  #6  
Old 11-01-2011, 11:11 PM
bitraptor bitraptor is offline
Junior Member
 
Join Date: Aug 2011
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy PC-BSD 9.0 RC1 Firefox does not start
On my machine Firefox-7.0.1-i386 causes a Segmentation fault while starting.
Removed and reinstalled PBI - no change
deleted .mozilla folder - no change
Reply With Quote
  #7  
Old 11-27-2011, 06:25 AM
bitraptor bitraptor is offline
Junior Member
 
Join Date: Aug 2011
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy Problem persists in RC2
firefox ends with "Illegal instruction" at startup
installed firefox with pkg_add - works
Could it be that AppCafe is pulling in the x64 version of firefox even though I am on a x32 machine?
Reply With Quote
  #8  
Old 11-28-2011, 02:35 PM
kmoore134's Avatar
kmoore134 kmoore134 is offline
Administrator
 
Join Date: May 2005
Location: Knoxville, TN
Posts: 2,568
Thanks: 0
Thanked 163 Times in 127 Posts
Default Problem persists in RC2
Are you installing firefox via AppCafe or via command-line with pbi_add?
Can you send pbi_info over after you install firefox?
__________________
----
Kris Moore
PC-BSD Founder
Reply With Quote
  #9  
Old 11-28-2011, 07:38 PM
bitraptor bitraptor is offline
Junior Member
 
Join Date: Aug 2011
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default
I installed it via AppCafe
Architecture seems having been detected correctly, see output of pbi_info -v attached
Attached Files:
File Type: txt pbi_info.txt (2.0 KB, 1 views)
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 10:13 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Copyright 2005-2010, The PC-BSD Project. PC-BSD and the PC-BSD logo are registered trademarks of iXsystems.
All other content is freely available for sharing under the terms of the Creative Commons Attribution License.