Reply
 
Thread Tools Display Modes
  #1  
Old 09-12-2011, 08:19 PM
jimnorcal jimnorcal is offline
Junior Member
 
Join Date: Sep 2011
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default low screen resolution in virtualbox
After two failed installation attempts with MS Virtual PC (installing pcbsd), I downloaded Oracle's virtualbox and was able to install it easily. However, I'm having a display problem. The installation offered me a display of 1024x768 which I was fine with (I'm running 1680x1050 on my win7 x64 machine). However, when I starting playing around with PCBSD, I notice that the resolution is at 800x600. When going to the GUI hardware settings screen (system settings-hardware-display and monitor) to change the resolution, I see that 800x600 is the maximum it allows with the only other setting being 640x480. I opend up a terminal and went to /etc/X11/xorg.conf and saw under the Section "Screen" SubSection Modes was "1024x768" as it stated during setup. There were no other modes specified.

When it asked me for a graphics card during setup the default was Vesa if I remember correctly.
I tried switching to NVida (had some numbers after it but was the only nvidia choice) but that failed and it reverted me back to the default Vesa setting which I kept since I didn't know what else to chose. I'm running an NVida GTX 275 card but since I'm also running this install inside a virtual machine I don't really know how this works (and each VM is different, right?). I just want to get a higher resolution so everything isn't so compressed and hard to work with.
Reply With Quote
  #2  
Old 09-12-2011, 10:05 PM
daemon daemon is offline
Junior Member
 
Join Date: Nov 2010
Posts: 12
Thanks: 0
Thanked 2 Times in 2 Posts
Default
You'll need to install virtualbox-ose-additions inside PC-BSD to get a higher resolution.

As root
Code:
pkg_add -r virtualbox-ose-additons
or if you want to install from ports (again as root)

Code:
cd /usr/ports/emulators/virtualbox-ose-additions && make install clean
There will be a post install message informing that you need to add a couple of lines to /etc/rc.conf iirc
Reply With Quote
  #3  
Old 09-14-2011, 01:53 AM
jimnorcal jimnorcal is offline
Junior Member
 
Join Date: Sep 2011
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default
First I tried the first option:
pkg_add -r virtualbox-ose-additons

After that appeared to complete, nothing else was mentioned about having to configure anything else and nothing changed even after a reboot.

So, I tried your second command but I got an error about not having the required kernal sources so I found this page:
http://wiki.freebsd.org/VirtualBox

I followed the instruction by doing this first to get the newest files (or so I thought)
portsnap fetch update

That loaded a bunch of things.

Then I tried the make install clean command again and the command line is still saying:
===> virtualbox-ose-additions-4.0.12 requires kernel sources
*** Error code 1
Stop in /usr/ports/emulators/virtualbox-ose-additions.

In the meantime (thinking I had them installed for some reason) I did change things in the xorg.conf but I have not yet changed anything in the /boot/loader.conf file as directed (and the other requirements it states).

How am I supposed to get these kernal sources installed in an easy non-expert programmer manner, if there is such a thing?
Reply With Quote
  #4  
Old 09-14-2011, 09:01 AM
daemon daemon is offline
Junior Member
 
Join Date: Nov 2010
Posts: 12
Thanks: 0
Thanked 2 Times in 2 Posts
Default
Just double checked a PC-BSD running in a VM on Solaris, all I have installed is the additions package using pkg_add.

Try this before messing with the source tree etc,

Verify you have virtualbox-ose-additions installed with
Code:
pkg_info -Ix virtualbox
if not, reinstall it with
Code:
pkg_add -r virtualbox-ose-additions
Add this to /etc/rc.conf in the PC-BSD guest:
Code:
vboxguest_enable="YES"
vboxservice_enable="YES"
and reboot the VM.

HTH
Reply With Quote
  #5  
Old 09-15-2011, 04:42 AM
jimnorcal jimnorcal is offline
Junior Member
 
Join Date: Sep 2011
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default
virtualbox-ose-additions-3.2.12_1 VirtualBox additions for FreeBSD guests

trying another pkg_add just tells me that its already installed so that does nothing.

I had already added the two lines in /etc/rc.d
The resolution issue remains (800x600 max).

Maybe its a virtual box for windows glitch?
Reply With Quote
  #6  
Old 09-15-2011, 08:25 AM
daemon daemon is offline
Junior Member
 
Join Date: Nov 2010
Posts: 12
Thanks: 0
Thanked 2 Times in 2 Posts
Default
Must still be using the Vesa driver then.
When you boot the VM and you get the screen with PC-BSD at the top, hit any key, choose option 6 and then hit the return key.
In the menu that appears ensure that you choose vboxvideo.
Reply With Quote
  #7  
Old 09-15-2011, 02:06 PM
kmoore134's Avatar
kmoore134 kmoore134 is offline
Administrator
 
Join Date: May 2005
Location: Knoxville, TN
Posts: 2,568
Thanks: 0
Thanked 163 Times in 127 Posts
Default low screen resolution in virtualbox
Did you edit xorg.conf with the correct virtualbox driver?

Can you paste it here?
__________________
----
Kris Moore
PC-BSD Founder
Reply With Quote
  #8  
Old 09-23-2011, 06:38 AM
jimnorcal jimnorcal is offline
Junior Member
 
Join Date: Sep 2011
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default
Sorry for the delay. In the middle of a move in numerous other related activities.

Here's my /etc/rc.conf file:


background_dhclient="YES"
compat5x_enable="YES"
sshd_enable="YES"
devd_enable="YES"
devfs_system_ruleset="devfsrules_common"
ldconfig_paths="/usr/lib/compat /usr/local/lib /usr/local/kde4/lib /usr/local/lib/compat/pkg"

# Disable Sendmail by default
sendmail_enable="NONE"

# Enable console mouse
moused_type="auto"
moused_enable="YES"

# Enable the pcbsd startup / shutdown scripts
pcbsdinit_enable="YES"

#Enable samba server
samba_enable="YES"
winbindd_enable="YES"

# Disable LPD
lpd_enable="NO"

# Enable CUPS
cupsd_enable="YES"
linux_enable="YES"

# FSCK Enhancements
fsck_y_enable="YES"

# Denyhosts Startup
denyhosts_enable="YES"

# powerd: adaptive speed while on AC power, adaptive while on battery power
powerd_enable="YES"
powerd_flags="-a hiadaptive -b adaptive" # set CPU frequency

# enable HAL / DBUS
dbus_enable="YES"
hald_enable="YES"

# Enables support for HPLIP
hpiod_enable="NO"
hpssd_enable="NO"

# Enable the firewall
pf_rules="/etc/pf.conf"
pf_enable="YES"
pf_flags=""

# Enable sound-support
snddetect_enable="YES"
mixer_enable="YES"

# Enable avahi_daemon
avahi_daemon_enable="YES"

# Run the port jail
portjail_enable="YES"

# Added for sound support in the portjail, access to /dev/random, /dev/null, etc.
jail_pcbsd_devfs_enable="YES"

# Start the swapmonitor
swapmonitor_enable="YES"

# Enable IPV6 support
ipv6_enable="YES"

# Enable BSDStats
bsdstats_enable="YES"

# Enable webcamd
webcamd_enable="YES"

# Enable VirtualBox Higher Reolution
vboxguest_enable="YES"
vboxservice_enable="YES"


# Disable writing syslogs to remote devices by default
syslogd_flags="-ss"
warden_enable="YES"
ntpd_enable="YES"
ntpd_sync_on_start="YES"
keymap="us U.S..iso"
# Auto-Enabled NICs from pc-sysinstall
ifconfig_em0="DHCP"
hostname="sparkfire"


And here's my /X11/xorg.conf file:


# Xorg.conf file generated for PC-BSD

Section "ServerLayout"
Identifier "XFree86 Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
Option "Clone" "off"
EndSection

Section "ServerFlags"
Option "AutoAddDevices" "False"
Option "AllowEmptyInput" "Off"
EndSection

Section "Files"
ModulePath "/usr/local/lib/xorg/modules"
FontPath "/Programs/fonts/"
FontPath "/usr/local/lib/X11/fonts/cyrillic/"
FontPath "/usr/local/lib/X11/fonts/TrueType/"
FontPath "/usr/local/lib/X11/fonts/webfonts/"
FontPath "/usr/local/lib/X11/fonts/misc/"
FontPath "/usr/local/lib/X11/fonts/TTF/"
FontPath "/usr/local/lib/X11/fonts/Type1/"
FontPath "/usr/local/lib/X11/fonts/CID/"
FontPath "/usr/local/lib/X11/fonts/75dpi/"
FontPath "/usr/local/lib/X11/fonts/100dpi/"
FontPath "/usr/local/lib/X11/fonts/dejavu/"
FontPath "/usr/local/lib/X11/fonts/local/"
EndSection

Section "Module"
Load "ddc"
Load "dbe"
Load "extmod"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XkbVariant" ""
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/sysmouse"
Option "Buttons" "6"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
EndSection


Section "Device"
Identifier "Card0"
Screen 0
Driver "vesa"
VendorName "Generic Vesa Driver"
BusID "PCI:0:2:0"
EndSection


Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1024x768"
EndSubSection
EndSection


I could swear I changed my xorg.conf file to reflect the virtualbox changes as I saw on a previous website (that I mentioned in an earlier post in this thread). SO, I'm guessing the changes need to be made here:

Section "Device"
Identifier "Card0"
Screen 0
Driver "vesa"
VendorName "Generic Vesa Driver"
BusID "PCI:0:2:0"
EndSection

Just so I know I'm doing it right and not possibly following the wrong instructions somewhere, could you tell me what changes I need to make to that (and any other section in the rc.conf or xorg.conf files)?

Thank you for your help. Getting this running properly is a big deal to me as I want to be using this on a daily basis. I feel if I can it will be something I can call my own (in a way but much more so than bill's wallet fattening software).
Reply With Quote
  #9  
Old 09-23-2011, 06:45 AM
jimnorcal jimnorcal is offline
Junior Member
 
Join Date: Sep 2011
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default
This is what I had tried in the past before I must have changed my setting back to the original settings (I had a backup file with my test settings). I'm only including those sections of the xorg.conf file that I had changed but it made no difference.

Section "InputDevice"
Identifier "Mouse0"
Driver "vboxmouse"
Option "Protocol" "auto"
Option "Device" "/dev/sysmouse"
Option "Buttons" "6"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons"
EndSection

Section "Device"
Identifier "Card0"
Screen 0
Driver "vboxvideo"
VendorName "InnoTek Systemberatung Gmbh"
BusID "PCI:0:2:0"
EndSection
Reply With Quote
  #10  
Old 09-23-2011, 07:42 AM
jimnorcal jimnorcal is offline
Junior Member
 
Join Date: Sep 2011
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default Resolved
After I redid the settings in xorg.conf and restarted, I am now getting a 1024x768 screen res! YAY!
I don't understand why it didn't work for me previously. Obviously the first attempt went wrong somehow and my second attempt although I did the same thing appears to work great (after I changed the xorg.conf settings from my backup of the settings I tried earlier).

However, I just realized there's a new problem. Does the bottom panel typically only go about 3/4 of the way across. It's like its the same size as it was when the screen was 800x600.
Also, and worse yet, the mouse will not click anything. The help bubbles come up when I pause the mouse over things but I can't click anything. Is there a key combination to get a terminal up so I can remove the mouse setting from the xorg.conf file and reboot so I can end this mouse dilemma?

Edit (UPDATE): Somehow I was able to press the right key by accident enough to bring up a small terminal window, VI the xorg.conf file replacing the mouse entry with the old settings and did a reboot. The mouse now works as it did before but the bottom panel is still shorter than I would expect. I'm guessing that maybe it's supposed to be that way? In any case .. I'm content to play around with my bigger screen. On to the next pcbsd learning project. Perhaps now I'll learn C real fast and write some new cool software that will be so impressive that it will cause all windows users to convert over by years end.

Last edited by jimnorcal; 09-23-2011 at 08:26 AM. Reason: new information
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 08:34 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Copyright 2005-2010, The PC-BSD Project. PC-BSD and the PC-BSD logo are registered trademarks of iXsystems.
All other content is freely available for sharing under the terms of the Creative Commons Attribution License.