Reply
 
Thread Tools Display Modes
  #1  
Old 01-22-2011, 02:23 PM
sunburstgl sunburstgl is offline
Junior Member
 
Join Date: Jan 2011
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default WPA Enterprise Without Certificate
Hello, I just installed PC-BSD and I'm really liking it.
The one problem I am having is that my school's wireless network is WPA-Enterprise PEAP, but they don't use certificates.

I've added the wireless network, but when I configure it and select WPA Enterprise, it requires that I enter a certificate.

Is there any way around this?

Thank you.
Reply With Quote
  #2  
Old 01-24-2011, 03:46 PM
kmoore134's Avatar
kmoore134 kmoore134 is offline
Administrator
 
Join Date: May 2005
Location: Knoxville, TN
Posts: 2,568
Thanks: 0
Thanked 163 Times in 127 Posts
Default WPA Enterprise Without Certificate
I'll take a look at fixing that for 9, but in the meantime you can edit
/etc/wpa_supplicant.conf and take out the cert stuff, assuming you enter
a bogus one for now
__________________
----
Kris Moore
PC-BSD Founder
Reply With Quote
  #3  
Old 02-03-2012, 08:54 PM
stelyian stelyian is offline
Junior Member
 
Join Date: Feb 2012
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default
Hi,

i am new to this forum. Hmm, the thing is that i also use pc-bsd
on my primary computer in school and the school network is also
using wpa enterprise without an certificate , so is there any way
around this? Because, it won't let connect, but keeps asking for a
certificate ?!

Wpa_supplicant doesn't have an option certificate, there is nothing to remove ?

thanks,
stelyian

Last edited by stelyian; 02-03-2012 at 09:14 PM.
Reply With Quote
  #4  
Old 10-31-2012, 06:00 AM
BillC BillC is offline
Junior Member
 
Join Date: Oct 2012
Location: Sydney, Australia
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default
Hello,

I have a similar problem: at home WPA and WPA2 Personal and at work:

Security: WPA and WPA2 Enterprise
Authentication: Protected EAP (PEAP)
CA Certificate: None
PEAP version: automatic
Inner authentication: MSCHAPv2

The PCBSD graphical network configuration tool does not allow no CA certificate...

Using the examples in the wpa_supplicant man page (man wpa_supplicant) and the further explanation in wpa_supplicant.conf(5) (man 5 wpa_supplicant.conf) I modified my /etc/wpa_supplicant.conf file as follows and PCBSD now successfully connects to both networks


Code:
ctrl_interface=/var/run/wpa_supplicant

# Home
network={
 ssid="home_network"
 priority=1
 scan_ssid=1
 psk="pass_phrase"
}

# Work
network={
 ssid="work_network"
 scan_ssid=1
 key_mgmt=WPA-EAP
 eap=PEAP
 identity="username"
 password="pass_phrase"
# ca_cert=""
 phase1="peaplabel=0"
 phase2="auth=MSCHAPV2"
}
Note that the line ca_cert="" could of course be removed.

I hope this helps,
Bill
Reply With Quote
  #5  
Old 09-25-2013, 03:17 PM
drulavigne drulavigne is offline
Administrator
 
Join Date: Nov 2009
Posts: 1,126
Thanks: 45
Thanked 54 Times in 52 Posts
Default
Is this still an issue in 9.2? If so, please file a bug report at trac.pcbsd.org and post the bug number here.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 11:29 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Copyright 2005-2010, The PC-BSD Project. PC-BSD and the PC-BSD logo are registered trademarks of iXsystems.
All other content is freely available for sharing under the terms of the Creative Commons Attribution License.