Reply
 
Thread Tools Display Modes
  #1  
Old 01-07-2011, 12:45 AM
bawbaw bawbaw is offline
Junior Member
 
Join Date: Jan 2011
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Default Help: How to Set-up FTP server on PCBSD
Hi guys

Can you help me setting up an FTP server? , Im a Newbie on PCBSD and I would like to set-up an FTP server, Can you give me a Step by Step process on how to set-up?

btw.. Im a windows User ,Im a complete noob on PCBSD.

thanks.
Reply With Quote
  #2  
Old 01-07-2011, 05:21 AM
Ole Juul Ole Juul is offline
Senior Member
 
Join Date: Jan 2011
Location: Coalmont, BC, Canada
Posts: 284
Thanks: 0
Thanked 0 Times in 0 Posts
Default
I'm a complete newbie as well, but I've never used Windows. I was just looking for proftpd which is one of the standard ones in the *nix world and it seems that there is no such thing here, although I don't really believe that could be true. It's probably just my ignorance. Surely the FreeBSD port will work.

However, it might not matter that much, because for a desktop machine the single FTP server which is offered in the pbiDIR is probably just fine. It is called Bftpd and they claim it is easy to set up - though nothing could be easier than proftpd which has a single config file in the style of apache and has such a wide user base that any question can be answered with a quick Google. Anyway, I'm going to give Bftpd a try.
Reply With Quote
  #3  
Old 01-07-2011, 07:09 AM
bawbaw bawbaw is offline
Junior Member
 
Join Date: Jan 2011
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Default
I've already installed bftpd 3.0 my problem is I dont know where to find that and how to execute it.
Reply With Quote
  #4  
Old 01-07-2011, 08:11 AM
Ole Juul Ole Juul is offline
Senior Member
 
Join Date: Jan 2011
Location: Coalmont, BC, Canada
Posts: 284
Thanks: 0
Thanked 0 Times in 0 Posts
Default
Originally Posted by bawbaw View Post
I've already installed bftpd 3.0 my problem is I dont know where to find that and how to execute it.
I see. Well, it seems like you and I are on the same page right now. I installed it right now and rebooted to make sure the network was restarted and anything else which should be happening automatically. Mine did not work either.

There is something odd about the way PC-BSD does networking I think. I have FTP servers on Ubuntu Server, Kubuntu, and Debian running right now and they all worked out of the box. I have also had proftpd running on two of my FreeBSD machines without problem. I hope somebody who knows the quirks of PC-BSD answers soon.
Reply With Quote
  #5  
Old 01-07-2011, 12:58 PM
thnewguy thnewguy is offline
Senior Member
 
Join Date: May 2010
Posts: 845
Thanks: 5
Thanked 66 Times in 54 Posts
Default
To get Bftpd to start-up when you boot the machine, find where the bftpd executable is (probably /Programs/Bftpd/sbin/bftpd) and add that path to your /etc/rc.local file.

So your /etc/rc.local file will have a line in it that looks like this

/Programs/Bftpd/sbin/bftpd -d

That should be it. Well, actually, there is one more thing. The version PC-BSD comes with has a known security vulnerability in the configuration and you should edit the /etc/bftpd.conf file. At the bottom of the config file there is a section with the various special user accounts Bftpd recognizes. Make sure the "ftp" user section look like this:

Code:
user ftp {
  #Any password fits.
  ANONYMOUS_USER="yes"
  DENY_LOGIN="Anonymous login disabled."
  #ROOTDIR="/path/for/anonymous/user"
}
The Bftpd project fixed the security issue with version 3.1, but PC-BSD and FreeBSD still use 3.0. If you're running a firewall (such as a router), make sure you open port 21 in that firewall.
Reply With Quote
  #6  
Old 01-07-2011, 10:04 PM
Ole Juul Ole Juul is offline
Senior Member
 
Join Date: Jan 2011
Location: Coalmont, BC, Canada
Posts: 284
Thanks: 0
Thanked 0 Times in 0 Posts
Default
Thanks thnewguy. There was no /etc/rc.local file so I made one. It still didn't work. However, I found a problem. There is a firewall enabled by default. Since I have plenty of firewalling anyway, I just disabled it. Now ftp works.

Regarding anonymous ftp, this is not a public server and is for local use, so everybody will have an account anyway. Therefore I didn't bother with making a /etc/bftpd.conf file.

Anyway, I'm happy now. Hopefully bawbaw will have the same success.

Last edited by Ole Juul; 01-07-2011 at 10:31 PM.
Reply With Quote
  #7  
Old 01-07-2011, 10:15 PM
thnewguy thnewguy is offline
Senior Member
 
Join Date: May 2010
Posts: 845
Thanks: 5
Thanked 66 Times in 54 Posts
Default
I'm pretty sure Bftpd installs a configuration file for you, you don't have to make one. I recommend making sure anonymous FTP isn't enabled (see my previous post on how to do that). Better safe than sorry, right?
Reply With Quote
  #8  
Old 01-07-2011, 10:30 PM
Ole Juul Ole Juul is offline
Senior Member
 
Join Date: Jan 2011
Location: Coalmont, BC, Canada
Posts: 284
Thanks: 0
Thanked 0 Times in 0 Posts
Default
Originally Posted by thnewguy View Post
I'm pretty sure Bftpd installs a configuration file for you, you don't have to make one. I recommend making sure anonymous FTP isn't enabled (see my previous post on how to do that). Better safe than sorry, right?
Hmm, I didn't see the file, but you're right, it should have one. I'll investigate a little more but there is nothing remotely like that in /etc - hidden or otherwise. However I just tested anonymous and it doesn't work, so all is good there. This is only for local network use and I'm pretty well protected, but still, I want everything to at least need a password.
Reply With Quote
  #9  
Old 01-07-2011, 11:16 PM
thnewguy thnewguy is offline
Senior Member
 
Join Date: May 2010
Posts: 845
Thanks: 5
Thanked 66 Times in 54 Posts
Default
Since anonymous logins aren't working and you're just using it for LAN work, then it sounds like you've got all the bases covered.

In case you need to use th config file later it's probably in /Programs/Bftpd/etc
Reply With Quote
  #10  
Old 01-08-2011, 05:09 AM
Ole Juul Ole Juul is offline
Senior Member
 
Join Date: Jan 2011
Location: Coalmont, BC, Canada
Posts: 284
Thanks: 0
Thanked 0 Times in 0 Posts
Default
I just checked and there is a file called /Programs/Bftpd/bftpd.conf.sample, so it just needs to be edited and renamed. However, as noted, anonymous login doesn't work as is, so I'll leave the file alone since I have nothing else I need from it at the moment.

One thing I forgot to say (in case someone else comes across this thread later) is that when the firewall is disabled from the GUI, one has to tick a box to make the changes effective on boot.

@bawbaw: sorry for hijacking your thread. Hopefully you can use the same solution.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 12:15 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Copyright 2005-2010, The PC-BSD Project. PC-BSD and the PC-BSD logo are registered trademarks of iXsystems.
All other content is freely available for sharing under the terms of the Creative Commons Attribution License.