Reply
 
Thread Tools Display Modes
  #1  
Old 07-27-2010, 10:52 AM
bsdaddict bsdaddict is offline
Senior Member
 
Join Date: Nov 2008
Posts: 253
Thanks: 4
Thanked 1 Time in 1 Post
Default modify date and time in 8.1
Hi,
I just realised that i can not modify the date/time any more ! In System Settings, Date & Time, i see a message "You are not allowed to save the configuration".
Any modification i do gives me the following error message :
Unable to authenticate/execute the action: 4,
Sow how do i modify the time now ?
Reply With Quote
  #2  
Old 07-27-2010, 06:54 PM
Fatmice Fatmice is offline
Senior Member
 
Join Date: Feb 2008
Location: US
Posts: 888
Thanks: 0
Thanked 1 Time in 1 Post
Default
Were you root?
__________________
|================================================= =====|
|Please search the forum prior to posting. Intellectual laziness is not nice. | (Does not apply to non-offenders =))
|================================================= =====|
Reply With Quote
  #3  
Old 07-28-2010, 09:02 AM
bsdaddict bsdaddict is offline
Senior Member
 
Join Date: Nov 2008
Posts: 253
Thanks: 4
Thanked 1 Time in 1 Post
Default
No root, just normal user login. I don't even get the question/button to run it in Administrator Mode (like with the System Manager or the Services Manager).
Reply With Quote
  #4  
Old 07-28-2010, 09:52 AM
bsdaddict bsdaddict is offline
Senior Member
 
Join Date: Nov 2008
Posts: 253
Thanks: 4
Thanked 1 Time in 1 Post
Default
I seem to be not the only one with this problem : http://forum.kde.org/viewtopic.php?f=66&t=88528. Don't know if there is any solution yet.
Reply With Quote
  #5  
Old 07-28-2010, 12:15 PM
thnewguy thnewguy is offline
Senior Member
 
Join Date: May 2010
Posts: 844
Thanks: 5
Thanked 66 Times in 54 Posts
Default
Silly question: If you right-click on the clock on the taskbar to bring up its menu, can you adjust the date/time that way?
Reply With Quote
  #6  
Old 07-28-2010, 12:58 PM
kmoore134's Avatar
kmoore134 kmoore134 is offline
Administrator
 
Join Date: May 2005
Location: Knoxville, TN
Posts: 2,568
Thanks: 0
Thanked 163 Times in 127 Posts
Default modify date and time in 8.1
I still don't know why KDE4 doesn't have an "administrator" button in
the system-settings for tools which need root... But in the meantime,
give this a shot:

% kdesu kcmshell4 clock
__________________
----
Kris Moore
PC-BSD Founder
Reply With Quote
  #7  
Old 07-28-2010, 01:15 PM
bsdaddict bsdaddict is offline
Senior Member
 
Join Date: Nov 2008
Posts: 253
Thanks: 4
Thanked 1 Time in 1 Post
Default
@thnewguy : right clic does bring up the "Adjust date and time" and the "Digital clock settings", but does not permit to modify date and/or time settings.

@kmoor134 : that brings up the (same) screen to modify date & time, but with the same (error) message that i am not allowed to save the configuration.
I am stuck with the UTC timezone too. What is weird (for me) is that i can change in Country/Region settings on the Date & Time-tab but it seems to have no effect on the clock. Changing p. ex. the clock from ap/pm to 24hours display, changes nothing to the clock display, whick is still displaying in am/pm format. I changed my locale to Belgium with the US English language, no problem. I can change the currency to Euro, no problem. It even show ok at the bottom of the window. But it changes nothing in the clock.
I even (re)launched tzsetup to change my timezone to Brussels. The program starts up, i follow the instructions, but nothing changes. I get stuck in UTC as default local timezone.
Reply With Quote
  #8  
Old 07-28-2010, 08:11 PM
Fatmice Fatmice is offline
Senior Member
 
Join Date: Feb 2008
Location: US
Posts: 888
Thanks: 0
Thanked 1 Time in 1 Post
Default
Give sysinstall a shot. Run as root and change the date/time from there.
__________________
|================================================= =====|
|Please search the forum prior to posting. Intellectual laziness is not nice. | (Does not apply to non-offenders =))
|================================================= =====|
Reply With Quote
  #9  
Old 07-29-2010, 08:56 AM
bsdaddict bsdaddict is offline
Senior Member
 
Join Date: Nov 2008
Posts: 253
Thanks: 4
Thanked 1 Time in 1 Post
Default
It seems that modifying the Country/REgion settings does affect the clock settings ! Now i have a 24hour display with the correct locale... A logout/login should take care of the new settings i think (even if it is not shown as such).
But the original problem still remains : i am still not allowed to save the configuration in the Date & Time panel.
But the problem can be bypassed :-)
Reply With Quote
  #10  
Old 08-04-2010, 09:09 AM
SolarCatcher SolarCatcher is offline
Member
 
Join Date: Jul 2010
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Default
I just ran into the same problem: KDE displays the date/time setting to the normal user but complains only in the end that one does not have the rights to do the changes.

Being logged in as normal user also doesn't let you open the /usr/local/kde4/bin/systemsettings as root or with sudo. Logging-in to KDE as root is not allowed, either. So you cannot use the KDE tools in any way.

That left me with sysinstall, indeed. Which was easy. But I also had to change the clock display in KDE to reflect the changed time zone.

This leaves me with some suggestions: Could you take out (completely disable) the date/time setting from KDE to not confuse users about what they can change at what they can't? Furthermore, I think when I installed PC-BSD, I was asked to chose my location - but then it seems this information is not used to set the time zone correctly (I chose "Brussels" but ended up with UTC). I only noticed the problem when I received several e-mails a few hours in the past. Maybe the location could be used to set the correct time zone?

Best regards
SolarCatcher
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 06:00 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Copyright 2005-2010, The PC-BSD Project. PC-BSD and the PC-BSD logo are registered trademarks of iXsystems.
All other content is freely available for sharing under the terms of the Creative Commons Attribution License.