Reply
 
Thread Tools Display Modes
  #1  
Old 04-17-2010, 10:56 AM
hirohitosan hirohitosan is offline
Junior Member
 
Join Date: Mar 2009
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default updating ports
hi there!
I'm trying to get use with PCBSD. I want to upgrade my ports collection and do:
Code:
portsnap fetch update
...
/usr/ports was not created by portsnap.
You must run 'portsnap extract' before running 'portsnap update'.
the message is clear. My question is, if I run 'portsnap extract' I'll not destroy my existent /usr/ports collection?
And in this case how can I update my ports collections and update my system?

thanks
Reply With Quote
  #2  
Old 04-21-2010, 01:49 AM
rhyous rhyous is offline
Senior Member
 
Join Date: Aug 2005
Posts: 100
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to rhyous Send a message via MSN to rhyous Send a message via Yahoo to rhyous
Default
What do you mean it will destroy your existing ports system.

Yes, it will extract over the top, but it won't destroy it. It will also be an updated version of the ports tree, so your tree would be almost the same as if you updated it and didn't just extract.

If you have a manually created port, it won't be overwritten (mine aren't) though if you modified a regular port, you may loose your modifications.
__________________
Rhyous's 127.0.0.1 or ::1
http://www.rhyous.com
Reply With Quote
  #3  
Old 04-21-2010, 06:54 AM
hirohitosan hirohitosan is offline
Junior Member
 
Join Date: Mar 2009
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default
thanks rhyous for your reply.
The problem is that I cannot update my pcbsd box. I'm connected through a proxy server and my update manager cannot access the bdi's. For this I tried to update my ports using portsnap and I got that message, so I stopped.

So my question is how can I update my pc-bsd
Reply With Quote
  #4  
Old 04-21-2010, 01:04 PM
kmoore134's Avatar
kmoore134 kmoore134 is offline
Administrator
 
Join Date: May 2005
Location: Knoxville, TN
Posts: 2,568
Thanks: 0
Thanked 163 Times in 127 Posts
Default updating ports
Have you setup your proxy configuration in "system settings" yet? A good way to test is if Konqueror can connect to the internet. The update manager uses the same settings, so in theory once KDE is proxy enabled, it'll be able to connect as well. (If you need to enter a password before getting out to the web, then do so in Konq first, then try to run the update manager, does it connect now?)
__________________
----
Kris Moore
PC-BSD Founder
Reply With Quote
  #5  
Old 04-22-2010, 10:06 AM
hirohitosan hirohitosan is offline
Junior Member
 
Join Date: Mar 2009
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default
Originally Posted by kmoore134 View Post
Have you setup your proxy configuration in "system settings" yet?
thanks Kris. I set the proxy in Konqueror. Konqueror works fine but when I try to start Update Manager I got a popup window:
Code:
Failed to connect to pbidir!
Could not connect to host sysupdate.pcbsd.org: Timed out trying to connect to remote host.
Reply With Quote
  #6  
Old 04-22-2010, 01:56 PM
kmoore134's Avatar
kmoore134 kmoore134 is offline
Administrator
 
Join Date: May 2005
Location: Knoxville, TN
Posts: 2,568
Thanks: 0
Thanked 163 Times in 127 Posts
Default updating ports
I can see why the PBI browser may not work, since it uses QtWebKit, and
may not use the KDE proxy, however the system update tool should use the
proxy settings. Couple of things to check:

First, can you access FTP sites through your proxy? I.E in Konq, try
bringing up the following URL:

ftp://ftp.pcbsd.org/pub/snapshots/8/

Next, try going to system settings -> Network Settings.

Make sure your proxy information is entered, and maybe try using
persistant connections and/or entering your authentication data. Does
that make a difference? Also, you need to logout / log into KDE again
for the settings to take effect.

Lastly, and this MAY be the key, is checking the proxy settings as root:

run "kdesu systemsettings", then go to "Network Settings". Is your proxy
still configured there? Since the Software Manager runs in "root" mode,
it may not be pulling the proxy config from your user settings.
__________________
----
Kris Moore
PC-BSD Founder
Reply With Quote
  #7  
Old 04-23-2010, 09:08 AM
alek alek is offline
Junior Member
 
Join Date: Apr 2010
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default
Hi, all!
Thanks a lot, kmoore123.
Now I can update PBI soft through proxy. But I cannot install new soft because of:
Quote:
Error Code: 403 Forbidden. The ISA Server denied the specified Uniform Resource Locator (URL). (12202)
Although, I have check proxy settings with help of konqueror as you describe and did not met problems.
This is not very important as I can fetch PBI soft manually using pbidir.com. But it would be greate to fix this issue too.

Last edited by alek; 04-23-2010 at 09:12 AM.
Reply With Quote
  #8  
Old 04-23-2010, 10:57 AM
hirohitosan hirohitosan is offline
Junior Member
 
Join Date: Mar 2009
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default
Still have problems.
I set up proxy as simple user and root (kdesu systemsettings) System Settings -> Network Settings. I can browse Internet but I cannot connect through ftp.

Ubdate magager gives my the same message:
Code:
Failed to connect to pbidir!
what's wrong?
thanks

PS
I try to use firefox instead. I set up in firefox Edit->Preferences->Advanced-> Network-> Use system proxy settings and it doesn't connect. If I set Manual proxy configuration for all protocols I can connect both Internet and ftp.

Last edited by hirohitosan; 04-23-2010 at 11:21 AM.
Reply With Quote
  #9  
Old 04-23-2010, 11:29 AM
alek alek is offline
Junior Member
 
Join Date: Apr 2010
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default
Originally Posted by hirohitosan View Post
I can browse Internet but I cannot connect through ftp.
In my case I had the same problem with ftp. But I thought the root case of it is ftp works through the Internet directly.
I tried to solve it just set empty FTP field in KDE proxy settings but it does not help. Then I tried to setup proxy using .xprofile for both root & user account, just add next variables:
export HTTP_PROXY="http://<you IP address>:8080"
export HTTPS_PROXY="$HTTP_PROXY"

in case of ftp does not have direct connection try please to add
export FTP_PROXY="$HTTP_PROXY"

then reboot to load new environment variables.
Go to Proxy settings and choose load proxy settings from environment variables instead of set up it manually, repeat for root (really for user it is not necessary but do it just in case).
Try run update manager.
Reply With Quote
  #10  
Old 04-23-2010, 11:33 AM
alek alek is offline
Junior Member
 
Join Date: Apr 2010
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default
Originally Posted by hirohitosan View Post
I try to use firefox instead. I set up in firefox Edit->Preferences->Advanced-> Network-> Use system proxy settings and it doesn't connect. If I set Manual proxy configuration for all protocols I can connect both Internet and ftp.
No. you should use konqueror instead of firefox for clear experiment. Because konqueror have closer relationship to KDE than firefox. Please try konqueror before my above complicated way.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 02:59 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Copyright 2005-2010, The PC-BSD Project. PC-BSD and the PC-BSD logo are registered trademarks of iXsystems.
All other content is freely available for sharing under the terms of the Creative Commons Attribution License.