Reply
 
Thread Tools Display Modes
  #1  
Old 04-09-2010, 07:24 PM
bcrowell bcrowell is offline
Junior Member
 
Join Date: Apr 2010
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default packages won't install, want perl 5.8 instead of perl 5.10?
I have a fresh install of PC-BSD. The version of perl installed by
default from the DVD was 5.10. There are a whole bunch of packages
that I want to install using pkg_add, but when I try to add them,
I get errors like these:

root@pcbsd-6714# pkg_add -r libxul
Fetching
ftp://ftp.freebsd.org/pub/FreeBSD/ports ... e/Lat......
Done.
Fetching
ftp://ftp.freebsd.org/pub/FreeBSD/ports ... e/All......
Done.
pkg_add: package 'perl-5.8.9_3' conflicts with perl-5.10.1
pkg_add: please use pkg_delete first to remove conflicting package(s) or
-f to force installation
pkg_add: pkg_add of dependency 'perl-5.8.9_3' failed!

If I look at the FreshPorts entry for libxul,
http://www.freshports.org/www/libxul/ ,
it lists perl 5.8 under "required to build," but not under "required to
run."

How do I fix this?

Thanks,

-Ben
Reply With Quote
  #2  
Old 04-10-2010, 06:36 PM
bcrowell bcrowell is offline
Junior Member
 
Join Date: Apr 2010
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: packages won't install, want perl 5.8 instead of perl 5.10?
I'm still not having any luck solving this problem, and would be
grateful for any suggestions.

I tried doing pkg_add with the -f (force) option, but that still didn't
work.

To make sure that the problem wasn't something silly that I'd
inadvertently done to my system, I did a fresh install from the
PC-BSD DVD. After the fresh install, I did a reboot, opened an
xterm, and did "pkg_add -r aterm", and it resulted in the same
error about the perl dependency.
Reply With Quote
  #3  
Old 04-11-2010, 12:03 PM
Ian_Robinson Ian_Robinson is offline
Senior Member
 
Join Date: Jan 2007
Location: Salem, Ohio, U.S.
Posts: 328
Thanks: 0
Thanked 2 Times in 2 Posts
Default Re: packages won't install, want perl 5.8 instead of perl 5.10?
I don't know if I have an answer for you, but I have a suggestion you could try until someone with more know-how weighs in.

The program you want to install has been upgraded on March 28, 2010 which is after the release date for PCBSD 8.0. Perhaps that is good news for you or not. Even though a port is upgraded, packages do not get upgraded immediately, so perhaps you could build from ports.

Upgrade src and ports.

Code:
# csup -g -L 2 /root/standard-supfile

# portsnap fetch update
Code:
# portsnap fetch extract (if the first time)
Then try to install the libxul port.
Code:
# cd /usr/ports/www/libxul/ && make install clean
__________________
Ian
FitchKendall AT Gmail.com
Reply With Quote
  #4  
Old 06-17-2010, 01:18 AM
dralex999 dralex999 is offline
Junior Member
 
Join Date: Feb 2010
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Default
What I found is that firefox 3.5.9 needs perl 5.10. While many other ports like perl 5.8. So what I did was to use perl5.10 to build/install firefox 3.5.9 then I did a pkg_delete on perl 5.10. I installed and ran perl 5.8.9 from that point on and had no problems. I don't recommend that as your solution. What I'd recommend as your solution is to switch to PC-BSD 8.1-BETA. It seems to work fine with base perl package 5.10...I've had 8.1 running for two days now and haven't had a problem yet.
Reply With Quote
  #5  
Old 07-01-2010, 12:35 PM
THE JEW (RaVeN) THE JEW (RaVeN) is offline
Junior Member
 
Join Date: Jul 2010
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Default
Originally Posted by bcrowell View Post
I have a fresh install of PC-BSD. The version of perl installed by
default from the DVD was 5.10. There are a whole bunch of packages
that I want to install using pkg_add, but when I try to add them,
I get errors like these:

root@pcbsd-6714# pkg_add -r libxul
Fetching
ftp://ftp.freebsd.org/pub/FreeBSD/ports ... e/Lat......
Done.
Fetching
ftp://ftp.freebsd.org/pub/FreeBSD/ports ... e/All......
Done.
pkg_add: package 'perl-5.8.9_3' conflicts with perl-5.10.1
pkg_add: please use pkg_delete first to remove conflicting package(s) or
-f to force installation
pkg_add: pkg_add of dependency 'perl-5.8.9_3' failed!

If I look at the FreshPorts entry for libxul,
http://www.freshports.org/www/libxul/ ,
it lists perl 5.8 under "required to build," but not under "required to
run."

How do I fix this?

Thanks,

-Ben
Did you try removing the problem package and reinstalling?
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Creating Perl DBI Module Error rufino General Questions 2 04-08-2008 03:59 AM
Cannot install Perl Audio Converter from ports tommy_yanez Sound and Multimedia 4 02-26-2008 02:24 AM
perl Gtk how do I get mgreen General Questions 1 12-11-2007 10:22 PM
Irssi won't start - perl related surfbass General Bug Reports 0 09-09-2005 09:40 AM
0.78 perl error General Questions 10 07-30-2005 10:08 PM


All times are GMT. The time now is 07:08 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Copyright 2005-2010, The PC-BSD Project. PC-BSD and the PC-BSD logo are registered trademarks of iXsystems.
All other content is freely available for sharing under the terms of the Creative Commons Attribution License.