Reply
 
Thread Tools Display Modes
  #1  
Old 02-24-2010, 02:38 AM
a_bateman a_bateman is offline
Junior Member
 
Join Date: Feb 2010
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default wireless stuck at associated
I just installed PC-BSD 8.0 after using 7.X for a while, with which the wireless worked perfectly.

After installing wireless and setting up my network just as it was in 7.X the wireless sticks at associated and never makes it to being up.

Any suggestions are appreciated.

Thanks
-Andrew
Reply With Quote
  #2  
Old 02-24-2010, 03:01 AM
Fatmice Fatmice is offline
Senior Member
 
Join Date: Feb 2008
Location: US
Posts: 888
Thanks: 0
Thanked 1 Time in 1 Post
Default Re: wireless stuck at associated
Your wireless driver?

I only know how to setup via CLI ... Never used that network interface or whatever...

What does ifconfig say?
__________________
|================================================= =====|
|Please search the forum prior to posting. Intellectual laziness is not nice. | (Does not apply to non-offenders =))
|================================================= =====|
Reply With Quote
  #3  
Old 02-24-2010, 03:09 AM
a_bateman a_bateman is offline
Junior Member
 
Join Date: Feb 2010
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: wireless stuck at associated
for wireless ifconfig says:

Quote:
wpi0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 2290
ether 00:1a:4b:60:4d:24
media: IEEE 802.11 Wireless Ethernet autoselect mode 11g
status: associated
Reply With Quote
  #4  
Old 02-24-2010, 03:51 AM
Fatmice Fatmice is offline
Senior Member
 
Join Date: Feb 2008
Location: US
Posts: 888
Thanks: 0
Thanked 1 Time in 1 Post
Default Re: wireless stuck at associated
what does ifconfig wpi0 scan say?

If you know your ssid and use WEP encryption, the following should get you back on the network

1/ Escalate to super-user, ssid name must have quotes

Code:
ifconfig wpi0 ssid "name of ssid" wepmode on wepkey "your key" weptxkey 1 up
Example

Code:
ifconfig wpi0 ssid "bubba" wepmode on wepkey 0x8372ABAAFFAB39285012478925 weptxkey 1 up
__________________
|================================================= =====|
|Please search the forum prior to posting. Intellectual laziness is not nice. | (Does not apply to non-offenders =))
|================================================= =====|
Reply With Quote
  #5  
Old 02-24-2010, 03:54 AM
a_bateman a_bateman is offline
Junior Member
 
Join Date: Feb 2010
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: wireless stuck at associated
They decided not to encrypt the connection (shows I didnt set it up).

ifconfig wpi0 scan returns:

Quote:
ifconfig: unable to get scan results
Reply With Quote
  #6  
Old 02-24-2010, 04:07 AM
Fatmice Fatmice is offline
Senior Member
 
Join Date: Feb 2008
Location: US
Posts: 888
Thanks: 0
Thanked 1 Time in 1 Post
Default Re: wireless stuck at associated
Okay. So I guess you must create a wireless lan device from it....

Code:
ifconfig wlan0 create wlandev wpi0
then do

Code:
ifconfig wlan0 scan
if the scan gives you something then choose the corrent ssid and join it.

Code:
ifconfig wlan0 ssid "ssidname" up
__________________
|================================================= =====|
|Please search the forum prior to posting. Intellectual laziness is not nice. | (Does not apply to non-offenders =))
|================================================= =====|
Reply With Quote
  #7  
Old 02-24-2010, 01:39 PM
a_bateman a_bateman is offline
Junior Member
 
Join Date: Feb 2010
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: wireless stuck at associated
thanks for the help. I got it to work... it just sticks at associated now.
Reply With Quote
  #8  
Old 02-25-2010, 02:07 AM
Fatmice Fatmice is offline
Senior Member
 
Join Date: Feb 2008
Location: US
Posts: 888
Thanks: 0
Thanked 1 Time in 1 Post
Default Re: wireless stuck at associated
Wonderful.

Could you step through what you did so that others could follow in the future?

Thanks.

BTW. Could you cat and give the content of your /etc/rc.conf
__________________
|================================================= =====|
|Please search the forum prior to posting. Intellectual laziness is not nice. | (Does not apply to non-offenders =))
|================================================= =====|
Reply With Quote
  #9  
Old 02-26-2010, 01:23 PM
a_bateman a_bateman is offline
Junior Member
 
Join Date: Feb 2010
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: wireless stuck at associated
Thanks for all the help Fatmice.

I didn't really do much to get it working but here are my steps:

1. I configured the wireless network in system settings.

2. I then closed the system settings and waited a few minutes to see if the network would connect.

3. I went back into the system settings and checked the box to show the network connections in my system tray and after a few minutes the network was working even though it was still saying associated.


cating /etc/rc.conf returns:

Code:
background_dhclient="YES"                                
compat5x_enable="YES"                                    
sshd_enable="YES"                                        
usbd_enable="YES"                                        
devd_enable="YES"                                        
devfs_system_ruleset="devfsrules_common"                 
ldconfig_paths="/usr/lib/compat /usr/local/lib /usr/local/kde4/lib /usr/local/lib/compat/pkg"                                                                   

# Disable Sendmail by default
sendmail_enable="NONE"       

# Enable console mouse
moused_type="auto"    
moused_enable="YES"   

# Enable the pcbsd startup / shutdown scripts
pcbsdinit_enable="YES"                       
                                             
#Enable samba server                         
samba_enable="YES"                           
winbindd_enable="YES"                        
                                             
# Disable LPD                                
lpd_enable="NO"                              
                                             
# Enable CUPS                                
cupsd_enable="YES"                           
linux_enable="YES"                           
                                             
# FSCK Enhancements                          
fsck_y_enable="YES"                          
background_fsck="NO"                         
                                             
# Denyhosts Startup                          
denyhosts_enable="YES"                       

# powerd: adaptive speed while on AC power, adaptive while on battery power
# WARNING: May cause crashes with nvidia driver                            
#powerd_enable="YES"                                                       
#powerd_flags="-a adaptive -b adaptive" # set CPU frequency                

# enable HAL / DBUS
dbus_enable="YES"  
polkitd_enable="YES"
hald_enable="YES"   

# Enables support for HPLIP
hpiod_enable="NO"          
hpssd_enable="NO"          

# Enable the firewall
pf_rules="/etc/pf.conf"
pf_enable="YES"        
pf_flags=""

# Enable ipfw and open it by default since we have PF
firewall_enable="YES"
firewall_type="open"

# Enable sound-support
snddetect_enable="YES"
mixer_enable="YES"

# Enable avahi_daemon
avahi_daemon_enable="YES"

# Run the port jail
portjail_enable="YES"

# Added for sound support in the portjail, access to /dev/random, /dev/null, etc.
jail_pcbsd_devfs_enable="YES"

# Start the swapmonitor
swapmonitor_enable="YES"

# Enable IPV6 support
ipv6_enable="YES"

# Enable BSDStats
bsdstats_enable="YES"
ntpd_enable="YES"
ntpd_sync_on_start="YES"
keymap="us.iso"
# Auto-Enabled NICs from pc-sysinstall
ifconfig_bge0="up"
ifconfig_wpi0="`ifconfig bge0 ether`"
ifconfig_wpi0="ether ${ifconfig_wpi0##*ether }"
wlans_wpi0="wlan0"
cloned_interfaces="lagg0"
ifconfig_lagg0="laggproto failover laggport bge0 laggport wlan0 DHCP"
hostname="pcbsd-7166"
ifconfig_wlan0="WPA"
Reply With Quote
  #10  
Old 02-26-2010, 07:29 PM
Fatmice Fatmice is offline
Senior Member
 
Join Date: Feb 2008
Location: US
Posts: 888
Thanks: 0
Thanked 1 Time in 1 Post
Default Re: wireless stuck at associated
Quote:
# Auto-Enabled NICs from pc-sysinstall
ifconfig_bge0="up"
ifconfig_wpi0="`ifconfig bge0 ether`"
ifconfig_wpi0="ether ${ifconfig_wpi0##*ether }"
wlans_wpi0="wlan0"
cloned_interfaces="lagg0"
ifconfig_lagg0="laggproto failover laggport bge0 laggport wlan0 DHCP"
hostname="pcbsd-7166"
ifconfig_wlan0="WPA"
Let us know when it starts to break.
__________________
|================================================= =====|
|Please search the forum prior to posting. Intellectual laziness is not nice. | (Does not apply to non-offenders =))
|================================================= =====|
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Stuck in a Login Loop numbersix6 Installing PC-BSD 4 10-31-2008 03:35 AM
FreeBSD 7 stuck at loader nickbsd FreeBSD Help 13 10-05-2008 06:00 AM
Wine Help - Stuck randy General Questions 2 04-06-2008 02:40 AM
Stuck in Read-Only Mode nexus General Support 2 01-28-2007 05:30 AM
Install stuck on HD setup pg Startup Bug Reports (read-only) 0 10-10-2006 10:14 AM


All times are GMT. The time now is 08:25 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Copyright 2005-2010, The PC-BSD Project. PC-BSD and the PC-BSD logo are registered trademarks of iXsystems.
All other content is freely available for sharing under the terms of the Creative Commons Attribution License.