Reply
 
Thread Tools Display Modes
  #1  
Old 05-09-2009, 09:53 PM
bforest bforest is offline
Senior Member
 
Join Date: Feb 2009
Location: Va, USofA
Posts: 161
Thanks: 11
Thanked 8 Times in 6 Posts
Default Please advise on touchpad install/config attempt.
Hello,

I have a SONY VGN-UX280P and I would like to get the TouchScreen working.
(motion eye cameras too)

http://esupport.sony.com/US/perl/swu-li ... =VGNUX280P

I have PCBSD 7.1 installed and it seems to be running properly.

Code:
/home/user(102)% uname -a
FreeBSD pcbsd 7.2-PRERELEASE 
FreeBSD 7.2-PRERELEASE #12: Fri Apr 17 15:37:58 EDT 2009     
root@pcbsdx32-7:/usr/obj/pcbsd-build71/cvs/7.1-src/sys/PCBSD  i386
dmesg output is below (at end of post)

I located some references to getting this touch screen working and hope
someone can look it over and provide additional pointers as to how to
implement this on FreeBSD/PCBSD.

http://tuxmobil.org/sony.html
http://stz-softwaretechnik.com/~ke/touc ... touch.html

Thanks in advance for any assistance you might provide!

-Ben


Code:
/home/user(108)% dmesg
Copyright (c) 1992-2009 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 7.2-PRERELEASE #12: Fri Apr 17 15:37:58 EDT 2009
    root@pcbsdx32-7:/usr/obj/pcbsd-build71/cvs/7.1-src/sys/PCBSD
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Genuine Intel(R) CPU           U1400  @ 1.20GHz (1197.01-MHz 686-class CPU)
  Origin = "GenuineIntel"  Id = 0x6e8  Stepping = 8
  Features=0xafe9fbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE
,SSE2,SS,TM,PBE>
  Features2=0xc1a9<SSE3,MON,VMX,EST,TM2,xTPR,PDCM>
  AMD Features=0x100000<NX>
real memory  = 1063780352 (1014 MB)
avail memory = 1027235840 (979 MB)
ACPI APIC Table: <Sony N2>
ioapic0 <Version 2.0> irqs 0-23 on motherboard
kbd1 at kbdmux0
acpi0: <Sony> on motherboard
acpi0: [ITHREAD]
Timecounter "ACPI-safe" frequency 3579545 Hz quality 850
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x1008-0x100b on acpi0
acpi_ec0: <Embedded Controller: GPE 0x17> port 0x62,0x66 on acpi0
acpi_button0: <Power Button> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
vgapci0: <VGA-compatible display> port 0x1800-0x1807 mem 0xd4200000-0xd427ffff,0xc0000000-0xcfffffff,0xd4300000-0xd43
3ffff irq 16 at device 2.0 on pci0
agp0: <Intel 82945GM (945GM GMCH) SVGA controller> on vgapci0
agp0: detected 7932k stolen memory
agp0: aperture size is 256M
vgapci1: <VGA-compatible display> mem 0xd4280000-0xd42fffff at device 2.1 on pci0
pci0: <multimedia, HDA> at device 27.0 (no driver attached)
pcib1: <ACPI PCI-PCI bridge> irq 16 at device 28.0 on pci0
pci2: <ACPI PCI bus> on pcib1
wpi0: <Intel(R) PRO/Wireless 3945ABG> mem 0xd2000000-0xd2000fff irq 16 at device 0.0 on pci2
wpi0: Ethernet address: 00:18:xx:xx:xx:xx
wpi0: [ITHREAD]
pcib2: <ACPI PCI-PCI bridge> irq 17 at device 28.1 on pci0
pci6: <ACPI PCI bus> on pcib2
mskc0: <Marvell Yukon 88E8036 Gigabit Ethernet> port 0x3000-0x30ff mem 0xd4000000-0xd4003fff irq 17 at device 0.0 on 
pci6
msk0: <Marvell Technology Group Ltd. Yukon FE Id 0xb7 Rev 0x01> on mskc0
can't re-use a leaf (jabbers)!
msk0: disabling jumbo frame support
msk0: Ethernet address: 00:13:xx:xx:xx:xx
miibus0: <MII bus> on msk0
e1000phy0: <Marvell 88E3082 10/100 Fast Ethernet PHY> PHY 0 on miibus0
e1000phy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
mskc0: [FILTER]
uhci0: <UHCI (generic) USB controller> port 0x1820-0x183f irq 17 at device 29.0 on pci0
uhci0: [GIANT-LOCKED]
uhci0: [ITHREAD]
usb0: <UHCI (generic) USB controller> on uhci0
usb0: USB revision 1.0
uhub0: <Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb0
uhub0: 2 ports with 2 removable, self powered
uhci1: <UHCI (generic) USB controller> port 0x1840-0x185f irq 19 at device 29.1 on pci0
uhci1: [GIANT-LOCKED]
uhci1: [ITHREAD]
usb1: <UHCI (generic) USB controller> on uhci1
usb1: USB revision 1.0
uhub1: <Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb1
uhub1: 2 ports with 2 removable, self powered
uhci2: <UHCI (generic) USB controller> port 0x1860-0x187f irq 21 at device 29.2 on pci0
uhci2: [GIANT-LOCKED]
uhci2: [ITHREAD]
usb2: <UHCI (generic) USB controller> on uhci2
usb2: USB revision 1.0
uhub2: <Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb2
uhub2: 2 ports with 2 removable, self powered
uhci3: <UHCI (generic) USB controller> port 0x1880-0x189f irq 17 at device 29.3 on pci0
uhci3: [GIANT-LOCKED]
uhci3: [ITHREAD]
usb3: <UHCI (generic) USB controller> on uhci3
usb3: USB revision 1.0
uhub3: <Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb3
uhub3: 2 ports with 2 removable, self powered
ehci0: <Intel 82801GB/R (ICH7) USB 2.0 controller> mem 0xd4544000-0xd45443ff irq 23 at device 29.7 on pci0
ehci0: [GIANT-LOCKED]
ehci0: [ITHREAD]
usb4: EHCI version 1.0
usb4: companion controllers, 2 ports each: usb0 usb1 usb2 usb3
usb4: <Intel 82801GB/R (ICH7) USB 2.0 controller> on ehci0
usb4: USB revision 2.0
uhub4: <Intel EHCI root hub, class 9/0, rev 2.00/1.00, addr 1> on usb4
uhub4: 8 ports with 8 removable, self powered
uhub5: <NECEL USB2.0 Hub, class 9/0, rev 2.00/1.00, addr 2> on uhub4
uhub5: single transaction translator
uhub5: 3 ports with 3 removable, self powered
ugen0: <vendor 0x05ca product 0x1832, class 0/0, rev 2.00/1.00, addr 3> on uhub4
pcib3: <ACPI PCI-PCI bridge> at device 30.0 on pci0
pci7: <ACPI PCI bus> on pcib3
cbb0: <PCI-CardBus Bridge> at device 4.0 on pci7
cardbus0: <CardBus bus> on cbb0
pccard0: <16-bit PCCard bus> on cbb0
cbb0: [ITHREAD]
fwohci0: <1394 Open Host Controller Interface> mem 0xd4105000-0xd41057ff,0xd4100000-0xd4103fff irq 21 at device 4.1 on pci7
fwohci0: [FILTER]
fwohci0: OHCI version 1.10 (ROM=1)
fwohci0: No. of Isochronous channels is 4.
fwohci0: EUI64 08:00:46:03:02:27:7e:ee
fwohci0: Phy 1394a available S400, 2 ports.
fwohci0: Link S400, max_rec 2048 bytes.
firewire0: <IEEE1394(FireWire) bus> on fwohci0
fwe0: <Ethernet over FireWire> on firewire0
if_fwe0: Fake Ethernet address: 0a:00:46:27:7e:ee
fwe0: Ethernet address: 0a:00:46:27:7e:ee
fwip0: <IP over FireWire> on firewire0
fwip0: Firewire address: 08:00:46:03:02:27:7e:ee @ 0xfffe00000000, S400, maxrec 2048
sbp0: <SBP-2/SCSI over FireWire> on firewire0
dcons_crom0: <dcons configuration ROM> on firewire0
dcons_crom0: bus_addr 0x3e410000
fwohci0: Initiate bus reset
fwohci0: BUS reset
fwohci0: node_id=0xc000ffc0, gen=1, CYCLEMASTER mode
pci7: <mass storage> at device 4.2 (no driver attached)
isab0: <PCI-ISA bridge> at device 31.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <Intel ICH7 UDMA100 controller> port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0x1810-0x181f at device 31.1 on pci0
ata0: <ATA channel 0> on atapci0
ata0: [ITHREAD]
pci0: <serial bus, SMBus> at device 31.3 (no driver attached)
acpi_tz0: <Thermal Zone> on acpi0
acpi_tz1: <Thermal Zone> on acpi0
acpi_tz2: <Thermal Zone> on acpi0
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
atkbd0: [ITHREAD]
psm0: <PS/2 Mouse> flags 0x1000 irq 12 on atkbdc0
psm0: [GIANT-LOCKED]
psm0: [ITHREAD]
psm0: model GlidePoint, device ID 0
battery0: <ACPI Control Method Battery> on acpi0
acpi_acad0: <AC Adapter> on acpi0
cpu0: <ACPI CPU> on acpi0
est0: <Enhanced SpeedStep Frequency Control> on cpu0
p4tcc0: <CPU Frequency Thermal Control> on cpu0
pmtimer0 on isa0
orm0: <ISA Option ROMs> at iomem 0xc0000-0xcffff,0xd0000-0xd0fff,0xdc000-0xdffff pnpid ORM0000 on isa0
ppc0: parallel port not found.
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio0: configured irq 4 not in bitmap of probed irqs 0
sio0: port may not be enabled
sio0: configured irq 4 not in bitmap of probed irqs 0
sio0: port may not be enabled
sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
sio0: type 8250 or not responding
sio0: [FILTER]
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
ums0: <Kensington Kensington Ci75m Wireless Notebook Mouse, class 0/0, rev 1.10/1.12, addr 2> on uhub0
ums0: 3 buttons and Z dir.
uhub1: device problem (STALLED), disabling port 1
ugen1: <STMicroelectronics Biometric Coprocessor, class 0/0, rev 1.00/0.01, addr 2> on uhub2
ugen2: <ALPS UGX, class 224/1, rev 2.00/19.15, addr 2> on uhub3
Timecounter "TSC" frequency 1197009270 Hz quality 800
Timecounters tick every 1.000 msec
ipfw2 (+ipv6) initialized, divert enabled, nat loadable, rulfirewire0: 1 nodes, maxhop <= 0, cable IRM = 0 (me)
firewire0: bus manager 0 (me)
e-based forwarding disabled, default to accept, logging disabled
ad0: 38147MB <TOSHIBA MK4009GAL BS111A> at ata0-master UDMA100
Trying to mount root from ufs:/dev/ad0s2a
wpi0: timeout resetting Tx ring 1
wpi0: timeout resetting Tx ring 3
wpi0: timeout resetting Tx ring 4
msk0: link state changed to UP
hdac0: <Intel 82801G High Definition Audio Controller> mem 0xd4340000-0xd4343fff irq 19 at device 27.0 on pci0
hdac0: HDA Driver Revision: 20090131_0127
hdac0: [ITHREAD]
hdac0: HDA Codec #0: Realtek ALC262
pcm0: <HDA Realtek ALC262 PCM #0 Analog> at cad 0 nid 1 on hdac0
pcm1: <HDA Realtek ALC262 PCM #1 Analog> at cad 0 nid 1 on hdac0
wpi0: link state changed to UP
drm0: <Intel i945GM> on vgapci0
vgapci0: child drm0 requested pci_enable_busmaster
info: [drm] AGP at 0xc0000000 256MB
info: [drm] Initialized i915 1.6.0 20080730
drm0: [ITHREAD]
pid 2530 (nepomukservicestub), uid 1001: exited on signal 6
wpi0: link state changed to DOWN
__________________
- Ben
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
OS upgrade attempt destroyed the OS Kafpauzo Startup Bug Reports (read-only) 5 08-06-2008 08:52 PM
[fixed] 1st LONG use attempt at BSD w/ bumps in the road... angryfirelord General Questions 17 08-01-2007 12:45 AM
1.3 Success and failure please advise robinreplab General Questions 7 01-08-2007 07:49 PM
Averatec touchpad rcengland General Support 24 06-27-2006 12:26 PM
Advise for multiboot installation martincho Installing PC-BSD 1 08-29-2005 03:14 AM


All times are GMT. The time now is 11:29 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Copyright 2005-2010, The PC-BSD Project. PC-BSD and the PC-BSD logo are registered trademarks of iXsystems.
All other content is freely available for sharing under the terms of the Creative Commons Attribution License.