Reply
 
Thread Tools Display Modes
  #1  
Old 01-04-2009, 10:49 AM
hawei hawei is offline
Junior Member
 
Join Date: Jan 2009
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default desktop window
After hours of reading and trial&error I cannot find out how to change the position and size of the desktop window sitting in the upper left corner of my display surface.
I've dragged&dropped the gimp application on both the desktop window where it is totally inactive, and on the remaining display surface where it is active as usual. But on a terminal both icons seem desperately invisible.
Could somebody tell me where to find a description of the pcbsd desktop philosophy which seems to be unlike the standard one, e. g. MacOSX or Ubuntu ?
Nevertheless, I've understood two things:
1. One can display any directory on the desktop window, for example /mnt.
2. Depending on the number of items, there is a scroll bar or not.

What I cannot understand:
How is it possible that no other user ever asked the same questions ? :-)

Thank you in advance.
Reply With Quote
  #2  
Old 01-04-2009, 05:19 PM
bekins bekins is offline
Junior Member
 
Join Date: Dec 2008
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: desktop window
To move or change the size of the desktop window you have to first unlock the widgets. You can do this either by right clicking on the taskbar, or by clicking on the yellow cashew icon thingy in the very upper right hand corner of the screen. After the widgets are unlocked just click and drag the very top of the desktop window to move it. To change the size of the desktop window move your cursor to the very right edge of the desktop window until see a bunch of icons on the side. You should see a blue resize box on the very top, a purple arrow, a silver wrench, and a red X. Click and drag your cursor on the blue box to change the size and shape of the desktop window. Be warned that changing the size is somewhat akward with this version of KDE so expect some trial and error. It's up to you if you want to lock the widgets after you are finished.
Reply With Quote
  #3  
Old 01-05-2009, 10:09 AM
hawei hawei is offline
Junior Member
 
Join Date: Jan 2009
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: desktop window
Thank you very much indeed. Positioning and resizing work fine.
I still have two questions.
1. If I lose the desktop window in the event of finger trouble (or on purpose), is there a way to get it back without removing the
.kde* directories in $HOME ?
2. Why can't I see the application icon I've dropped onto the "root" desktop (i.e. outside the desktop window) on a terminal window ?
Reply With Quote
  #4  
Old 01-06-2009, 07:18 AM
bekins bekins is offline
Junior Member
 
Join Date: Dec 2008
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: desktop window
To add the desktop window you can always add a widget in case it ever gets lost. The widget that is used for the desktop window is the folder view widget. I think the default folder is the home folder (not the desktop folder), but you can always change the folder to whatever folder you want later on in the options section (the silver wrench icon). Just remember if you choose the add a widget option from the taskbar it will add the desktop window widget (or whatever widget) to your taskbar. If you want the widget on your desktop then click on the yellow icon in the upper right corner.
I don't have any answer for your second question. Hopefully someone else can answer that.
Reply With Quote
  #5  
Old 01-07-2009, 06:24 PM
hawei hawei is offline
Junior Member
 
Join Date: Jan 2009
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: desktop window
Thank you again.
I've got another stupid question:
While playing with the panel widgets I've lost the original volume control widget. How can I get it back, this one ? I can't find it in the widget list.
The Multimedia>Sound Mixer (KMix) does not seem to work. It does start but exits after 30 seconds or so.
I have of course installed the rexima port which does run like a charm. But rexima is not the type of tool for the user for whom I've installed PC-BSD :-)
Oh, there is yet another question: How can I get rid of the dancing icon near the mouse pointer during the application starting period? It is sometimes really annoying.
Reply With Quote
  #6  
Old 01-08-2009, 10:33 AM
bekins bekins is offline
Junior Member
 
Join Date: Dec 2008
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: desktop window
Here is the link to the kde docs to compile and install the Kmix volume control
http://docs.kde.org/stable/en/kdemultim ... ation.html

To get rid of the bouncing icon open up the system settings. Under the look and feel section you should see icons for appearance, desktop, notifications, and window behavior. Click on the desktop option. In the desktop options there should be four icons on the left. Click on the bottom Launch Feedback icon. Click on the drop down box to change it from the default Bouncing Cursor, to No Busy Cursor and apply the changes.
Reply With Quote
  #7  
Old 01-08-2009, 05:03 PM
hawei hawei is offline
Junior Member
 
Join Date: Jan 2009
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: desktop window
Thank you for the bouncing icon. That was really simple. I'm ashamed.

As to kmix, I've found kdemultimedia-4.1.85.tar.bz2. There is a kmix directory in there. But I cannot see any Makefile. Bizarre.

I don't really bother about kmix (which does not work for some reason), if I could get back the original volume control without removing the .kde* directories in $HOME (which seems to me a clumsy procedure). The icon of the original volume control is different from the kmix icon. So I guess that the underlying program is not the same, is it?
Reply With Quote
  #8  
Old 01-09-2009, 05:13 AM
bekins bekins is offline
Junior Member
 
Join Date: Dec 2008
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: desktop window
Do you know if KMix is still installed and working properly? If it is, then it should still show up in the System Monitor. To lauch the System Monitor Click on KDE "start" button, go to the Applications tab on the bottom, click on the System option and scroll down until you find it. If you have trouble finding the KMix process in the System Monitor you can always type KMix into the box at the top.

If KMix is still installed and working properly, then you should be able to get the icon back onto the panel by pressing Alt + F2 at the same time. Type in KMix into the box and it should start KMix again. This can be used to start pretty much any program fairly quickly, and not just KMix.

Hopefully, this does the trick. If it doesn't let me know.
Reply With Quote
  #9  
Old 01-09-2009, 08:36 PM
hawei hawei is offline
Junior Member
 
Join Date: Jan 2009
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: desktop window
This morning I've used the brutal method to get the original volume control icon back onto the panel (by removing the .kde* directories in $HOME).
With the System Monitor it becomes clear that the mixer associated with this original icon is in fact KMix.
So, KMix is working perfectly alright and the title of the mixer window is ``OSS Audio Mixer''.
It did certainly not work during the period of time when I had lost the original icon. This remains a mystery.
Adding the KMix-widget to the panel (as a second loudspeaker icon) does work fine as well now.
But I have still no answer to the question: How to get back the original volume icon, once i've lost it, in the soft way, i.e. with
the nice ``Add Widgets'' function ?
Reply With Quote
  #10  
Old 01-10-2009, 03:22 AM
Protagonist Protagonist is offline
Senior Member
 
Join Date: Jan 2007
Location: Central Oregon coast
Posts: 328
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to Protagonist
Default Re: desktop window
Originally Posted by hawei
This morning I've used the brutal method to get the original volume control icon back onto the panel (by removing the .kde* directories in $HOME).
With the System Monitor it becomes clear that the mixer associated with this original icon is in fact KMix.
So, KMix is working perfectly alright and the title of the mixer window is ``OSS Audio Mixer''.
It did certainly not work during the period of time when I had lost the original icon. This remains a mystery.
Adding the KMix-widget to the panel (as a second loudspeaker icon) does work fine as well now.
But I have still no answer to the question: How to get back the original volume icon, once i've lost it, in the soft way, i.e. with
the nice ``Add Widgets'' function ?
"
What happens if you open a terminal and type in "kdesu kmix"? That should just restart it and put the icon in the tray on the lower right. But, perhapss I am misunderstanding your problem. It would not be the first time. :-)
__________________
--------------------------------------
Computing can be fun again
format C:\
There are alternatives
--------------------------------------
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Window Effects adbge General Questions 3 02-25-2010 07:24 PM
desktop not appear small terminal window open in corner manjot Installing PC-BSD 3 09-08-2009 12:43 AM
X window gone (long rant) Lazy General Questions 12 08-17-2008 04:24 PM
window maker ranran General Questions 12 02-09-2007 04:48 PM
Window Maker? Vinegar Joe General Questions 1 07-05-2005 01:16 PM


All times are GMT. The time now is 03:58 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Copyright 2005-2010, The PC-BSD Project. PC-BSD and the PC-BSD logo are registered trademarks of iXsystems.
All other content is freely available for sharing under the terms of the Creative Commons Attribution License.