Reply
 
Thread Tools Display Modes
  #1  
Old 05-30-2012, 11:53 AM
bergschreck bergschreck is offline
Junior Member
 
Join Date: May 2012
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Default Howto turn FreeBSD into PC-BSD?
Since PC-BSD did not boot on my Toshiba Satellite Pro A200, I installed FreeBSD 9.0, that worked fine.

After installing X11, Gnome2 and Firefox, I see that Firefox is an old version (9.0).

How can I now install AppCafe to get all the PC-BSD packages (which contain Firefox 12)?
Reply With Quote
  #2  
Old 05-30-2012, 02:37 PM
kmoore134's Avatar
kmoore134 kmoore134 is offline
Administrator
 
Join Date: May 2005
Location: Knoxville, TN
Posts: 2,568
Thanks: 0
Thanked 162 Times in 127 Posts
Default Howto turn FreeBSD into PC-BSD?
This is probably the best way to convert your FreeBSD desktop to PC-BSD:

First, checkout our sources via subversion:

# svn co svn://svn.pcbsd.org/pcbsd/current current
# cd current/src-sh
# make install
# cd ../src-qt4
# make install

That will install all the necessary bits / tools for the AppCafe to
function.
__________________
----
Kris Moore
PC-BSD Founder
Reply With Quote
  #3  
Old 05-31-2012, 07:31 PM
FreeMWP FreeMWP is offline
Junior Member
 
Join Date: Nov 2010
Location: Copenhagen, Denmark
Posts: 24
Thanks: 1
Thanked 2 Times in 2 Posts
Default
Here is a more complete Howto:

Make sure you have these ports installed, using pkg_add or ports:

Code:
devel/subversion
devel/cmake
devel/cmake-gui
devel/gmake
devel/qt4-assistant
devel/qt4-assistant-adp
devel/qt4-designer
misc/qt4-doc
devel/qt4-libqtassistantclient
devel/qt4-linguist
devel/qt4-moc
devel/qmake4
devel/qt4-rcc
devel/qt4-qtsolutions-singleapplication

Then run:

Code:
# svn co svn://svn.pcbsd.org/pcbsd/current current
# cd current/src-sh
# make
# make install
# cd ../src-qt4/libpcbsd
# qmake-qt4 *.pro
# make
# make install
# cd ..
# qmake-qt4 *.pro
# make
# make install
Reply With Quote
  #4  
Old 06-13-2012, 09:53 AM
cabriofahrer cabriofahrer is offline
Junior Member
 
Join Date: Feb 2009
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Default
I have a working FreeBSD 9.0 - system and I did a "pkg_add -r libpcbsd" (from 9-stable-packages). It installed, but appcafe does not show up or exist as command.
A pkg_info gives me:

elvis69# pkg_info | grep libpcbsd
libpcbsd-8.0 PC-BSD Support Library

I assume it should be 9.0 instead of 8.0, but a newer version does not exist in ports either?
Reply With Quote
  #5  
Old 06-13-2012, 12:08 PM
Beanpole's Avatar
Beanpole Beanpole is offline
Senior Member
 
Join Date: May 2010
Posts: 2,396
Thanks: 8
Thanked 387 Times in 323 Posts
Default
@cabriofahrer
You will want to use the instructions that FreeMWP posted earlier rather than installing the libpcbsd port.
libpcbsd is simply a library of functions that our PC-BSD tools use, not the tools themselves. Because of this, you always want to make sure that you build both the current versions of libpcbsd and the tools at the same time so that there are no incompatibilities between them
__________________
~ Ken Moore ~
PC-BSD/iXsystems
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 05:03 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Copyright 2005-2010, The PC-BSD Project. PC-BSD and the PC-BSD logo are registered trademarks of iXsystems.
All other content is freely available for sharing under the terms of the Creative Commons Attribution License.