Reply
 
Thread Tools Display Modes
  #1  
Old 02-09-2012, 04:17 PM
Pedr Pedr is offline
Junior Member
 
Join Date: May 2010
Location: Carmarthenshire Wales
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default Three questions
Hello everyone at last I've been able to install PC-BSD now that Gnome etc. are
available. So far so good , but I've got a few problems .

Screenlock, how can I disable it ?

I am in the UK so , during installation I chose the British keyboard but PC-BSD keeps reverting to the USA keyboard, it seems to
have a mind of its own !

Lastly I have used App Cafe its great but what I need is non GUI sometimes.
For instance vi is installed and its GUI cousin. What I need are the runtimes etc. to give me full vim ; in ubuntu it is apt-get install ..... , how does one do that in PC-BSD ?
There are a couple of others eg. `dcfldd " which is a great improvement on `dd" , but that , unlike the vi parts I need is a separate item not an add on .


Many thanks in anticipatation,
Pedr.

Last edited by Pedr; 02-09-2012 at 05:14 PM. Reason: re-phrasing to eliminate ambiguity.
Reply With Quote
  #2  
Old 02-09-2012, 04:33 PM
bds bds is offline
Senior Member
 
Join Date: Oct 2009
Posts: 510
Thanks: 75
Thanked 50 Times in 46 Posts
Default
Screenlock -- i'm not using GNOME, so the names may be a little different. Try Launcher > "Preferences" > "Screensaver". sorry i can't remember - GNOME has a separate launcher for the systems stuff, and i can't think of the name.

i can't help with the time thing sorry

i have both gvim and vim installed:
> which vim ~
/usr/local/bin/vim
> vim --version
VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Dec 28 2011 05:51:16)
Included patches: 1-121

if you need to add a package/port, try this for starters:
1) http://www.freshports.org to get the name of your package
2) as root, pkg_add -r "package_name"; e.g.:
# pkg_add -r dcfldd

see the FreeBSD handbook for more info on adding packages: http://www.freebsd.org/doc/en_US.ISO...ges-using.html

also: be aware that sometimes added packages/ports aren't updated during a system update, so you could lose a few things. however, i think Kris & co. are working on something to correct that.
Reply With Quote
  #3  
Old 02-09-2012, 05:12 PM
Cobalt Cobalt is offline
Senior Member
 
Join Date: Apr 2009
Location: USA
Posts: 447
Thanks: 0
Thanked 10 Times in 10 Posts
Default
For the time problem, you could just offset the hours to your local time and keep the USA timezone. I don't think a time server will mess with the hours, so synchronizing should still work.
Reply With Quote
  #4  
Old 02-09-2012, 05:51 PM
Pedr Pedr is offline
Junior Member
 
Join Date: May 2010
Location: Carmarthenshire Wales
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default
Originally Posted by bds View Post
Screenlock -- i'm not using GNOME, so the names may be a little different. Try Launcher > "Preferences" > "Screensaver". sorry i can't remember - GNOME has a separate launcher for the systems stuff, and i can't think of the name.

i can't help with the time thing sorry

i have both gvim and vim installed:
> which vim ~
/usr/local/bin/vim
> vim --version
VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Dec 28 2011 05:51:16)
Included patches: 1-121

if you need to add a package/port, try this for starters:
1) http://www.freshports.org to get the name of your package
2) as root, pkg_add -r "package_name"; e.g.:
# pkg_add -r dcfldd

see the FreeBSD handbook for more info on adding packages: http://www.freebsd.org/doc/en_US.ISO...ges-using.html

also: be aware that sometimes added packages/ports aren't updated during a system update, so you could lose a few things. however, i think Kris & co. are working on something to correct that.
Thanks bds
Re. screenlock I had tried that but to no avail ; what I'm trying now is SETTING the screenlock to ON for 720 minutes , so if I leave the machine I won't have to enter my password every time !

Re. 2nd. question - bad phrasing on my part - have edited post .

Re. vim - good to know another user. By the way one command I use a lot is ` :Rexplore "
it is barely documented , it took a lot of finding , do you use it ?
Thanks for the links I'll have to look at them tomorrow .
Reply With Quote
  #5  
Old 02-09-2012, 05:57 PM
Pedr Pedr is offline
Junior Member
 
Join Date: May 2010
Location: Carmarthenshire Wales
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default
Originally Posted by Cobalt View Post
For the time problem, you could just offset the hours to your local time and keep the USA timezone. I don't think a time server will mess with the hours, so synchronizing should still work.
Cobalt.
Many thanks for your response ; my apologies for my gross ambiguities , I have edited the post.
Reply With Quote
  #6  
Old 02-09-2012, 06:20 PM
Cobalt Cobalt is offline
Senior Member
 
Join Date: Apr 2009
Location: USA
Posts: 447
Thanks: 0
Thanked 10 Times in 10 Posts
Default
You should be able to just turn off screen locking in the Screensaver Preferences. Here's a picture for reference. http://linuxlibrary.org/wp-content/u...u-10-10-18.jpg

I'm not sure how you got to the '720 minutes' setting. Maybe you found an advanced screensaver GUI? The Screensaver Preferences should be under System on your top GNOME panel. Your top panel *should* look like this: http://www.freebsd.org/gnome/images/ss224-2.png

i.e. Applications Places System

Hope that helps.

Last edited by Cobalt; 02-09-2012 at 06:31 PM.
Reply With Quote
  #7  
Old 02-09-2012, 06:25 PM
bds bds is offline
Senior Member
 
Join Date: Oct 2009
Posts: 510
Thanks: 75
Thanked 50 Times in 46 Posts
Default
Pedr --
thanks for the tip! that's pretty nifty -- i'm going to incorporate it
Reply With Quote
  #8  
Old 02-27-2012, 11:19 PM
sg1efc sg1efc is offline
Senior Member
 
Join Date: Jan 2012
Location: USA
Posts: 257
Thanks: 449
Thanked 8 Times in 8 Posts
Smile
I installed KDE and Gnome on two computers. KDE gave me the ability to increase the size of the mouse cursor easily (which Gnome does not seem able to do) for a friend of mine who can not see the standard sized mouse cursor at all. By the way, the KDE mouse cursor’s increased size carries over to Gnome, Yay, LoL.

We both prefer to use Gnome however and: I also had this strange problem with no matter what setting I tried in the Gnome &/or KDE screensavers (tried being logged in on KDE & Gnome as both Root and regular user while making screensaver setting changes), my screen would lock itself after only a minute of not being used.

My latest try at solving this that I think/hope worked, was to go into the PC-BSD Control Panel, click on Startup Applications and uncheck the box for Screensaver. So far, so good.

Thanks a lot everyone for your help, input and advice.
Reply With Quote
  #9  
Old 02-29-2012, 02:41 PM
sg1efc sg1efc is offline
Senior Member
 
Join Date: Jan 2012
Location: USA
Posts: 257
Thanks: 449
Thanked 8 Times in 8 Posts
Default
Originally Posted by sg1efc View Post
My latest try at solving this that I think/hope worked, was to go into the PC-BSD Control Panel, click on Startup Applications and uncheck the box for Screensaver.
Update:

Well somehow it has just started back up on its own, Lots of laughs. It started by just blanking the screen, which returned as soon as I press a key or moved the mouse. However I just went away for a few minutes, came back and it asked me to log back on. I think it's haunted. :evil: :razz:

Does anyone know which file I might be able to edit manually (and instructions how to do so, example, just delete a particular file or section...), to completely turn off all Gnome and KDE (in case it is the KDE screensaver that is also contributing to this problem) screen savers?

Thanks in advance.

Another update, LoL:
Just turned off and disabled Power Devil thanks to this thread:
http://forums.pcbsd.org/showthread.php?t=13760

Will see if that helps.

Last edited by sg1efc; 02-29-2012 at 02:58 PM.
Reply With Quote
  #10  
Old 03-02-2012, 01:40 AM
sg1efc sg1efc is offline
Senior Member
 
Join Date: Jan 2012
Location: USA
Posts: 257
Thanks: 449
Thanked 8 Times in 8 Posts
Default
Disabling Power Devil didn't seem to help either.

After further research, in the PC Control Panel, went into Configuration Editor, click on Desktop, then Gnome, then on "LOCKDOWN". Put a check-mark in the setting of "Disable_Lock_Screen". So far have not had to log back in when I've walked away from my computer for a while.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 01:27 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Copyright 2005-2010, The PC-BSD Project. PC-BSD and the PC-BSD logo are registered trademarks of iXsystems.
All other content is freely available for sharing under the terms of the Creative Commons Attribution License.