Reply
 
Thread Tools Display Modes
  #1  
Old 10-08-2013, 09:24 PM
starikarp starikarp is offline
Junior Member
 
Join Date: Feb 2013
Posts: 18
Thanks: 1
Thanked 1 Time in 1 Post
Default sound settings - CS4206
Hi!

I installed FreeBSD 10.0 on iMac. Why did I choose Current? Because on Release and PCBSD doesn't work Radeon HD 4850 GPU ("eDP" port).
Installation on iMac 11,1 was smooth and it works very good except sound.

I have:

Quote:
cat /dev/sndstat
Installed devices:
pcm0: <Cirrus Logic CS4206 (Internal Analog 4.0/2.0)> (play/rec) default
pcm1: <Cirrus Logic CS4206 (Rear Analog)> (play/rec)
pcm2: <Cirrus Logic CS4206 (Rear Digital)> (play/rec)
pcm3: <ATI R6xx (HDMI)> (play)
And sysctl dev.hdaa shows:

Quote:
sysctl dev.hdaa
dev.hdaa.0.%desc: Cirrus Logic CS4206 Audio Function Group
dev.hdaa.0.%driver: hdaa
dev.hdaa.0.%location: nid=1
dev.hdaa.0.%pnpinfo: type=0x01 subsystem=0x106b5100
dev.hdaa.0.%parent: hdacc0
dev.hdaa.0.nid2: audio output
Widget cap: 0x000d041d PWR STEREO
Association: 4 (0x0001)
OSS: pcm (pcm)
Stream cap: 0x00000003 FLOAT32 PCM
PCM cap: 0x001e07f0 16 20 24 32 bits, 32 44 48 88 96 176 192 KHz
Output amp: 0x80017f73 mute=1 step=127 size=1 offset=115 (-57/6dB)

dev.hdaa.0.nid3: audio output
Widget cap: 0x000d041d PWR STEREO
Association: 3 (0x0001)
OSS: pcm (pcm)
Stream cap: 0x00000003 FLOAT32 PCM
PCM cap: 0x001e07f0 16 20 24 32 bits, 32 44 48 88 96 176 192 KHz
Output amp: 0x80017f73 mute=1 step=127 size=1 offset=115 (-57/6dB)

dev.hdaa.0.nid4: audio output
Widget cap: 0x000d041d PWR STEREO
Association: 3 (0x0004)
OSS: pcm (pcm)
Stream cap: 0x00000003 FLOAT32 PCM
PCM cap: 0x001e07f0 16 20 24 32 bits, 32 44 48 88 96 176 192 KHz
Output amp: 0x80017f73 mute=1 step=127 size=1 offset=115 (-57/6dB)

dev.hdaa.0.nid5: audio input
Widget cap: 0x0018051b PWR STEREO
Association: 1 (0x0001)
Stream cap: 0x00000003 FLOAT32 PCM
PCM cap: 0x001e01f5 16 20 24 32 bits, 8 16 32 44 48 88 96 KHz
Input amp: 0x80033f33 mute=1 step=63 size=3 offset=51 (-51/12dB)
Connections: 2
+ <- nid=12 [pin: Line-in (Blue Jack)] (selected)
+ [DISABLED] <- nid=18 [pin: Line-out (None)] [DISABLED]

dev.hdaa.0.nid6: audio input
Widget cap: 0x0018051b PWR STEREO
Association: 0 (0x0001)
Stream cap: 0x00000003 FLOAT32 PCM
PCM cap: 0x001e01f5 16 20 24 32 bits, 8 16 32 44 48 88 96 KHz
Input amp: 0x80033f33 mute=1 step=63 size=3 offset=51 (-51/12dB)
Connections: 2
+ <- nid=13 [pin: Mic (Fixed)] (selected)
+ [DISABLED] <- nid=14 [pin: Line-out (None)] [DISABLED]

dev.hdaa.0.nid7: audio input
Widget cap: 0x00180791 PWR DIGITAL UNSOL STEREO
Association: 2 (0x0001)
Stream cap: 0x00000007 AC3 FLOAT32 PCM
PCM cap: 0x001e0570 16 20 24 32 bits, 32 44 48 96 192 KHz
Connections: 1
+ <- nid=15 [pin: SPDIF-in (White Jack)]

dev.hdaa.0.nid8: audio output
Widget cap: 0x00040611 PWR DIGITAL STEREO
Association: 5 (0x0001)
OSS: pcm (pcm)
Stream cap: 0x00000007 AC3 FLOAT32 PCM
PCM cap: 0x001e07f0 16 20 24 32 bits, 32 44 48 88 96 176 192 KHz

dev.hdaa.0.nid9: pin: Headphones (Green Jack)
Widget cap: 0x00410581 PWR UNSOL STEREO
Association: 4 (0x0001)
Pin cap: 0x0000001c PDC HP OUT
Pin config: 0x012b4050 as=5 seq=0 device=Headphones conn=Jack ctype=Combo loc=Rear color=Green misc=0
Pin control: 0x000000c0 HP OUT
Connections: 1
+ <- nid=2 [audio output]

dev.hdaa.0.nid9_config: 0x012b4050 as=5 seq=0 device=Headphones conn=Jack ctype=Combo loc=Rear color=Green misc=0
dev.hdaa.0.nid9_original: 0x012b4050 as=5 seq=0 device=Headphones conn=Jack ctype=Combo loc=Rear color=Green misc=0
dev.hdaa.0.nid10: pin: Speaker (Fixed)
Widget cap: 0x00410581 PWR UNSOL STEREO
Association: 3 (0x0001)
Pin cap: 0x00000054 PDC OUT BAL
Pin config: 0x90100140 as=4 seq=0 device=Speaker conn=Fixed ctype=Unknown loc=Internal color=Unknown misc=1
Pin control: 0x00000040 OUT
Connections: 1
+ <- nid=3 [audio output]

dev.hdaa.0.nid10_config: 0x90100140 as=4 seq=0 device=Speaker conn=Fixed ctype=Unknown loc=Internal color=Unknown misc=1
dev.hdaa.0.nid10_original: 0x90100140 as=4 seq=0 device=Speaker conn=Fixed ctype=Unknown loc=Internal color=Unknown misc=1
dev.hdaa.0.nid11: pin: Speaker (Fixed)
Widget cap: 0x00410101 STEREO
Association: 3 (0x0004)
Pin cap: 0x00000050 OUT BAL
Pin config: 0x90100142 as=4 seq=2 device=Speaker conn=Fixed ctype=Unknown loc=Internal color=Unknown misc=1
Pin control: 0x00000040 OUT
Connections: 1
+ <- nid=4 [audio output]

dev.hdaa.0.nid11_config: 0x90100142 as=4 seq=2 device=Speaker conn=Fixed ctype=Unknown loc=Internal color=Unknown misc=1
dev.hdaa.0.nid11_original: 0x90100142 as=4 seq=2 device=Speaker conn=Fixed ctype=Unknown loc=Internal color=Unknown misc=1
dev.hdaa.0.nid12: pin: Line-in (Blue Jack)
Widget cap: 0x0041048b PWR UNSOL STEREO
Association: 1 (0x0001)
OSS: line (line)
Pin cap: 0x00000024 PDC IN
Pin config: 0x018b3020 as=2 seq=0 device=Line-in conn=Jack ctype=Combo loc=Rear color=Blue misc=0
Pin control: 0x00000020 IN
Input amp: 0x00270300 mute=0 step=3 size=39 offset=0 (0/30dB)

dev.hdaa.0.nid12_config: 0x018b3020 as=2 seq=0 device=Line-in conn=Jack ctype=Combo loc=Rear color=Blue misc=0
dev.hdaa.0.nid12_original: 0x018b3020 as=2 seq=0 device=Line-in conn=Jack ctype=Combo loc=Rear color=Blue misc=0
dev.hdaa.0.nid13: pin: Mic (Fixed)
Widget cap: 0x0041048b PWR UNSOL STEREO
Association: 0 (0x0001)
OSS: monitor (monitor)
Pin cap: 0x00001764 PDC IN BAL VREF[ 50 80 GROUND HIZ ]
Pin config: 0x90a00110 as=1 seq=0 device=Mic conn=Fixed ctype=Unknown loc=Internal color=Unknown misc=1
Pin control: 0x00000024 IN VREFs
Input amp: 0x00270300 mute=0 step=3 size=39 offset=0 (0/30dB)

dev.hdaa.0.nid13_config: 0x90a00110 as=1 seq=0 device=Mic conn=Fixed ctype=Unknown loc=Internal color=Unknown misc=1
dev.hdaa.0.nid13_original: 0x90a00110 as=1 seq=0 device=Mic conn=Fixed ctype=Unknown loc=Internal color=Unknown misc=1
dev.hdaa.0.nid14: pin: Line-out (None) [DISABLED]
Widget cap: 0x0041000b STEREO
Pin cap: 0x00000020 IN
Pin config: 0x400000f0 as=15 seq=0 device=Line-out conn=None ctype=Unknown loc=0x00 color=Unknown misc=0
Pin control: 0x00000000
Input amp: 0x00270200 mute=0 step=2 size=39 offset=0 (0/20dB)

dev.hdaa.0.nid14_config: 0x400000f0 as=15 seq=0 device=Line-out conn=None ctype=Unknown loc=0x00 color=Unknown misc=0
dev.hdaa.0.nid14_original: 0x400000f0 as=15 seq=0 device=Line-out conn=None ctype=Unknown loc=0x00 color=Unknown misc=0
dev.hdaa.0.nid15: pin: SPDIF-in (White Jack)
Widget cap: 0x00410681 PWR DIGITAL UNSOL STEREO
Association: 2 (0x0001)
OSS: dig1 (dig1)
Pin cap: 0x00000024 PDC IN
Pin config: 0x01cbe030 as=3 seq=0 device=SPDIF-in conn=Jack ctype=Combo loc=Rear color=White misc=0
Pin control: 0x00000020 IN

dev.hdaa.0.nid15_config: 0x01cbe030 as=3 seq=0 device=SPDIF-in conn=Jack ctype=Combo loc=Rear color=White misc=0
dev.hdaa.0.nid15_original: 0x01cbe030 as=3 seq=0 device=SPDIF-in conn=Jack ctype=Combo loc=Rear color=White misc=0
dev.hdaa.0.nid16: pin: SPDIF-out (White Jack)
Widget cap: 0x00410301 DIGITAL STEREO
Association: 5 (0x0001)
Pin cap: 0x00000010 OUT
Pin config: 0x014be060 as=6 seq=0 device=SPDIF-out conn=Jack ctype=Combo loc=Rear color=White misc=0
Pin control: 0x00000040 OUT
Connections: 1
+ <- nid=8 [audio output]

dev.hdaa.0.nid16_config: 0x014be060 as=6 seq=0 device=SPDIF-out conn=Jack ctype=Combo loc=Rear color=White misc=0
dev.hdaa.0.nid16_original: 0x014be060 as=6 seq=0 device=SPDIF-out conn=Jack ctype=Combo loc=Rear color=White misc=0
dev.hdaa.0.nid17: vendor widget [DISABLED]
Widget cap: 0x00f00040 PROC

dev.hdaa.0.nid18: pin: Line-out (None) [DISABLED]
Widget cap: 0x0041000b STEREO
Pin cap: 0x00000020 IN
Pin config: 0x400000f0 as=15 seq=0 device=Line-out conn=None ctype=Unknown loc=0x00 color=Unknown misc=0
Pin control: 0x00000000
Input amp: 0x00270200 mute=0 step=2 size=39 offset=0 (0/20dB)

dev.hdaa.0.nid18_config: 0x400000f0 as=15 seq=0 device=Line-out conn=None ctype=Unknown loc=0x00 color=Unknown misc=0
dev.hdaa.0.nid18_original: 0x400000f0 as=15 seq=0 device=Line-out conn=None ctype=Unknown loc=0x00 color=Unknown misc=0
dev.hdaa.0.nid19: beep widget
Widget cap: 0x00700000
Association: -2 (0x0000)
OSS: speaker (speaker)

dev.hdaa.0.nid20: audio output [DISABLED]
Widget cap: 0x00040611 PWR DIGITAL STEREO
Stream cap: 0x00000007 AC3 FLOAT32 PCM
PCM cap: 0x001e07f0 16 20 24 32 bits, 32 44 48 88 96 176 192 KHz

dev.hdaa.0.nid21: pin: Line-out (None) [DISABLED]
Widget cap: 0x00410301 DIGITAL STEREO
Pin cap: 0x00000010 OUT
Pin config: 0x400000f0 as=15 seq=0 device=Line-out conn=None ctype=Unknown loc=0x00 color=Unknown misc=0
Pin control: 0x00000000
Connections: 1
+ <- nid=20 [audio output] [DISABLED]

dev.hdaa.0.nid21_config: 0x400000f0 as=15 seq=0 device=Line-out conn=None ctype=Unknown loc=0x00 color=Unknown misc=0
dev.hdaa.0.nid21_original: 0x400000f0 as=15 seq=0 device=Line-out conn=None ctype=Unknown loc=0x00 color=Unknown misc=0
dev.hdaa.0.config: forcestereo,ivref50,ivref80,ivref100,ivref,vref
dev.hdaa.0.gpi_state:
dev.hdaa.0.gpio_state: 0=disabled 1=disabled 2=disabled 3=output(0)
dev.hdaa.0.gpio_config: 0=keep 1=keep 2=keep 3=keep
dev.hdaa.0.gpo_state:
dev.hdaa.0.gpo_config:
dev.hdaa.0.reconfig: 0
dev.hdaa.1.%desc: ATI R6xx Audio Function Group
dev.hdaa.1.%driver: hdaa
dev.hdaa.1.%location: nid=1
dev.hdaa.1.%pnpinfo: type=0x01 subsystem=0x00aa0100
dev.hdaa.1.%parent: hdacc1
dev.hdaa.1.nid2: audio output
Widget cap: 0x00000201 DIGITAL STEREO
Association: 0 (0x0001)
OSS: pcm (pcm)
Stream cap: 0x00000001 PCM
PCM cap: 0x00020070 16 bits, 32 44 48 KHz

dev.hdaa.1.nid3: pin: Digital-out (Jack)
Widget cap: 0x00400381 DIGITAL UNSOL STEREO
Association: 0 (0x0001)
Pin cap: 0x00000094 PDC OUT HDMI
Pin config: 0x18560010 as=1 seq=0 device=Digital-out conn=Jack ctype=Digital loc=0x18 color=Unknown misc=0
Pin control: 0x00000040 OUT
Connections: 1
+ <- nid=2 [audio output]

dev.hdaa.1.nid3_config: 0x18560010 as=1 seq=0 device=Digital-out conn=Jack ctype=Digital loc=0x18 color=Unknown misc=0
dev.hdaa.1.nid3_original: 0x18560010 as=1 seq=0 device=Digital-out conn=Jack ctype=Digital loc=0x18 color=Unknown misc=0
dev.hdaa.1.config: forcestereo,ivref50,ivref80,ivref100,ivref,vref
dev.hdaa.1.gpi_state:
dev.hdaa.1.gpio_state:
dev.hdaa.1.gpio_config:
dev.hdaa.1.gpo_state:
dev.hdaa.1.gpo_config:
dev.hdaa.1.reconfig: 0
If I choose unit 1 as default than I get sound through headphones but speakers don't work and the same microphone.

Any idea how to save a problem, please?

Thank you.

Last edited by starikarp; 10-08-2013 at 11:55 PM.
Reply With Quote
  #2  
Old 12-01-2013, 02:35 AM
malco_2001 malco_2001 is offline
Senior Member
 
Join Date: Aug 2010
Posts: 136
Thanks: 9
Thanked 34 Times in 26 Posts
Default
This is what finally did the trick for me with an imac 13,1. I can't guarentee that it will work for you as my layout in /dev/sndstat is different. However I tried playing with device.hints and this got me nowhere. After running this command I immediately had sound. Perhaps playing around with this value before setting permantley may be of some use.

sysctl dev.hdaa.1.gpio_config=3=set

After I had the audio working I just added the following in /etc/sysctl.conf.

dev.hdaa.1.gpio_config=3=set

After setting this I still had to adjust my default device in the sound control panel in pc-controlpanel.

Last edited by malco_2001; 12-01-2013 at 07:03 PM.
Reply With Quote
  #3  
Old 01-02-2014, 04:54 PM
starikarp starikarp is offline
Junior Member
 
Join Date: Feb 2013
Posts: 18
Thanks: 1
Thanked 1 Time in 1 Post
Default
Originally Posted by malco_2001 View Post
This is what finally did the trick for me with an imac 13,1. I can't guarentee that it will work for you as my layout in /dev/sndstat is different. However I tried playing with device.hints and this got me nowhere. After running this command I immediately had sound. Perhaps playing around with this value before setting permantley may be of some use.

sysctl dev.hdaa.1.gpio_config=3=set

After I had the audio working I just added the following in /etc/sysctl.conf.

dev.hdaa.1.gpio_config=3=set

After setting this I still had to adjust my default device in the sound control panel in pc-controlpanel.
I have
hint.hdaa.1.gpio_config="3=set"
hint.hdaa.1.nid9.config="as=4 seq=15"

in /boot/device.hints and I have sound which is not so good. The second hint I put because I thought that headphones will work. Yes, it works but the same time as speakers. I cannot listen through one or other. How is your sound? Dou you have the same Cirrus too, please? Does your speaker/headphones work correct? Is sound the same as on iMac, please?

Thank you.
Reply With Quote
  #4  
Old 05-24-2014, 04:57 PM
malco_2001 malco_2001 is offline
Senior Member
 
Join Date: Aug 2010
Posts: 136
Thanks: 9
Thanked 34 Times in 26 Posts
Default
Sorry for the delay. I had to research my old post to remember how I did this. No the headphones output has never worked. Only the built in speakers.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 09:48 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Copyright 2005-2010, The PC-BSD Project. PC-BSD and the PC-BSD logo are registered trademarks of iXsystems.
All other content is freely available for sharing under the terms of the Creative Commons Attribution License.