Reply
 
Thread Tools Display Modes
  #1  
Old 01-08-2013, 09:49 AM
q/pa q/pa is offline
Senior Member
 
Join Date: Jan 2013
Location: Germany
Posts: 176
Thanks: 26
Thanked 19 Times in 16 Posts
Default drm:KMS errors / no system shutdown messages
Hello everybody,

I freshly installed PCBSD 9.1x64 on a Lenovo B560 laptop with nvidia 310M/Intel GMA HD graphics, optimus is deactivated in BIOS (I’m also dual-booting with windows7 via EasyBCD).

With optimus deactivated I’m using only the integrated Intel GMA HD graphics card and except for the fact that I don’t see any system shutdown messages (just black screen), graphics work ok. In the dmesg output are quite a few drm:KMS messages, maybe someone knows what to make of these…

(Though I installed the nvidia drivers the computer crashes when optimus is activated.)
If you need more info don’t hesitate to ask. Maybe someone can tell me how to post the whole dmesg output as an attachment.

Thanks
Christian

(Sorry, can't find a button labelled 'Manage Attachments'. So here it comes... I had to shorten it).

dmesg :
Code:
[delipu@pcbsd-5998] ~% dmesg
Copyright (c) 1992-2012 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 9.1-RELEASE #2: Tue Nov 27 03:45:16 UTC 2012
    root@darkstar:/usr/obj/pcbsd-build90/fbsd-source/9.1/sys/GENERIC amd64
CPU: Intel(R) Core(TM) i5 CPU       M 460  @ 2.53GHz (2527.05-MHz K8-class CPU)
  Origin = "GenuineIntel"  Id = 0x20655  Family = 6  Model = 25  Stepping = 5
...
vgapci0: <VGA-compatible display> port 0x1800-0x1807 mem 0xf2000000-0xf23fffff,0xd0000000-0xdfffffff irq 16 at device 2.0 on pci0
agp0: <Intel Ironlake (M) SVGA controller> on vgapci0
agp0: aperture size is 256M, detected 65532k stolen memory
...
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
...
ndis0: <Broadcom 802.11n Network Adapter> mem 0xf2500000-0xf2503fff irq 17 at device 0.0 on pci4
ndis0: NDIS API version: 5.1
drmn0: <Intel IronLake> on vgapci0
info: [drm] MSI enabled 1 message(s)
info: [drm] AGP at 0xd0000000 256MB
iicbus0: <Philips I2C bus> on iicbb0 addr 0xff
iic0: <I2C generic I/O> on iicbus0
iic1: <I2C generic I/O> on iicbus1
iicbus2: <Philips I2C bus> on iicbb1 addr 0xff
iic2: <I2C generic I/O> on iicbus2
iic3: <I2C generic I/O> on iicbus3
iicbus4: <Philips I2C bus> on iicbb2 addr 0xff
iic4: <I2C generic I/O> on iicbus4
iic5: <I2C generic I/O> on iicbus5
iicbus6: <Philips I2C bus> on iicbb3 addr 0xff
iic6: <I2C generic I/O> on iicbus6
iic7: <I2C generic I/O> on iicbus7
iicbus8: <Philips I2C bus> on iicbb4 addr 0xff
iic8: <I2C generic I/O> on iicbus8
iic9: <I2C generic I/O> on iicbus9
iicbus10: <Philips I2C bus> on iicbb5 addr 0xff
iic10: <I2C generic I/O> on iicbus10
iic11: <I2C generic I/O> on iicbus11
iicbus12: <Philips I2C bus> on iicbb6 addr 0xff
iic12: <I2C generic I/O> on iicbus12
iic13: <I2C generic I/O> on iicbus13
iicbus14: <Philips I2C bus> on iicbb7 addr 0xff
iic14: <I2C generic I/O> on iicbus14
iic15: <I2C generic I/O> on iicbus15
info: [drm] Supports vblank timestamp caching Rev 1 (10.10.2010).
info: [drm] Driver supports precise vblank timestamp query.
[drm:KMS:pid456:intel_detect_pch] Found Ibex Peak PCH
[drm:KMS:pid456:init_vbt_defaults] Set default to SSC at 100MHz
[drm:KMS:pid456:intel_parse_bios] Using VBT from OpRegion: $VBT IRONLAKE-MOBILEd
[drm:KMS:pid456:parse_general_features] BDB_GENERAL_FEATURES int_tv_support 0 int_crt_support 1 lvds_use_ssc 1 lvds_ssc_freq 120 display_clock_mode 0
[drm:KMS:pid456:parse_general_definitions] crt_ddc_bus_pin: 2
[drm:KMS:pid456:parse_lfp_panel_data] Found panel mode in BIOS VBT tables:
[drm:KMS:pid456:drm_mode_debug_printmodeline] Modeline 0:"1366x768" 0 69300 1366 1398 1422 1432 768 771 775 806 0x8 0xa
[drm:KMS:pid456:parse_sdvo_panel_data] Found SDVO panel mode in BIOS VBT tables:
[drm:KMS:pid456:drm_mode_debug_printmodeline] Modeline 0:"1600x1200" 0 162000 1600 1664 1856 2160 1200 1201 1204 1250 0x8 0xa
[drm:KMS:pid456:parse_sdvo_device_mapping] No SDVO device info is found in VBT
[drm:KMS:pid456:intel_modeset_init] 2 display pipes available.
[drm:KMS:pid456:intel_modeset_init] plane 0 init failed: -19
[drm:KMS:pid456:intel_modeset_init] plane 1 init failed: -19
[drm:KMS:pid456:intel_crt_init] pch crt adpa set to 0xf40018
[drm:KMS:pid456:intel_setup_outputs] HDMIB 1 PCH_DP_B 1 HDMIC 0 HDMID 0 PCH_DP_C 0 PCH_DP_D 0 LVDS 1
[drm:KMS:pid456:intel_sdvo_read_byte] i2c transfer returned 2
[drm:KMS:pid456:intel_sdvo_init] No SDVO device found on SDVOB
[drm:KMS:pid456:intel_dp_i2c_init] i2c_init DPDDC-B
[drm:KMS:pid456:intel_dp_aux_ch] dp_aux_ch timeout status 0x5145003f
[drm:KMS:pid456:intel_dp_i2c_aux_ch] aux_ch failed -60
[drm:KMS:pid456:intel_dp_aux_ch] dp_aux_ch timeout status 0x5145003f
[drm:KMS:pid456:intel_dp_i2c_aux_ch] aux_ch failed -60
[drm:KMS:pid456:ironlake_crtc_dpms] crtc 0/0 dpms off
[drm:KMS:pid456:intel_update_fbc] 
[drm:KMS:pid456:ironlake_crtc_dpms] crtc 1/1 dpms off
[drm:KMS:pid456:intel_update_fbc] 
[drm:KMS:pid456:ironlake_init_pch_refclk] has_panel 1 has_lvds 1 has_pch_edp 0 has_cpu_edp 0 has_ck505 0
drmn0: taking over the fictitious range 0xd0000000-0xe0000000
[drm:KMS:pid456:drm_helper_probe_single_connector_modes] [CONNECTOR:5:LVDS-1]
[drm:KMS:pid456:drm_helper_probe_single_connector_modes] [CONNECTOR:5:LVDS-1] probed modes :
[drm:KMS:pid456:drm_mode_debug_printmodeline] Modeline 19:"1366x768" 60 69300 1366 1398 1422 1432 768 771 775 806 0x48 0xa
[drm:KMS:pid456:drm_helper_probe_single_connector_modes] [CONNECTOR:11:VGA-1]
[drm:KMS:pid456:intel_ironlake_crt_detect_hotplug] trigger hotplug detect cycle: adpa=0xf40018
[drm:KMS:pid456:intel_ironlake_crt_detect_hotplug] ironlake hotplug adpa=0xf40018, result 0
[drm:KMS:pid456:intel_crt_detect] CRT not detected via hotplug
[drm:KMS:pid456:drm_helper_probe_single_connector_modes] [CONNECTOR:11:VGA-1] disconnected
[drm:KMS:pid456:drm_helper_probe_single_connector_modes] [CONNECTOR:14:HDMI-A-1]
[drm:KMS:pid456:drm_do_probe_ddc_edid] iicbus_transfer countdown 5 error 2
[drm:KMS:pid456:drm_do_probe_ddc_edid] iicbus_transfer countdown 4 error 2
[drm:KMS:pid456:drm_do_probe_ddc_edid] iicbus_transfer countdown 3 error 2
[drm:KMS:pid456:drm_do_probe_ddc_edid] iicbus_transfer countdown 2 error 2
[drm:KMS:pid456:drm_do_probe_ddc_edid] iicbus_transfer countdown 1 error 2
[drm:KMS:pid456:intel_hdmi_detect] [CONNECTOR:14:HDMI-A-1] got no edid, ddc port 5
[drm:KMS:pid456:drm_helper_probe_single_connector_modes] [CONNECTOR:14:HDMI-A-1] disconnected
[drm:KMS:pid456:drm_helper_probe_single_connector_modes] [CONNECTOR:17:DP-1]
[drm:KMS:pid456:intel_dp_aux_ch] dp_aux_ch timeout status 0x5145003f
[drm:KMS:pid456:intel_dp_aux_ch] dp_aux_ch timeout status 0x5145003f
[drm:KMS:pid456:intel_dp_aux_ch] dp_aux_ch timeout status 0x5145003f
[drm:KMS:pid456:drm_helper_probe_single_connector_modes] [CONNECTOR:17:DP-1] disconnected
[drm:KMS:pid456:drm_setup_crtcs] 
[drm:KMS:pid456:drm_enable_connectors] connector 5 enabled? yes
[drm:KMS:pid456:drm_enable_connectors] connector 11 enabled? no
[drm:KMS:pid456:drm_enable_connectors] connector 14 enabled? no
[drm:KMS:pid456:drm_enable_connectors] connector 17 enabled? no
[drm:KMS:pid456:drm_target_preferred] looking for cmdline mode on connector 5
[drm:KMS:pid456:drm_target_preferred] looking for preferred mode on connector 5
[drm:KMS:pid456:drm_target_preferred] found mode 1366x768
[drm:KMS:pid456:drm_setup_crtcs] picking CRTCs for 8192x8192 config
[drm:KMS:pid456:drm_setup_crtcs] desired mode 1366x768 set on crtc 3
[drm:KMS:pid456:intelfb_create] allocated 1366x768 fb: 0x00043000, bo 0xfffffe000b758800
info: [drm] Initialized i915 1.6.0 20080730
[drm:KMS:pid456:drm_mode_getresources] CRTC[2] CONNECTORS[4] ENCODERS[4]
[drm:KMS:pid456:drm_mode_getresources] [CRTC:3]
[drm:KMS:pid456:drm_mode_getresources] [CRTC:4]
[drm:KMS:pid456:drm_mode_getresources] [ENCODER:6:LVDS-6]
[drm:KMS:pid456:drm_mode_getresources] [ENCODER:12:DAC-12]
[drm:KMS:pid456:drm_mode_getresources] [ENCODER:13:TMDS-13]
[drm:KMS:pid456:drm_mode_getresources] [ENCODER:18:TMDS-18]
[drm:KMS:pid456:drm_mode_getresources] [CONNECTOR:5:LVDS-1]
[drm:KMS:pid456:drm_mode_getresources] [CONNECTOR:11:VGA-1]
[drm:KMS:pid456:drm_mode_getresources] [CONNECTOR:14:HDMI-A-1]
[drm:KMS:pid456:drm_mode_getresources] [CONNECTOR:17:DP-1]
[drm:KMS:pid456:drm_mode_getresources] CRTC[2] CONNECTORS[4] ENCODERS[4]
[drm:KMS:pid456:drm_mode_getconnector] [CONNECTOR:5:?]
[drm:KMS:pid456:drm_helper_probe_single_connector_modes] [CONNECTOR:5:LVDS-1]
[drm:KMS:pid456:drm_helper_probe_single_connector_modes] [CONNECTOR:5:LVDS-1] probed modes :
[drm:KMS:pid456:drm_mode_debug_printmodeline] Modeline 19:"1366x768" 60 69300 1366 1398 1422 1432 768 771 775 806 0x48 0xa
[drm:KMS:pid456:drm_mode_getconnector] [CONNECTOR:5:?]
[drm:KMS:pid456:drm_mode_getconnector] [CONNECTOR:11:?]
[drm:KMS:pid456:drm_helper_probe_single_connector_modes] [CONNECTOR:11:VGA-1]
[drm:KMS:pid456:intel_ironlake_crt_detect_hotplug] ironlake hotplug adpa=0xf40018, result 0
[drm:KMS:pid456:intel_crt_detect] CRT not detected via hotplug
[drm:KMS:pid456:drm_helper_probe_single_connector_modes] [CONNECTOR:11:VGA-1] disconnected
[drm:KMS:pid456:drm_mode_getconnector] [CONNECTOR:11:?]
[drm:KMS:pid456:drm_helper_probe_single_connector_modes] [CONNECTOR:11:VGA-1]
[drm:KMS:pid456:intel_ironlake_crt_detect_hotplug] ironlake hotplug adpa=0xf40018, result 0
[drm:KMS:pid456:intel_crt_detect] CRT not detected via hotplug
[drm:KMS:pid456:drm_helper_probe_single_connector_modes] [CONNECTOR:11:VGA-1] disconnected
[drm:KMS:pid456:drm_mode_getconnector] [CONNECTOR:14:?]
[drm:KMS:pid456:drm_helper_probe_single_connector_modes] [CONNECTOR:14:HDMI-A-1]
[drm:KMS:pid456:drm_do_probe_ddc_edid] iicbus_transfer countdown 5 error 2
[drm:KMS:pid456:drm_do_probe_ddc_edid] iicbus_transfer countdown 4 error 2
...
[drm:KMS:pid0:drm_do_probe_ddc_edid] iicbus_transfer countdown 5 error 2
[drm:KMS:pid0:drm_do_probe_ddc_edid] iicbus_transfer countdown 4 error 2
[drm:KMS:pid0:drm_do_probe_ddc_edid] iicbus_transfer countdown 3 error 2
[drm:KMS:pid0:drm_do_probe_ddc_edid] iicbus_transfer countdown 2 error 2
[drm:KMS:pid0:drm_do_probe_ddc_edid] iicbus_transfer countdown 1 error 2
[drm:KMS:pid0:intel_hdmi_detect] [CONNECTOR:14:HDMI-A-1] got no edid, ddc port 5
[drm:KMS:pid0:output_poll_execute] [CONNECTOR:14:HDMI-A-1] status updated from 2 to 2
[drm:KMS:pid0:intel_dp_aux_ch] dp_aux_ch timeout status 0x5145003f
[drm:KMS:pid0:intel_dp_aux_ch] dp_aux_ch timeout status 0x5145003f
[drm:KMS:pid0:intel_dp_aux_ch] dp_aux_ch timeout status 0x5145003f
[drm:KMS:pid0:output_poll_execute] [CONNECTOR:17:DP-1] status updated from 2 to 2
...
Reply With Quote
The Following User Says Thank You to q/pa For This Useful Post:
Cousk1982 (09-29-2013)
  #2  
Old 01-10-2013, 12:37 PM
q/pa q/pa is offline
Senior Member
 
Join Date: Jan 2013
Location: Germany
Posts: 176
Thanks: 26
Thanked 19 Times in 16 Posts
Default
maybe this is of help, too:

my xorg log file
XOrg2.txt
Reply With Quote
  #3  
Old 03-07-2013, 01:19 PM
Ordoban Ordoban is offline
Junior Member
 
Join Date: Mar 2013
Posts: 23
Thanks: 0
Thanked 3 Times in 3 Posts
Default
Maybe i have a related problem.

I cannot switch from gui-mode to textmode with <strg><alt><f1>.
If i try this the screen displayes a "crashed" graphic and freezes.
I can't switch back to gui-mode with <strg><alt><f9>.

q/pa, can you verify this on your system ?

I have tryed this on 3 different PC's with 3 different graphiccards.
Everywhere the same fault !
From 2 PC's i know switching to textmode was working on PcBSD 9.0.

Edit:
All 3 are Intel-Graphics. I tryed VESA-Mode and its working !

Last edited by Ordoban; 03-07-2013 at 02:51 PM.
Reply With Quote
  #4  
Old 03-07-2013, 05:46 PM
q/pa q/pa is offline
Senior Member
 
Join Date: Jan 2013
Location: Germany
Posts: 176
Thanks: 26
Thanked 19 Times in 16 Posts
Default
Hi Ordoban,

switching from gui-mode to textmode with <strg><alt><f1> results in a "crashed" graphic, too. But I can switch back with <strg><alt><f9>.
Reply With Quote
Reply

Tags
intel, kms

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 07:00 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Copyright 2005-2010, The PC-BSD Project. PC-BSD and the PC-BSD logo are registered trademarks of iXsystems.
All other content is freely available for sharing under the terms of the Creative Commons Attribution License.