Reply
 
Thread Tools Display Modes
  #1  
Old 02-04-2013, 03:32 PM
Georgios Georgios is offline
Junior Member
 
Join Date: Feb 2012
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default Problem with hidden network
I just installed PC-BSD 9.1 -it is really great job; my congratulations on that. Sadly, I have to report a yet remaining (because that has been there since version 8.0 (hubble)) problem/bug: it seems that the system does not handle well hidden wireless networks -as it was promised when PC-BSD 9.1 was released.

Now, my card is a Realtek, RTL8187B which uses urtw driver. Because I have used other *nix systems (like OpenIndiana) which use exactly the same driver, I conclude that the problem is in the hidden network utility and not in hardware.

The steps I have done (many times) are:
I press the button "Add hidden", then I enter the network name, I get the message "The security for this wifi access point could not be automatically determined. Please edit the profile to manually the proper security encryption", then I enter my WPA key, I save, the network manager (restarts), and... nothing happens... (i.e. no connection).
Again, I underline the fact that my hidden network works perfectly fine in other Unix system with the same driver. So, I guess, for some reason, even with the necessary data given, the connection can not be established.


Below, is the output of ifconfig:

Code:
 ~% ifconfig
msk0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=8010a<TXCSUM,VLAN_MTU,TSO4,LINKSTATE>
        ether 00:1e:68:b7:aa:72
        inet6 fe80::21e:68ff:feb7:aa72%msk0 prefixlen 64 scopeid 0x1 
        inet 192.168.1.64 netmask 0xffffff00 broadcast 192.168.1.255
        nd6 options=23<PERFORMNUD,ACCEPT_RTADV,AUTO_LINKLOCAL>
        media: Ethernet autoselect (100baseTX <full-duplex>)
        status: active
fwe0: flags=8902<BROADCAST,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=8<VLAN_MTU>
        ether 02:1b:24:23:cc:0b
        nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
        ch 1 dma -1
fwip0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
        lladdr 0.1b.24.0.1.23.cc.b.a.2.ff.fe.0.0.0.0
        nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
        options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>
        inet6 ::1 prefixlen 128 
        inet6 fe80::1%lo0 prefixlen 64 scopeid 0xa 
        inet 127.0.0.1 netmask 0xff000000 
        nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
urtw0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 2290
        ether 00:22:5f:04:1e:00
        nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
        media: IEEE 802.11 Wireless Ethernet autoselect mode 11g
        status: associated
wlan0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        ether 00:22:5f:04:1e:00
        inet6 fe80::222:5fff:fe04:1e00%wlan0 prefixlen 64 scopeid 0xc 
        nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
        media: IEEE 802.11 Wireless Ethernet autoselect (autoselect)
        status: no carrier
        ssid "" channel 11 (2462 MHz 11g)
        regdomain ETSI country GR authmode WPA1+WPA2/802.11i privacy OFF
        txpower 30 bmiss 7 scanvalid 450 bgscan bgscanintvl 300 bgscanidle 250
        roam:rssi 7 roam:rate 5 protmode CTS
Reply With Quote
  #2  
Old 02-04-2013, 08:25 PM
drulavigne drulavigne is offline
Administrator
 
Join Date: Nov 2009
Posts: 1,080
Thanks: 35
Thanked 48 Times in 47 Posts
Default
What happens when you click the Add Hidden button shown in http://wiki.pcbsd.org/index.php/File:Hidden1.png. Does it accept the name of the network and attempt to associate?
Reply With Quote
  #3  
Old 02-04-2013, 10:06 PM
Georgios Georgios is offline
Junior Member
 
Join Date: Feb 2012
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default
I quote from my initial post:

"The steps I have done (many times) are:
I press the button "Add hidden", then I enter the network name, I get the message "The security for this wifi access point could not be automatically determined. Please edit the profile to manually the proper security encryption", then I enter my WPA key, I save, the network manager (restarts), and... nothing happens... (i.e. no connection)."
Reply With Quote
  #4  
Old 02-05-2013, 01:28 PM
Beanpole's Avatar
Beanpole Beanpole is offline
Senior Member
 
Join Date: May 2010
Posts: 2,394
Thanks: 8
Thanked 386 Times in 322 Posts
Default
You said that you entered your WPA key, but did you manually configure that network to attempt to use the proper WPA encryption type? When you receive that warning, you should have to select the saved profile for your hidden network and click the "edit" button to show/set the security type. After you make sure that the network profile is setup properly, then hit apply to restart the network and see if it works.
__________________
~ Ken Moore ~
PC-BSD/iXsystems
Reply With Quote
  #5  
Old 02-05-2013, 04:11 PM
Georgios Georgios is offline
Junior Member
 
Join Date: Feb 2012
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default
Ι did all the simple steps. Simply, the manager doesn't work -since I have established successfully connection in various KDE-based *nices (line OpenIndiana and Linux distros).
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 06:57 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Copyright 2005-2010, The PC-BSD Project. PC-BSD and the PC-BSD logo are registered trademarks of iXsystems.
All other content is freely available for sharing under the terms of the Creative Commons Attribution License.