Reply
 
Thread Tools Display Modes
  #11  
Old 06-06-2012, 04:18 PM
IslandWolf IslandWolf is offline
Junior Member
 
Join Date: Mar 2011
Posts: 12
Thanks: 2
Thanked 0 Times in 0 Posts
Default Installing Extension Pack still fails
I have tried to install the VirtualBox Extension Pack, but I keep getting the following error:
Failed to locate the main module ('VBoxPuelMain').
Result Code: NS_ERROR_FAILURE (0x80004005)
Component: ExtPackManager
Interface: IExtPackManager {3295e6ce-b051-47b2-9514-2c588bfe7554}
PC-BSD 9.0 RELEASE 64

I want to run an MS Windows 7 Pro 64-bit machine in VB, and I need the ExtPak to be able to access my USB drives. I have uninstalled and reinstalled VB per your instructions above to no avail.

Last edited by IslandWolf; 06-06-2012 at 04:19 PM. Reason: changed STABLE to RELEASE, since that's what I'm actually using
Reply With Quote
  #12  
Old 06-09-2012, 05:21 PM
Peter2121 Peter2121 is offline
Senior Member
 
Join Date: Sep 2011
Posts: 164
Thanks: 16
Thanked 2 Times in 2 Posts
Default
IslandWolf, it seems that the VirtualBox Extension Pack does not work under FreeBSD. I've tried to install it but I had the same error. I found some messages in BSD forums where the gurus said it's impossible (Linux only binary).
Reply With Quote
  #13  
Old 06-21-2012, 11:18 AM
nemysis nemysis is offline
Senior Member
 
Join Date: Sep 2011
Posts: 219
Thanks: 5
Thanked 15 Times in 12 Posts
Smile
I have too problem with virtualbox-4.1.8-amd64.pbi

VirtualBox: supR3HardenedMainGetTrustedMain: dlopen("/usr/pbi/virtualbox-amd64/lib/virtualbox/VirtualBox.so",) failed: /usr/local/lib/qt4/libQtGui.so.4: Undefined symbol "_ZN20QEventDispatcherGlib16staticMetaObjectE"

Only FreeBSD Ports works with 4.1.8 but i wish to use PBI.

And not find on site

http://pbibuild64.pcbsd.org/

have downloaded from

http://mirror.hs-esslingen.de/pub/Mi...box-ose/9/x64/

but not works too.

Please rebuild PBI.

Thanks


Now works have missed FreeBSD Port devel/qt4-corelib.

Last edited by nemysis; 07-13-2012 at 09:13 PM. Reason: solved
Reply With Quote
  #14  
Old 12-18-2012, 07:25 PM
mcochris mcochris is offline
Junior Member
 
Join Date: Dec 2012
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default VirtualBox-4.1.22_01 PBI
VirtualBox-4.1.22_01 won't run on my AMD64 FreeBSD 9.0 PC. The error message is

Code:
VirtualBox: supR3HardenedMainGetTrustedMain: dlopen(
"/usr/pbi/virtualbox-amd64/lib/virtualbox/VirtualBox.so",) 
failed: Shared object "libQtCore.so.4" not found, 
required by "VirtualBox.so"

I installed devel/qt4-corelib 4.8.2 on my PC, reinstalled the PBI, but it did not fix the problem. "libQtCore.so.4" is in /usr/pbi/virtualbox-amd64/lib/qt4/

UPDATE: works if I run VirtualBox as root

Last edited by mcochris; 12-18-2012 at 07:33 PM. Reason: found work-around
Reply With Quote
  #15  
Old 12-18-2012, 08:03 PM
Abdul Abdul is offline
Senior Member
 
Join Date: Jan 2011
Posts: 333
Thanks: 19
Thanked 15 Times in 14 Posts
Default
When I run it here, it first asks me for root rights.
__________________
touch -- '-rf ~'
Reply With Quote
  #16  
Old 12-23-2012, 07:29 PM
maioral maioral is offline
Senior Member
 
Join Date: Nov 2012
Posts: 105
Thanks: 28
Thanked 4 Times in 4 Posts
Default
is it not suposed to ask root rights to run?
If so, that is very alarming...
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 09:33 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Copyright 2005-2010, The PC-BSD Project. PC-BSD and the PC-BSD logo are registered trademarks of iXsystems.
All other content is freely available for sharing under the terms of the Creative Commons Attribution License.