PC-BSD Forums

PC-BSD Forums (http://forums.pcbsd.org/index.php)
-   Usage Bug Reports (read-only) (http://forums.pcbsd.org/forumdisplay.php?f=21)
-   -   Opera 12.12 fails to load (http://forums.pcbsd.org/showthread.php?t=19190)

sunnyeveryday 01-28-2013 04:05 AM

Opera 12.12 fails to load
 
FreeBSD pcbsd-4667 9.1-RELEASE FreeBSD 9.1-RELEASE #2: Tue Nov 27 03:45:16 UTC 2012 root@darkstar:/usr/obj/pcbsd-build90/fbsd-source/9.1/sys/GENERIC amd64


Chromium, Firefox and Konqueror work fine.

Opera 12.12 launch icon bounces up and down for several seconds, then nothing.

/var/log/messages show this during the launch timeframe

Jan 28 00:02:25 pcbsd-4667 kernel: pid 2340 (opera), uid 1001: exited on signal 10

Beanpole 01-28-2013 11:49 AM

This sounds like the same error that was reported for Opera 12.11, the fix for that is as follows:
Quote:

20121128:
AFFECTS: Users of www/opera
AUTHOR: itetcu@FreeBSD.org

If you are running KDE and you are using KDE's File dialog toolkit, and if
your Opera crashes on start with a 'libpng error: incorrect data check'
you can work around it by setting 'Dialog Toolkit=4' in your
.opera/operaprefs.ini [File Selector] section.

Zagzigger 02-23-2013 12:36 AM

Clarification please
 
My ./opera/operaprefs.ini has:
==============================
Opera Preferences version 2.1
; Do not edit this file while Opera is running
; This file is stored in UTF-8 encoding

[User Prefs]
Home URL=http://blekko.com/pcbsd
Show Startup Dialog=0
Startup Type=2
Language Files Directory=
Preferences Version=6

[State]
Detected Country Code=US
Active Country Code=US
Active Region=us
=========================

And adding 'Dialog Toolkit=4' seems to have no effect.

I suspect I misunderstand something here; I hope someone can help.

Opera 12.14 from AppCafe.
Running on PSBSD 9.1 release amd64

Thanks

q/pa 02-23-2013 06:44 AM

Did you put it in the [File Selector] section?

Zagzigger 02-23-2013 08:54 AM

Thanks for the rapid reply.

>Did you put it in the [File Selector] section?

That's my problem - where is the [File Selector] section? -'cos as you can see from my .operaprefs.ini - it doesn't have one.

Apologies if I'm being particularly dense here.

Thanks,

q/pa 02-23-2013 11:07 AM

No problem. Simply add these lines to your *.operaprefs.ini :

[File Selector]
Dialog Toolkit=4

Zagzigger 02-23-2013 12:04 PM

Quote:

Originally Posted by q/pa (Post 104549)
No problem. Simply add these lines to your *.operaprefs.ini :

[File Selector]
Dialog Toolkit=4

Many thanks.

I nearly tried that earlier, but it seemed too simple.

Thanks again

sysfu 03-22-2013 11:17 PM

Would it be possible to build this fix into the Opera PBI? Still happens an fresh installs with Opera 12.14.

It will probably throw newb users for a loop, and is mildly annoying for a technical user.

sunnyeveryday 04-01-2013 06:02 PM

Back...been a long time but I just tried Opera again.

Yes, the solution fixed the issue.

[File Selector]
Dialog Toolkit=4


Shouldn't this be built-in to the package ?

Thanks again.

Mr.Bean 04-25-2013 07:51 PM

Where can I access to .operaprefs.ini???


All times are GMT. The time now is 02:43 PM.

Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.


Copyright 2005-2010, The PC-BSD Project. PC-BSD and the PC-BSD logo are registered trademarks of iXsystems.
All other content is freely available for sharing under the terms of the Creative Commons Attribution License.