PDA

View Full Version : Unable to mount USB stick


Doc
01-13-2008, 01:05 PM
Hi everyone. I've just installed the latest version of PC-BSD after lurking on these forums for the last year or so. Everything went well and in general the system seems to be working fine. The only problem I've encountered so far is that I'm unable to mount my usb stick.

I've tried inserting three different usb sticks and always get the same error message from dmesg | tail:

uhub1: device problem (SHORT_XFER), disabling port 4

All these sticks mount without a problem in Linux and Windows so I'm fairly sure they're not the problem. I don't know if it helps, but here's the spec of my system:

AMD 64 3800+ (single core), 3GB RAM, Nvidia 6600GT, 3xSATA hard drives, USB WACOM tablet (system seems to recognise this), PS2 mouse and keyboard, MSI K8 Neo4 Platinum motherboard (with latest bios).

Any suggestions?

Gerard
01-14-2008, 06:21 AM
If it's a large memory stick, try:

mount -t msdosfs -o large /dev/YOURDISK /mnt

Doc
01-14-2008, 07:56 AM
If it's a large memory stick, try:

mount -t msdosfs -o large /dev/YOURDISK /mnt

OK, but given the error message I'm not sure a device node has even been created. How can I check this (there's no clue in dmesg)? Also, it's a 4GB fat32 partition on the stick, so I would presume I need to use vfat rather than msdosfs?

Thanks for the help so far.

DragnLord
01-14-2008, 10:32 AM
OK, but given the error message I'm not sure a device node has even been created. How can I check this (there's no clue in dmesg)?
"ls /dev" will list all device nodes
Also, it's a 4GB fat32 partition on the stick, so I would presume I need to use vfat rather than msdosfs?
BSD is very efficient, "msdosfs" covers FAT32 filesystems.

Gerard
01-14-2008, 11:38 AM
If it's a large memory stick, try:

mount -t msdosfs -o large /dev/YOURDISK /mnt

OK, but given the error message I'm not sure a device node has even been created. How can I check this (there's no clue in dmesg)? Also, it's a 4GB fat32 partition on the stick, so I would presume I need to use vfat rather than msdosfs?

Thanks for the help so far.




mount -t msdosfs -o large /dev/YOURDISK /mnt

This is how I mount my external 200GB Fat32 drive

Doc
01-14-2008, 03:38 PM
OK. tried again and again I got this message:

uhub1: device problem (SHORT_XFER), disabling port 4

ls /dev returned:

%ls /dev
acd0 ata dsp0.0 fwmem0 net3 ptyp4 ttyv4
acpi atkbd0 dsp0.1 fwmem0.0 net4 random ttyv5
ad0 audio0.0 dsp0.2 geom.ctl net5 sndstat ttyv6
ad0s1 audio0.1 dsp0.3 io net6 stderr ttyv7
ad0s2 audio0.2 dsp0.4 kbd0 network stdin ttyv8
ad0s5 audio0.3 dsp0.5 kbd1 nfs4 stdout ttyv9
ad1 audio0.4 dspW0.0 kbdmux0 nfslock sysmouse ttyva
ad1s1 audio0.5 dspW0.1 klog null ttyd0 ttyvb
ad1s2 bpsm0 dspW0.2 kmem nvidia0 ttyd0.init ttyvc
ad1s5 cd0 dspW0.3 log nvidiactl ttyd0.lock ttyvd
ad2 cdrom dspW0.4 lpt0 pass0 ttyp0 ttyve
ad2s1 console dspW0.5 lpt0.ctl pci ttyp1 ttyvf
ad2s1a consolectl dspr0.1 md0 pf ttyp2 ums0
ad2s1b ctty dvd mdctl ppi0 ttyp3 urandom
ad2s1c cuad0 fd mem psm0 ttyp4 usb
ad2s2 cuad0.init fd0 mixer0 ptyp0 ttyv0 usb0
ad2s3 cuad0.lock fido net ptyp1 ttyv1 usb1
ad2s5 devctl fw0 net1 ptyp2 ttyv2 xpt0
apm devstat fw0.0 net2 ptyp3 ttyv3 zero

This is a corsair voyager usbstick, and I can't see anything that could be it.

DragnLord
01-15-2008, 04:31 AM
This may seem like an odd question, but it has to asked so as to not assume.
Have you tried all the USB ports on that computer?

Doc
01-15-2008, 06:07 AM
This may seem like an odd question, but it has to asked so as to not assume.
Have you tried all the USB ports on that computer?

Don't worrry, I'm an IT tech for a job so I've got used to checking the obvious first. So yes, all usb ports return the same type of error.

wmjodea
03-30-2008, 04:07 AM
Try mount -t msdosfs /dev/da0 /media or mount -t msdosfs /dev/da0s1. Sometimes da0 is used for usb memory sticks some sticks mount as da0s1. Configure you /etc/fstab file: /dev/da0 /media msdosfs rw,noauto 0 0 then to mount just type mount /dev/da0 (or /dev/da0s1).

Oko
03-30-2008, 07:07 AM
Try mount -t msdosfs /dev/da0 /media or mount -t msdosfs /dev/da0s1. Sometimes da0 is used for usb memory sticks some sticks mount as da0s1. Configure you /etc/fstab file: /dev/da0 /media msdosfs rw,noauto 0 0 then to mount just type mount /dev/da0 (or /dev/da0s1).


That is actually a good advice.
Go to su - mode and read dmesg.
Your USB stick should be seen by a SCSI driver da but it should be mounted as

mount -t msdosfs /dev/da0s1 /mnt


Auto mounting should work too but you will have to do little bit more configuration then just fstab. You will have to edit usbd.conf file as well.

pheet
03-30-2008, 10:29 PM
ls /dev returned:

%ls /dev
acd0 ata dsp0.0 fwmem0 net3 ptyp4 ttyv4
acpi atkbd0 dsp0.1 fwmem0.0 net4 random ttyv5
ad0 audio0.0 dsp0.2 geom.ctl net5 sndstat ttyv6
ad0s1 audio0.1 dsp0.3 io net6 stderr ttyv7
ad0s2 audio0.2 dsp0.4 kbd0 network stdin ttyv8
ad0s5 audio0.3 dsp0.5 kbd1 nfs4 stdout ttyv9
ad1 audio0.4 dspW0.0 kbdmux0 nfslock sysmouse ttyva
ad1s1 audio0.5 dspW0.1 klog null ttyd0 ttyvb
ad1s2 bpsm0 dspW0.2 kmem nvidia0 ttyd0.init ttyvc
ad1s5 cd0 dspW0.3 log nvidiactl ttyd0.lock ttyvd
ad2 cdrom dspW0.4 lpt0 pass0 ttyp0 ttyve
ad2s1 console dspW0.5 lpt0.ctl pci ttyp1 ttyvf
ad2s1a consolectl dspr0.1 md0 pf ttyp2 ums0
ad2s1b ctty dvd mdctl ppi0 ttyp3 urandom
ad2s1c cuad0 fd mem psm0 ttyp4 usb
ad2s2 cuad0.init fd0 mixer0 ptyp0 ttyv0 usb0
ad2s3 cuad0.lock fido net ptyp1 ttyv1 usb1
ad2s5 devctl fw0 net1 ptyp2 ttyv2 xpt0
apm devstat fw0.0 net2 ptyp3 ttyv3 zero

This is a corsair voyager usbstick, and I can't see anything that could be it.

I can't see a da device listed there, so the mount commands not going to work.


uhub1: device problem (SHORT_XFER), disabling port 4

That's a problem with the USB hub, not the USB stick itself.

Hmm, you've mentioned that the BIOS is upto date, have you searched in the BIOS for any USB options that might be applicable? :?

It's possible a motherboard incompatability problem.

Doc
03-31-2008, 03:29 AM
Sorry for the delay in replying. It seems that Freebsd has problems with Nforce4 usb controllers. This same problem happens with PC-BSD and DesktopBSD. I've tried compiling a kernel with the USB4BSD driver stack, which did at least allow the system to recognise that a usb stick was connected, but when tring to mount and browse the stick the system locked solid. So the upshot would seem to be that my motherboard isn't yet fully supported - which is a shame because everything else works well. Hopefully these will eventually be sorted out. Lets face it, nforce4 hardware is hardly cutting edge.