PDA

View Full Version : Turn Off Sound Driver


davebc15
01-08-2008, 04:42 PM
I have installed PC-BSD on an older machine (PII Dell OptiPlex) which is to be donated to a low-income school district. However, it will not boot since it cannot load the sound driver for the sound card (I keep getting an error message and it keeps trying after loading snd_driver). How would I turn off loading snd_driver upon boot-up?

Thanks!

Oko
01-08-2008, 05:22 PM
I have installed PC-BSD on an older machine (PII Dell OptiPlex) which is to be donated to a low-income school district. However, it will not boot since it cannot load the sound driver for the sound card (I keep getting an error message and it keeps trying after loading snd_driver). How would I turn off loading snd_driver upon boot-up?

Thanks!


The /boot/loader.conf should have the line like snd_driver_load="YES". Comment it and reboot. But if you can not do install becaouse of it or booting fails complitely that is more difficult problem. Try to boot the computer in the safe mode (do not ask me how to do that on PC-BSD I use Vanilla FreeBSD and that is trivial in Vanilla version).
then mount file system and try to edit /boot/loader.conf

davebc15
01-09-2008, 11:27 PM
Thanks OKO. I found where it detects the soundcard in /etc/rc.conf and changed the line:

snddetect_enable="YES" to snddetect_enable="NO"

it seems to have worked for my machine. Most of my experience is with vanilla FeeBSD as well, but I teach students with learning disabilities, so I figured that PC-BSD was a better candidate for them.

Thanks again!