PDA

View Full Version : intel GMA 950 drivers for pc bsd ?


bsdesigner
11-29-2007, 12:54 AM
Does anyone know Which and how to install the drivers for the intel gma 950 ?
Do I have to use the linux or suse linux ones?
Is there another that I must use?
OS independent driver?

I really want 1280 x 800 dpi like I had in Vista.

I feel this is another reason I cant get blender to work.

anyone please?

vermaden
11-29-2007, 05:26 AM
here: http://www.freshports.org/x11-drivers/xf86-video-intel

bsdesigner
11-29-2007, 11:52 AM
===> xf86-video-intel-2.1.0 depends on file: /usr/local/libdata/pkgconfig/xorg-server.pc - found
===> xf86-video-intel-2.1.0 depends on file: /usr/local/libdata/pkgconfig/xproto.pc - found
===> xf86-video-intel-2.1.0 depends on executable: pkg-config - found
===> Generating temporary packing list
===> Checking if x11-drivers/xf86-video-intel already installed
===> An older version of x11-drivers/xf86-video-intel is already installed (xf86-video-intel-2.1.1)
You may wish to ``make deinstall'' and install this port again
by ``make reinstall'' to upgrade it properly.
If you really wish to overwrite the old port of x11-drivers/xf86-video-intel
without deleting it first, set the variable "FORCE_PKG_REGISTER"
in your environment or the "make install" command line.
*** Error code 1

Stop in /usr/ports/x11-drivers/xf86-video-intel.
pcbsd#


This is the problem :oops:

TerryP
11-29-2007, 07:29 PM
You might try to upgrade it, the simplist way would probably be:

pkg_add -r portupgrade
rehash
portupgrade -rR xf86-video-intel

< go on coffee break >


Also, while BSD can run Linux *programs* through the Linux ABI it can not run Linux *drivers* because the drivers require a Linux Kernel and are not compatible with the FreeBSD Kernel.

So you need the FreeBSD driver ;-)

bsdesigner
11-30-2007, 01:12 AM
Thank you T

next problem :oops: :cry:

pcbsd# pkg_add -r portupgrade
Fetching ftp://ftp.freebsd.org/pub/FreeBSD/ports ... e/Latest/p (ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-6-stable/Latest/p)
ortupgrade.tbz... Done.
Fetching ftp://ftp.freebsd.org/pub/FreeBSD/ports ... e/All/ruby (ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-6-stable/All/ruby)
18-bdb-0.6.2.tbz... Done.
pkg_add: warning: package 'ruby18-bdb-0.6.2' requires 'ruby-1.8.6.111,1', but 'r
uby-1.8.6_2,1' is installed
pkg_add: warning: package 'portupgrade-2.3.1,2' requires 'ruby-1.8.6.111,1', but
'ruby-1.8.6_2,1' is installed
pkg_add: warning: package 'portupgrade-2.3.1,2' requires 'perl-5.8.8_1', but 'pe
rl-5.8.8' is installed

------------------------------------------------------------------------------
Fill ALT_PKGDEP section in pkgtools.conf file for portupgrade
be aware of alternative dependencies you use.
E.g.
ALT_PKGDEP = {
'www/apache13' => 'www/apache13-modssl',
'print/ghostscript-gnu' => 'print/ghostscript-gpl',
}

Note also, portupgrade knows nothing how to handle ports with different
suffixes (E.g. -nox11). So you should explicitly define variables
(E.g. WITHOUT_X11=yes) for the ports in /etc/make.conf or pkgtools.conf
(MAKE_ARGS section) files.
------------------------------------------------------------------------------

rehash
portupgrade -rR xf86-video-intelpcbsd# rehash
pcbsd# portupgrade -rR xf86-video-intel
[Updating the pkgdb <format:bdb_btree> in /var/db/pkg ... - 588 packages found (-17 +96) (...)............................................. .................................................. . done]
/usr/ports/INDEX-6.bz2 100% of 1129 kB 178 kBps
done
[Updating the portsdb <format:bdb_btree> in /usr/ports ... - 17746 port entries found .........1000.........2000.........3000.........40 00.........5000.........6000.........7000......... 8000.........9000.........10000.........11000..... ....12000.........13000.........14000.........1500 0.........16000.........17000....... ..... done]
** Port directory not found: x11/pixman
** No need to upgrade 'glib-2.14.2' (>= glib-2.12.13). (specify -f to force)
---> Skipping 'x11-drivers/xf86-video-intel' (xf86-video-intel-2.1.1) because a requisite package 'pixman-0.9.5_2' (x11/pixman) failed (specify -k to force)
** Listing the failed packages (*:skipped / !:failed)
! x11/pixman (pixman-0.9.5_2) (port directory error)
* x11-drivers/xf86-video-intel (xf86-video-intel-2.1.1)
---> Packages processed: 0 done, 86 ignored, 1 skipped and 1 failed
pcbsd#


what now?

TerryP
11-30-2007, 05:28 AM
looks to me like the ports index file thing (/usr/ports/INDEX* on my box) is out of date,


change directory into /usr/ports and fetch a new version as root; do a

cd /usr/ports
make fetchindex

note that it is one word, fetchindex - if you write 'fetch index' it will try to fetch *a lot* of crap... As my testing-typo's just found out lol.

If your ports tree is not fairly up to date with your local ports three, in my case the index is probably 2 weeks newer you might want to update your ports tree or build an index on your system (can take awhile) with running 'make index' rather then 'make fetchindex'

I don't think fetching an index rather then building won will do any harm if your ports tree is reasonably in sync with it, but I don't promise any thing.


Once the new index is ready, try doing the portupgrade process again, if it can't find x11/pixman, let us see the konsole output again.

TerryP.

jrc
07-15-2009, 02:33 AM
In case somebody stumbles across this thread like I did with the same problem, installing the latest intel driver out of the ports as above plus editing /etc/X11/xorg.conf to add the resolutions I want plus delete some line about 'Option "NoDDC" "yes"' did the trick. I think the most important bit was deleting the "NoDDC" thing.