PDA

View Full Version : High Definition Audio


xenonsoft
11-01-2006, 05:11 PM
http://forums.pcbsd.org/viewtopic.php?t ... tion+audio (http://forums.pcbsd.org/viewtopic.php?t=4615&highlight=high+definition+audio)

I have tried everything that was told here... but I have not any audio on my laptop :(

When I do a cat /dev/sndsat

FreeBSD Audio Driver (newpcm: 64bit)
Installed Devices:

What I am doing wrong? My "soundcard" is a REALTEK HDA (High Definition Audio) on a Intel Chipset.

Yours,

kenji
11-01-2006, 07:05 PM
Sorry for the dumb question, but did you reboot after making modifications to your /boot/loader.conf?

You may also use kldload to load the modules to test it out.
# kldload sound
# kldload snd_ich
And then try "cat /dev/sndstat"

xenonsoft
11-01-2006, 11:38 PM
Yes, I did it ;)

Well:


PCBSD# kldload sound
kldload: can't load sound: File exists



PCBSD# kldload snd_ich
kldload: can't load snd_ich: File exists



PCBSD# cat /dev/sndstat
FreeBSD Audio Driver (newpcm: 64bit)
Installed devices:


So... still no sound :twisted:

kenji
11-01-2006, 11:42 PM
did you un-mute the mixer? Open Kmix and make sure that it has sound enabled (no mute).

xenonsoft
11-02-2006, 09:54 AM
I can't unmute the mixer, because KMIX, for example says that there are not available mixers...

And actually, I am using this drivers I've found on FreeBSD lists:

http://lists.freebsd.org/pipermail/free ... 04864.html (http://lists.freebsd.org/pipermail/freebsd-multimedia/2006-September/004864.html)
http://people.freebsd.org/~ariff/HDA/kmod/

Yours,

xenonsoft
11-03-2006, 03:40 PM
Any idea?

kenji
11-03-2006, 03:53 PM
can you load the snd_hda.ko module?
# kldload snd_hda

I think that you may need to compile a custom kernel to get that to work. The snd_ich module should be part of the kernel already so it is better to use that module if it works for your hardware.

kenji
11-03-2006, 06:24 PM
can you load the snd_hda.ko module?
# kldload snd_hda

I think that you may need to compile a custom kernel to get that to work. The snd_ich module should be part of the kernel already so it is better to use that module if it works for your hardware.

antik
11-20-2006, 07:08 PM
can you load the snd_hda.ko module?
# kldload snd_hda

I think that you may need to compile a custom kernel to get that to work. The snd_ich module should be part of the kernel already so it is better to use that module if it works for your hardware.

From here (http://people.freebsd.org/~ariff/lowlatency/)you can download already compiled sound modules.

Tenchi-san
11-22-2006, 02:56 PM
this worked for me as well, mod should sticky it.

Kul
02-05-2007, 06:20 PM
[From here (http://people.freebsd.org/~ariff/lowlatency/)you can download already compiled sound modules.

I tried this, but I have done something wrong. After a repair the system is working, but I don't really understand how to install these modules.

xenonsoft
02-05-2007, 11:27 PM
Curious, I didn't realize of last answers. I will try tomorrow installing the drivers :). I have read the README (not very complete :P), but how do you have installed them?

Thanks!

Kul
02-07-2007, 12:04 PM
but how do you have installed them?

Here's what I did:

1) Download the files (sndkld_releng6_i386_lowlatency.tar.gz)
2) Unpack them, and make them overwrite the files in /boot/kernel
3) kldxref /boot/kernel
4) cp soundcard.h /usr/include/sys/
5) reboot.

It's probably not the right way, but I do get sound now :)
(I only have analog signal. Still searching for a way to use the S/PDIF out)

xenonsoft
02-07-2007, 09:23 PM
It works... PERFECTLY! :) :) :)

Thanks a lot. Now I am enjoying AMAROK and VLC (I don't like Kaffeine at all :x )

Yours,

Skywatcher
03-06-2007, 12:47 AM
Hi there,

I have just installed PC-BSD. I have the same soundcard and was having the same problem.
I followed the steps presented here, and the "no device" error did disappear.
However it now gives me an error on after KDE loads up saying "device is busy" and redirects sound to null, so... still no sound.

If I try to do a kdlunload snd_hda, it also gives me the message that it couldn't do it because the device is busy.

The Intel 82801F High Definition Audio Controller does appear on cat /dev/sndstat
But it's always "busy" so the system cannot access it.
Any ideas? :cry:

dracheflieger
03-06-2007, 01:13 AM
What does your kldstat return? ... maybe you have other sound drivers interfering?

Skywatcher
03-07-2007, 03:11 PM
Right you are.
It had all the sound drivers loaded (how do I prevent that from happening at boot?)

But the problem unfortunately persists.
When I unload the sound drivers it goes back to the error message of no device (as expected).

When I load only snd_hda it starts giving me back the "device busy" error again.
kldstat confirms that only snd_hda is loaded.
cat /dev/sndstat shows the High Definition Audio Controller properly installed

But.. I have no sound. Only the Device is Busy error -> redirecting output to null

If I go to the KDE Control Module -> Sound and Multimedia -> hardware, and try to make any change (auto detect, OSS, etc.) it will try to restart the sound system only to give me the Device Busy error again :cry:

Any help very much appreciated...

paolone
05-01-2007, 01:25 PM
2) Unpack them, and make them overwrite the files in /boot/kernel

:oops: I am a total newbie ... how to overwrite the files in /boot/kernel ?

Thanks,
Paolone

paolone
05-03-2007, 10:43 PM
please ... can someone help me ? This is my first experience with bsd ...

Thanks,
Paolone[/quote] :?:

Tricky
05-03-2007, 10:54 PM
I guess you have to be root for that.
Here's what you probably should do: (I'm just guessing the paths)

1) su
-> enter your root password
2) cd /boot/kernel
2) tar -xvzf /home/youruserwhodownloadedfile/Desktop/sndkld_releng6_i386_lowlatency.tar.gz .
3) kldxref .
4) cp soundcard.h /usr/include/sys/
5) reboot.

This is probably it.

paolone
05-04-2007, 05:09 PM
Thanks Tricky !!!
Now the audio works very well !!!!!!!!

Also... There is something I don't understand:

pcbsd-1278# cp soundcard.h /usr/include/sys/
cp: soundcard.h: No such file or directory

this is the message I have in Konsole before reboot

and Kmix don't show any mixer ...
and I can't play audio cd...

What I can do ?

Paolone

dracheflieger
05-04-2007, 08:31 PM
Thanks Tricky !!!
Now the audio works very well !!!!!!!!

Also... There is something I don't understand:

pcbsd-1278# cp soundcard.h /usr/include/sys/
cp: soundcard.h: No such file or directory

this is the message I have in Konsole before reboot

and Kmix don't show any mixer ...
and I can't play audio cd...

What I can do ?

Paolone

You either have to be in the directory of the soundcard.h when you perform the cp or you have to give it a full path to where it is.

cp /usr/myusername/unzippedfolder/soundcard.h /usr/include/sys

paolone
05-04-2007, 09:13 PM
Thanks to you,DracheFlieger
I follow your istruction and finish the installation,but my 2 problems remains.
Can someone help me ?

Paolone

dracheflieger
05-04-2007, 10:05 PM
That may fix the mixer...if not, try KMenu -> Run Program -> kmix

paolone
05-06-2007, 09:10 PM
That may fix the mixer...if not, try KMenu -> Run Program -> kmix

Tanx but...nothing happen ...

Paolone

Tricky
05-06-2007, 11:05 PM
For the kmix, if kmix opens but doesn't show controls then you should try settings -> sound and multimedia -> sound system.
For the audio cd, do you have you cd-drive connected to your soundcard by a small cable? If not you probably need it, else try to specify cd-path on settings -> sound and multimedia -> audio cd, but that's probably not the case, it should be on the missing cable.

paolone
05-07-2007, 03:55 PM
[quote="Tricky"]For the kmix, if kmix opens but doesn't show controls then you should try settings -> sound and multimedia -> sound system.

I have do it but nothing happen... I have 5 choice but nothing happen...

For the audio cd, (cut)

Excuse me ,I have no say I use a laptop Compaq nx 6310
:oops:

Any idea ?

Paolone

OKComputer
05-08-2007, 11:49 AM
Also... There is something I don't understand:
pcbsd-1278# cp soundcard.h /usr/include/sys/
cp: soundcard.h: No such file or directory


1. download soundcard.h (http://people.freebsd.org/~ariff/lowlatency/soundcard.h) and save it to the desktop.
2. open terminal
cp /usr/home/YOUR_LOGIN_NAME/Desktop/soundcard.h /usr/include/sys

Gerhard
07-26-2007, 02:04 PM
I guess you have to be root for that.
Here's what you probably should do: (I'm just guessing the paths)

1) su
-> enter your root password
2) cd /boot/kernel
2) tar -xvzf /home/youruserwhodownloadedfile/Desktop/sndkld_releng6_i386_lowlatency.tar.gz .
3) kldxref .
4) cp soundcard.h /usr/include/sys/
5) reboot.

This is probably it.

funktioniert nicht !!!

ich hab zwar die Datei auf den Desktop runtergeladen, aber wenn ich es entpacken will kommt andauernd die Meldung, dfie Datei sei nicht vorhanden, was natürlich blödsinn ist.

Gerhard
07-26-2007, 02:05 PM
Also... There is something I don't understand:
pcbsd-1278# cp soundcard.h /usr/include/sys/
cp: soundcard.h: No such file or directory


1. download soundcard.h (http://people.freebsd.org/~ariff/lowlatency/soundcard.h) and save it to the desktop.
2. open terminal
cp /usr/home/YOUR_LOGIN_NAME/Desktop/soundcard.h /usr/include/sys

funktioniert auch nicht, Datei nicht vorhanden !!!

rta0043
07-26-2007, 08:36 PM
Also... There is something I don't understand:
pcbsd-1278# cp soundcard.h /usr/include/sys/
cp: soundcard.h: No such file or directory


1. download soundcard.h (http://people.freebsd.org/~ariff/lowlatency/soundcard.h) and save it to the desktop.
2. open terminal
cp /usr/home/YOUR_LOGIN_NAME/Desktop/soundcard.h /usr/include/sys

funktioniert auch nicht, Datei nicht vorhanden !!!

You input the cp command exactly as stated? Then i have a question for you:

What's your username under PC-BSD?