PDA

View Full Version : Problems playing audio CD's and DVD's


impossiblescissors
12-03-2011, 08:33 PM
Hello,

I'm test-driving PC-BSD 9 RC2 (LXDE) and installed VLC, UMPlayer and Xine from AppCafe. The players work fine with media files on my PC, but I'm having big problems trying to get them to read directly from my DVD drive. After reading the VLC forums I've tried running chmod on /dev/cdrom and on /dev/cd1 and /dev/cd0 but it still gives me errors or just refuses to play when I try to select my CD to play.

Right now I have two DVD burners on my system--one PATA, one SATA. PATA is the drive I'm trying to use to play CD's (it's an old motherboard that can't boot from the SATA DVD burner.) The PATA drive shows up as /dev/cd1 in PCManFM. VLC looks like it wants to call it /dev/acd0 or /dev/acd1.

Another thing I considered is whether I'm missing libdvdcss. Where would I be able to look into this?

Thanks in advance.

wakajawaqa
01-18-2012, 12:55 AM
This looks like an old post, but to find out if you have libdvdcss installed run "pkg_info | grep libdvdcss" in a terminal. It should come with a standard PCBSD installation.

Is everything working with the final release?

I can't play CD's or DVD's with vlc mplayer xmms or cdcontrol, etc.

I can hear the drive spin the disc, and see the contents via nautilus (I'm using XFCE on PCBSD 9.0), but the media won't play.

martinsson
01-18-2012, 05:42 PM
Just wanted to add to this one, I have the same issue, I can copy the contents of the audio cd to a folder and open the items from there, but i can not open disc directly from vlc.

pkg_info | grep libdvdcss :
libdvdcss-1.2.10_1 Portable abstraction library for DVD decryption

I get this error message in vlc :
Your input can't be opened:
VLC is unable to open the MRL 'cdda:///dev/acd0'. Check the log for details.

So there it is.

I'm otherweise very happy with this excellent OS, PC-BSD 9 64bit, the final release, using XFCE as DE on a ASrock 330HT mini computer.

My guess is that the location specified in vlc is not correct (but the again I'm only a amateur user)

Any help on how (or if?) this can be resolved would be great:)

kmoore134
01-18-2012, 06:05 PM
One problem is that /dev/acd0 doesn't exist anymore, can you change that
to /dev/cd0?

wakajawaqa
01-18-2012, 08:08 PM
Pointing VLC to /dev/cd0 does not work. On the GUI, it cycles through all the track names very quickly but doesn't play anything. When run from a terminal, it gives a huge amount of output, all of it very similar. This is a sample:

[0x802416970] cdda access error: Could not set block size
[0x802416970] cdda access error: cannot read sector 11750

There is nothing wrong with the drive. This machine dual boots Arch Linux and VLC works fine with the same discs (audio CDs and DVDs) from the Linux side.

Is there any other information I can provide that would be of use?

The rest of the OS is working beautifully, by the way. I love the new control panel!

martinsson
01-19-2012, 07:36 PM
same here so +1 on that I'm afraid, I'll try google :)

wort
01-20-2012, 08:13 AM
Hello. I am having the same problems as the other posters. I can't play any audio CD's or DVD's. I can see the files in the file manager but cannot play them with any of the multimedia players. The file libdvdcss is installed. So I am puzzled. I am using PC-BSD 9.0 amd 64 bit. Am I supposed to be able to play the discs out of the box or do I have to configure something? Or is this a bug that will be fixed in a forthcoming update? Any help would be appreciate. I am trying to migrate from 9 years on Linux but I have a few issues to resolve in my PC-BSD install. Thanks

UPDATE: I was able to get the dvd's to play by installing Kaffeine media player from ports via command line. Kaffeine plays the dvd's but not the other players. Still have the issue with playing cd's. Still cannot play any audio cds. Anyone have any ideas?

I believe I need to install: win32-codecs to play cds. I am having problems getting the file:

Sat Jan 21 23:04:33 2] Installing in /usr/ports/multimedia/win32-codecs:
===> win32-codecs-20110131,1 is only for i386, while you are running amd64.
*** Error code 1

Stop in /usr/ports/multimedia/win32-codecs.

I guess I need the one for amd64 but looks like it's not available.

Anyone have any suggestions?

Thanks

wakajawaqa
01-20-2012, 06:39 PM
You shouldn't have to configure anything, it's supposed to work out of the box. I've been trying for a couple days in my spare time but still haven't been able to play a CD.If anyone else comes up with a possible solution, please share!

P.S. I mentioned not being able to play a DVD earlier, after trying again today I can say that DVD's WILL play on my system. I'm not sure what was going on the other day. So, sorry for the unnecessary whining earlier... CD's really don't work though, and consistently give the error output mentioned above.

wort
01-21-2012, 10:41 PM
I believe you need to install: win32-codecs to play cds .

wakajawaqa
01-21-2012, 11:13 PM
wort - What command did you use? pkg_add -r ? win32-codecs is in ports, see www.freebsd.org/ports or www.freshports.org. For directions on how to use ports see http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/ports.html but I would definitely not recommend doing much with ports if you haven't read up considerably on FreeBSD first, pbi's are the way to go. As such, I don't think win32-codecs is what we're looking for...

wort
01-22-2012, 05:53 AM
wort - What command did you use? pkg_add -r ? win32-codecs is in ports, see www.freebsd.org/ports or www.freshports.org. For directions on how to use ports see http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/ports.html but I would definitely not recommend doing much with ports if you haven't read up considerably on FreeBSD first, pbi's are the way to go. As such, I don't think win32-codecs is what we're looking for...

Yes I used the command "pkg_add -r win32-codecs" but package cannot be found. According to the BPM ports manager my system doesn't have win32-codecs installed. I am having problems getting the file:

-----------------------------------------------------------------------------------------------------
nova@pcbsd-2320] /home/nova# pkg_add -r win32-codecs
Error: Unable to get ftp://ftp.freebsd.org/pub/FreeBSD/ports/amd64/packages-9.0-release/Latest/win32-codecs.tbz: File unavailable (e.g., file not found, no access)
pkg_add: unable to fetch 'ftp://ftp.freebsd.org/pub/FreeBSD/ports/amd64/packages-9.0-release/Latest/win32-codecs.tbz' by URL
[nova@pcbsd-2320] /home/nova#

-------------------------------------------------------------------------
Sat Jan 21 23:04:33 2] Installing in /usr/ports/multimedia/win32-codecs:
===> win32-codecs-20110131,1 is only for i386, while you are running amd64.
*** Error code 1

Stop in /usr/ports/multimedia/win32-codecs.
-------------------------------------------

I guess I need the one for amd64 but looks like it's not available.

Anyone have any suggestions?

Thanks

naiyadorzy
01-24-2012, 09:45 AM
i will go with the wort...there is a need to install: win32-codecs to play cds your cds will rock...

Pain Arch of Foot (http://www.everythingforyourfeet.com)

joe75
01-24-2012, 02:06 PM
I think the problem with playing audio CDs could be that the players have not been adjusted to the new CAM-interface introduced with FreeBSD 9.0.

paolo52
02-08-2012, 01:01 PM
Sorry for my english. I had trouble with PC-BSD 8.2 playing audio CD. I worked it out with VLC and xmms. After upgrade to 9 Isotope, no audio CD :confused:
Now I can play it only with KsCD and it's working fine. But I had to switch off into System settings --> Multimedia --> Cd audio!
I changed the devfs.conf too, adding:

perm /dev/xpt0 0666
perm /dev/pass0 0666
perm /dev/pass1 0666
perm /dev/pass2 0666

after the output of command line 'camcontrol devlist' was:
<ASUS DRW-24B3ST 1.00> at scbus3 target 1 lun 0 (pass1,cd0)
(about my optical drive)

I hope this help someone :cool: