PDA

View Full Version : Music CDs do not play


toddlongfellow
09-21-2009, 03:10 PM
Greetings!

I seemed to have run across an odd problem. When I put a commercially made music CD in the drive, nothing happens. I fired up K3B and did a "media info" and it shows as an audio CD. However, it does not seem to mount. I've downloaded and installed a couple of music CD players from the PBI library, but nothing happens.

I have verified that sound card and speakers are working. I hear a couple of system sounds, like when I empty the recycle bin. I also went into the System Settings and clicked the Test button in the multimedia applet and the test music plays nicely. The "Backend" tab show XINE as the application.

As I am writing this, I have tried a couple of data CDs, and they also do not seem to mount, yet this is the same drive that I installed PC-BSD 7.1.1 from. I've also burned a couple of CDs. Is this some kind of a weird drive problem, or am I missing some step?

Thanks!
~todd

Cobalt
09-21-2009, 05:54 PM
A small box should pop up in the lower left-hand corner of your screen. Click the CD in the box and open it with the file manager. If it doesn't, logging out and logging in again or a reboot should fix the problem.

toddlongfellow
09-22-2009, 10:35 AM
I just tried rebooting. Sadly, that made no difference either. The drive is a DVD reader/CD writer combo drive, and it and the rest of the computer are about 4 years old. And now that I am thinking about it, I remember that when I first burned a CD using K3B and ask it to verify the burn, it did not re-read the CD. I am beginning to think that this is a hardware problem. I'll try swapping out the drive and see if that makes any difference.

toddlongfellow
09-22-2009, 12:41 PM
Okay, I swapped out the DVD/CDRW drive with a straight CD-ROM player. Double-checked the cabling and jumper setting. The drive is the only IDE device and is set as master, and is plugged into the only IDE port (hard drive is SATA).

Results: PC-BSD does not recognize a music CD but does recognize a data CD. K3B does see a music CD as an audio CD as before. I have tried a couple of different music CDs.

As a side-note - part of the problem with the original drive may have been that its jumper setting was cable select instead of master.

More information about the machine. It is an Acer (model: AcerPowerFG) running at 2.93 ghz with an Intel P4, with 1 gb ram. It has a reasonably fresh install of PC-BSD 7.1.1 fully updated. No other OSs on the single 80 gb SATA hard drive. The m/b is a model 915GV-M3 with all the peripherals integrated. The machine is about 4 years old and was recently given to me, so I have no idea of any previous history.

I also checked through all the BIOS settings. BIOS is American Megatrends, and released 02/08/2006. Most all the various drive settings are set to Auto.

I also note that when I boot up the machine with an audio CD in it, the boot up dialog sees the CD. I have also noted that when the machine shuts down that ACD0 seems to have some illegal requests posted to the terminal screen. The PC-BSD install is using the standard kernal. Despite trying to use scroll lock, the boot up info scrolls off the screen too fast to ketch much of the info. A note to developers: Don't disable the keyboard scroll lock during boot up or shutdown!!

Is there any other PC-BSD configuration settings I should check?

Thanks!

toddlongfellow
09-22-2009, 01:43 PM
Additional - While waiting for a reply, I decided to change out the drive one more time. No difference. K3B sees and recognizes the audio cds, and I can rip them or whatever. My installation of PC-BSD just does not seem to be able to recognize that an audio cd has been inserted and mount it so it can be played with an audio player. Data cds work just fine.

Any additional help on this problem is greatly appreciated.

~todd

TerryP
09-22-2009, 04:54 PM
A few years ago, it was consensus among those in the know, that systems lacking a certain cable between CD-ROM and sound card, have trouble playing back audio cd.

I however don't listen to CDs, so can't speak for it lol.

Cobalt
09-22-2009, 06:54 PM
I've also tried playing a disc with the command cdcontrol -f /dev/acd0 play 1 with no luck. I guess you'll need to rip them to hear 'em. All of my music is in MP3 format. I've been meaning to convert it to OGG to save on space. I'll get to it... someday.

toddlongfellow
09-23-2009, 10:35 AM
hmmm...I agree. However, in my case that mysterious little cable is present and connected properly. The real problem seems to be that whatever PC-BSD widget that is supposed to fire up when a music cd is inserted is not waking up. So, I am not getting far enough into the process to even test if I am getting sound through that little cable. Thanks for mentioning it though, every suggestion helps to get to the resolution.


A few years ago, it was consensus among those in the know, that systems lacking a certain cable between CD-ROM and sound card, have trouble playing back audio cd.

I however don't listen to CDs, so can't speak for it lol.

toddlongfellow
09-23-2009, 10:38 AM
Cobalt, I particularly appreciate your suggestions and comments. Based upon what you are saying here, the problem may not be my machine.

I've also tried playing a disc with the command cdcontrol -f /dev/acd0 play 1 with no luck. I guess you'll need to rip them to hear 'em. All of my music is in MP3 format. I've been meaning to convert it to OGG to save on space. I'll get to it... someday.

Cobalt
09-23-2009, 11:25 PM
Well, I've checked in the FreeBSD handbook and it says that you need an 'audio output cable' or something like that for correct playback. I'm don't have one in my machine. It's basically a thin gray cable with flat, 3/4 inch black ends. It plugs into your motherboard and into your optical drive. Not sure if it'll be picked up by VLC/KMPlayer etc., but the cdcontrol program should work. You could ask for one of the cables at a PC repair store, I suppose.

toddlongfellow
09-24-2009, 10:10 AM
Thanks, Cobalt. I made sure that I had one installed when I swapped out the drive. It runs from the audio output on the back of the drive to a connector in the audio section on my motherboard. The cable fits your description exactly, so I am assuming that must be the audio cable mentioned in the documentation.

I've been going through the various posts in the archive here at the Forum, and the results are rather inconclusive. Some of the posts seem to indicate that playing audio cds is just not an option yet with PC-BSD. While other posts seem to indicate the opposite - most of these posts had to do with earlier versions.

In going into the System Settings dialog there are some settings for music cds, and I did find one setting there to be incorrect. By default it sets the device to cdrom, and I read in one of the posts that it should be set to acd0 or cd0. I've tried both of those settings, but I do not get any kind of indication like the little popup window that there is anything in the drive like it does when I put in a data cd; that seems to work perfectly.

Oddly enough, in reading the info on the FreeBSD site about all the features, it talks about ripping audio cds and playing video dvds, but it never actually says that it can "play" audio cds.

Someone here must surely know whether or not PC-BSD can play music cds. If it can't then someday maybe that feature will be added, and if it can then I need to find out what my system problem is. I am fairly certain that the hardware is connected correctly and functioning correctly. If PC-BSD is capable of playing music cds then I must have a configuration setting(s) that is incorrect.

I appreciate all your help. Thanks!

Well, I've checked in the FreeBSD handbook and it says that you need an 'audio output cable' or something like that for correct playback. I'm don't have one in my machine. It's basically a thin gray cable with flat, 3/4 inch black ends. It plugs into your motherboard and into your optical drive. Not sure if it'll be picked up by VLC/KMPlayer etc., but the cdcontrol program should work. You could ask for one of the cables at a PC repair store, I suppose.

bekins
12-15-2009, 09:15 AM
After inserting an audio CD in the drive, try opening up a terminal (you don't need to log in as root) and type in the command

cdcontrol

then type in the command

play

You can also type a "?" for a full list of commands. Let me know if that was what you were looking for.

thomasz
12-17-2009, 12:49 AM
nice forum.... valuable info.... thx... :P

toddlongfellow
12-18-2009, 12:59 PM
bekins! Yes, that works! Thank you very much.

By the way, a little update on the original problem. A couple of weeks ago, I decided to reinstall PCBSD on my 64 bit machine. It is a custom box using an ASUS A8N-E m/b and a 64 bit AMD processor. I did a complete fresh install of the 64 bit version and then made sure the system was fully updated. The music CD problem persists.

However, as noted at the beginning of this post - clearly PCBSD is capable of playing music CDs. As for the original problem, the fact that I've had the same results on more than one machine as well as the changing of drives mentioned in earlier posts, I have to lean towards some sort of bug in the PCBSD system code.

Thanks again, bekins, for your very helpful response.

My best to everyone during this holiday season, and my best wishes to all of here in the PCBSD forums in the coming new year.

~todd

After inserting an audio CD in the drive, try opening up a terminal (you don't need to log in as root) and type in the command

cdcontrol

then type in the command

play

You can also type a "?" for a full list of commands. Let me know if that was what you were looking for.

ArnoldTritcher
01-26-2010, 03:36 PM
After inserting an audio CD in the drive, try opening up a terminal (you don't need to log in as root) and type in the command

cdcontrol

then type in the command

play

You can also type a "?" for a full list of commands. Let me know if that was what you were looking for.

Bekins that worked for me too so thanks. CDs are pretty outdated now so I'm going to convert everything into mp3 format. Only reason I haven't done it sooner is because I have hundreds of cd's lol. Anyway thanks again.

Extenze (http://extenzexposed.com/)